Author Topic: Avast NDIS Miniport Firewall Driver  (Read 3362 times)

0 Members and 1 Guest are viewing this topic.

Offline millisent81

  • Newbie
  • *
  • Posts: 3
Avast NDIS Miniport Firewall Driver
« on: July 08, 2013, 01:31:27 PM »
Help please!!! I am new to this page and desperately need help with my Windows 7 Lenovo laptop please. The Device Centre is saying the Avast NDIS Firewall Miniport is disabled and I am not able to enable it or update the driver. I am concerned I have a worm or something loading spam onto my new computer. When I go into the Device Manager and try to update the driver software my computer says "windows was unable to install avast Firewall NDIS Filter miniport on my computer". It refers me to the manufacturer who of course can't help because they do not support avast.
Can someone please help me in simple terms how to fix this?!? It is a brand new computer!!! Thank you.

Offline Pondus

  • Avast Überevangelist
  • Maybe Bot
  • *****
  • Posts: 26306
Re: Avast NDIS Miniport Firewall Driver
« Reply #1 on: July 08, 2013, 01:39:44 PM »
Quote
I am concerned I have a worm or something loading spam onto my new computer.
if so, follow the logs to assist in cleaning malware guide at top in the viruses and worms forum section
Chief Wiggum: Uh, no, you got the wrong number. This is 9-1…2.


Offline UserA789

  • Sr. Member
  • ****
  • Posts: 298
  • ...gone hut'n!
    • Final Level Radio
Re: Avast NDIS Miniport Firewall Driver
« Reply #2 on: October 24, 2013, 04:03:38 PM »
Was going to start a new topic but found this one.

Im having issues with the same driver in my Device Manager.  I noticed today after trying to install Windows Update (http://support.microsoft.com/kb/2862330) and it kept failing.  I opened my Device Manager to see that the Avast NDIS Filter Miniport Driver was not running. None of the scenarios meet the criteria for the update error; included in the notepad below.

Here are the details of the driver as to why its not running:  "Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)"

I just had TwinHeadedEagle go through the reports in finding malware on my system and he reported it clean here:  http://forum.avast.com/index.php?topic=137691.msg1006742#msg1006742

Any ideas on why the driver is disabled?  Do they have a new Avast Cleaner; maybe the one I had didn't clean the old Avast out when I updated.

EDIT:  Forgot attachment, spelling, detail
« Last Edit: October 24, 2013, 06:47:36 PM by UserA789 »

Offline UserA789

  • Sr. Member
  • ****
  • Posts: 298
  • ...gone hut'n!
    • Final Level Radio
Re: Avast NDIS Miniport Firewall Driver
« Reply #3 on: October 24, 2013, 06:46:17 PM »
I have not attempted ANY fix as of yet.  I am awaiting a response.  I did not try to update via Device Manager, unlike the OP.

Does it matter it cannot start?  Can I manually start the driver/service?

Should I simply try to re-install Avast! using the new "avastclear.exe" tool (http://files.avast.com/iavs9x/avastclear.exe)?

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 71416
  • No support PMs thanks
Re: Avast NDIS Miniport Firewall Driver
« Reply #4 on: November 03, 2013, 08:33:44 PM »
I suggest that anyone following this topic check out the latest avast version 9.0.2007 and see if this has resolved this.

- avast! 2014 (9.0.2007) general information, features, etc. http://forum.avast.com/index.php?topic=138753.0. There amongst other issues listed, * Firewall fixes, so I don't know if this would come under that heading.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2015 10.2.2215 R2/ Outpost Firewall Pro9.1/ Firefox 36.0.4, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.4/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline tommytinkroom

  • Full Member
  • ***
  • Posts: 155
  • The Dirty Boys
Re: Avast NDIS Miniport Firewall Driver
« Reply #5 on: November 03, 2013, 09:26:26 PM »
I had exactly the same thing with avast miniport
Showing a yellow exclamation symbol on three entries.
I was told on a previous thread to use Avast clean tool
then before installing the latest Avast version go into
device manager and uninstall all Avast miniport entries
Then install the latest Avast version.
I  followed the above instructions and my Avast IS is working
fine.Please note the avast miniport entries will not be there,
Apparently this is normal and the miniport only show when
there is an error.



Widows 7 Home Premium SP1 64bit/i5 intel processor/8gb Ram/640 harddrive/Graphics intel HD3000/