Author Topic: Problems shutting down  (Read 5505 times)

0 Members and 1 Guest are viewing this topic.

Offline kokomayla

  • Newbie
  • *
  • Posts: 1
Problems shutting down
« on: May 06, 2005, 04:22:15 PM »
Hi all...

I'm running windows 98se and I recently had to reformat the hard drive.  Before that I was running Avast before with no problems, but now I am getting shutdown issue where avast is making crash reports saying it does not have read access to the specified range of memory.  I have kept all of my Avast crash reports...some are empty.  Here is a snip-it of one of them...

Fault source
------------
C:\PROGRAM FILES\ALWIL SOFTWARE\AVAST4\ASHSERV.EXE caused an Access Violation at location 1005b2f0 Reading from location 1005b2f0.

-----------
Crash place
-----------


   don't have read access to the specified range of memory

----------------
Register content
----------------
EAX=000046AF EBX=0A07FE26 ECX=DD385E60 EDX=0001D3A4 ESI=0A07FE66 EDI=BFC00000
EIP=1005B2F0 ESP=0A07FDD0 EBP=0A07FE0C IOPL=0         NV UP EI PL ZR NA PO NC
CS=0167  SS=016F  DS=016F  ES=016F  FS=46B7  GS=0000             FLG=00010246

SymInitialize: 126
----------
Call stack
----------
AddrPC     AddrReturn AddrFrame  AddrStack  Params
1005B2F0   1005B2F0   0A07FE0C   0A07FDD0   BFC03C6E   00000000   00000001   0A07FE2E
1005B2F0
1005B2F0   B2F00003   0A07FE6C   0A07FDD0   6D2A1005   8EDC17AF   0001468F   16B70000
1005B2F0
B2F00003   FFFFFFFF   000D8E92   0A07FDD0   FFFFFFFF   FFFFFFFF   FFFFFFFF   FFFFFFFF
B2F00003
FFFFFFFF   70040000   FFFFFFFF   0A07FDD0   CB001600   70046507   70046500   00FF5400
FFFFFFFF

There is much more included in these reports...i wasn't sure if it was all needed.  When I try to shut down, I also get a small window in the left hand side which says XPCOM:EventReceiver is waiting to shut down...wait 20 seconds or shut down.  When I click the shutdown option it goes away, then comes back.    After about 5 times, I get other errors appearing with the avast email error report behind them.

Anybody have any ideas as to what's going on?? 
Thanks,
kokomayla

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Problems shutting down
« Reply #1 on: May 06, 2005, 08:36:38 PM »
This is an old 'problem', reported a lot, a lot of users' guesses but never completely solved.
It comes back from time to time in Windows 98 and XP...
Maybe somebody from Alwil could comment this...  :-[
The best things in life are free.

Offline Starfighter

  • Sr. Member
  • ****
  • Posts: 309
  • They only let me use pencils, not pens!
Re: Problems shutting down
« Reply #2 on: May 07, 2005, 10:54:39 AM »
I also had avast! shutdown problems with Win98SE (and FE for that matter too).
However, I solved it by adding the line:

GracefulRpcShutdown=1

in the avast4.ini file (put the line under the AAVM section)

the avast4.ini file is located in
C:\Program Files\Alwil Software\Avast4\DATA

Make sure you also have the Win98SE shutdown patch installed (available on the windows update site).


I use avast! because it's the best.

Offline Skram0

  • Jr. Member
  • **
  • Posts: 26
Re: Problems shutting down
« Reply #3 on: May 08, 2005, 10:09:25 AM »
I've seen this same problem too, on multiple computers.

One recent, about a week ago, was an eMachines 2GHz system with XP Home installed. I had uninstalled McAfee since it was already past its "free" working year. After installing version 4.6.652, I'd shutdown the computer and I'd get that Access Violation error box. I've seen it more than once on the same system. And the system hadn't been on too long for each boot, since I was updating the system, removing adware, and installing anti-ad programs.

I just hope since I had given the computer back to the original owner he doesn't call me back with questions about the the shutdown issue.

Offline hpoehrli

  • Jr. Member
  • **
  • Posts: 35
  • PrivatPilot, SW-Amateur
Re: Problems shutting down
« Reply #4 on: May 08, 2005, 10:11:08 AM »
Welcome to the club, kokomayla

this is unfortunately a old, a very old mistery, and there are several threads to this in the forum, maybe you have a look at
http://forum.avast.com/index.php?topic=11945.0

Contrary to statements in the message before, this problem also exists in W2K, and the line for "graceful shut down" did not help in W2K. Actually, nothing of all the various advices has remedied the situation. In my case, after ending work I let the system rest for maybe 10 seconds, and when I think that it is now truly idle, I shut it down. But still, maybe every 3rd or fourth time the message appears...

I'm still waiting for a solution
Hanspeter
Laptop Compaq Armada 1700 P2 300MHz 292MByte
W2K SP4, AvastPro V4, Avast home V5, Kerio 4,  Firefox, WLAN-Broadband-Cable;
Laptop ASUS Eee 1000, XP:
Laptop Toshiba Tecra A8, XP, VMWare

Offline Skram0

  • Jr. Member
  • **
  • Posts: 26
Re: Problems shutting down
« Reply #5 on: May 08, 2005, 10:27:48 AM »
After posting my previous message, I've seen that thread you had just posted. It is a problem with ashServ.exe that I've seen. I don't think I've ever seen it on my main computer though, as stated, it comes and goes. I wonder if Alwil was ever able to recreate the problem? If not, I wonder if they could use a disc image of the computer I've seen the issue, or maybe it is really a hardware based problem.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11765
    • AVAST Software
Re: Problems shutting down
« Reply #6 on: May 09, 2005, 05:16:19 PM »
I'm afraid the info in the first post is not very useful - there's no (address of any) avast! module mentioned in the data.