Author Topic: Auto-update does not work with proxy  (Read 4594 times)

0 Members and 1 Guest are viewing this topic.

Offline xash

  • Newbie
  • *
  • Posts: 16
Auto-update does not work with proxy
« on: September 10, 2013, 06:24:21 AM »
Hi,

I'm using Avast since a couple days ago and from the very first day I had some major problems with the update. In another topic we discussed about the update problem and finally I got it fixed by using a proxy.

  • Manual update IS working
  • Auto-update at startup or when the laptop is turned on (waking up after sleep) IS NOT working

Please note that for some weird reasons, neither the direct connection nor IE Settings work and as we discussed about it in another topic, I realized that the only way to get to the update server is through proxy.

If I remove the proxy, I get the connection error and it fails to update. But through proxy, the manual update works flawlessly. However, I see the "Connection not established" when I set the proxy.

Streaming updates: Enabled
Connection: Connection not established
Last update received: ---


I also tried it with dial-up and/or permanent connection settings checked, but the auto-update at startup doesn't work at all! I read some other topics about auto-update problem with proxy settings but I didn't find any solution to this annoying problem.

Vaio Laptop
Windows 7 Home Premium 64-bit
Windows Firewall
Avast 8.0.1497
Malwarebytes Anti-Malware 1.75.0.1300


P.S. Basic troubleshooting is done. Uninstall tools, clean install and repair is done already.

Thanks in advance
« Last Edit: September 10, 2013, 06:36:00 AM by xash »

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: Auto-update does not work with proxy
« Reply #1 on: September 10, 2013, 06:53:32 AM »
hi xash,

Check you other thread here:  http://forum.avast.com/index.php?topic=134206.msg986412#msg986412

[EDIT:]  To clarify how an automatic vps update occurs, one must start a cold boot (system off and not running at all; sleep or hibernate is not a complete system shutdown, but is a state of suspended animation for your system) to get avast! to automatically check for the newest vps available.

If you are running avast! free, then the vps check interval is 240 minutes by default while the system is up and running.  Free version does not allow a lower time interval setting to be set, but paid versions do allow the user to have avast! check more frequently.  Mine is set to check @ 60 minute intervals.  As you have found out, a manual check can be done at any time.

However, free or paid, all streaming updates come in at the same time for everyone, thus everyone gets the same current up-to-date protection.
« Last Edit: September 10, 2013, 07:07:44 AM by mchain »
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline xash

  • Newbie
  • *
  • Posts: 16
Re: Auto-update does not work with proxy
« Reply #2 on: September 10, 2013, 09:01:53 AM »
Thank you so much, mchain. Since my other topic was about the connection error and it's now fixed by using a proxy, I prefer to use this one so that if someone else encounters the same problem (which I believe there are others with the same problem), find this topic easier by searching the web.

Although I've already installed all MS runtime libraries (such as VC++ redist packs, MSXML updates and .NET frameworks) and updated them all by Windows Update, I downloaded and installed the file you've mentioned but WU didn't find any new update even after restart. 9.0.30729.6161 is in the Programs and Features list as you can see in the following screenshot:
http://i42.tinypic.com/skylj8.jpg

Speaking of automatic VPS updates, I always shut my laptop down every night. So I presume I have to get the auto-update check every morning...

P.S. Either I'm lucky or Avast has improved the free version as I can change the interval too. But as I said before, it seems that VPS check interval will be interrupted when the system goes to sleep. (I changed it to 60 as you suggested)

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: Auto-update does not work with proxy
« Reply #3 on: September 10, 2013, 09:51:28 AM »
You're welcome.

So you did not have version 9.0.30729.6161 installed?  As that is the one avast! needs.  And it is the only one on my system; prefer the less clutter the better.  Just a personal preference.

Not saying to remove other C + + libraries, you may very well need them all.  I just only run/install what I need, no less.
...Speaking of automatic VPS updates, I always shut my laptop down every night. So I presume I have to get the auto-update check every morning...

P.S. Either I'm lucky or Avast has improved the free version as I can change the interval too. But as I said before, it seems that VPS check interval will be interrupted when the system goes to sleep. (I changed it to 60 as you suggested)
There have been numerous times when the next day's vps has not arrived for that day when I checked or booted from a cold start.  The more important things are the streaming automatic updates; this is something that was not available until version 7 arrived, and version 8 extends that capability. 

Sometimes there is only one or no vps updates for a given day.  In that case, that would depend on whether the bad boys are behaving or not.

Experience exactly the same vps issue when resuming from hibernate; sometimes takes 120 minutes for it to kick in.  Even then, there may be no new vps update available, so it will then show an update attempt with no change in status.
« Last Edit: September 10, 2013, 10:08:04 AM by mchain »
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline xash

  • Newbie
  • *
  • Posts: 16
Re: Auto-update does not work with proxy
« Reply #4 on: September 10, 2013, 10:24:40 AM »
So you did not have version 9.0.30729.6161 installed?  As that is the one avast! needs.  And it is the only one on my system; prefer the less clutter the better.  Just a personal preference.
I had it already installed (as shown by the installed date in the attached screenshot) but I just installed what you suggested to make sure nothing is missing.

There have been numerous times when the next day's vps has not arrived for that day when I checked or booted from a cold start.  The more important things are the streaming automatic updates; this is something that was not available until version 7 arrived, and version 8 extends that capability.
Just like yesterday, when I turned on my laptop today I didn't get any update even after half an hour (no need to mention that it was a cold boot). But when I checked for updates manually, I got the update right away and the release time was for 8 hours before I turn it on.

btw, as mentioned in my first post, it says "Connection not established". This problem will be fixed if I set the connection type to either direct or system settings. And since I won't get updates (even the manual update fails) if I disable the proxy, I can't fix this problem.

The main question is how to fix the streaming automatic update while using proxy?
« Last Edit: September 10, 2013, 05:59:24 PM by xash »