Author Topic: Performance/Stability Issue  (Read 3719 times)

0 Members and 1 Guest are viewing this topic.

Offline travisrich

  • Newbie
  • *
  • Posts: 5
Performance/Stability Issue
« on: October 16, 2013, 10:47:06 PM »
I'm using the latest version of the installer and SQL Express.  I have about 2000 clients connected to the server until it crashes and it always crashes.  I've rebuilt the server using Windows 2008 instead of 2012, which did seem to net me some additional stability, but the problem remains.  Is 2000 too many clients for SQL express?  I've tried to tune SQL express by assigning additional memory but not much improvement, except I can run a report before crashing. 

Offline travisrich

  • Newbie
  • *
  • Posts: 5
Re: Performance/Stability Issue
« Reply #1 on: October 17, 2013, 03:00:37 AM »
I'm referring to avast! Endpoint Protection Suite with Enterprise Administration Console.  I've tried different operating systems, allocating more memory to the VM, reserving memory for SQL, but each time I have performance problems that seem to cause the console to crash.  Is anyone else running 2000'ish clients on SQL express?

Offline travisrich

  • Newbie
  • *
  • Posts: 5
Re: Performance/Stability Issue
« Reply #2 on: October 18, 2013, 08:27:59 PM »
[2013/10/18 13:06:21.186,1620] No properties dialog is available...
Last message repeated 2023 time(s)
[2013/10/18 13:13:00.518,3364] Unable to send idle message, error 0x000005B4...
Last message repeated 45 time(s)
[2013/10/18 14:22:50.228,1620] Nothing to do...
Last message repeated 1 time(s)
[2013/10/18 14:23:07.400,1620] Server returned 0x000005B4 error code on objects enumeration...
[2013/10/18 14:23:35.603,1620] Nothing to do...
[2013/10/18 14:23:39.213,1620] User has requested program shutdown...
[2013/10/18 14:23:39.228,1620] Nothing to do...
[2013/10/18 14:23:39.260,1620] Switching panes to HTML...
[2013/10/18 14:23:39.275,1620] Destroying objects of folders....
[2013/10/18 14:23:39.275,1620] No properties dialog is available...
Last message repeated 2099 time(s)
[2013/10/18 14:23:39.291,1620] Item deleted: 0, Name: avast! Enterprise Administration Console.
[2013/10/18 14:23:39.291,1620] Folder deleted: 0, Name: Folders.
[2013/10/18 14:23:39.322,1620] No properties dialog is available...
Last message repeated 1 time(s)
[2013/10/18 14:23:45.744,3364] Unable to send idle message, error 0x000005B4...
[2013/10/18 14:23:45.744,1620] Stopping CSocket::ListenThread()...
[2013/10/18 14:23:45.775,1620] Unfreed client detected!!!
[2013/10/18 14:24:05.166,3652] Synchro timeout: 15000
[2013/10/18 14:24:06.228,3652] Status bar was successfully created...
[2013/10/18 14:24:06.307,3652] InitInstance() returning 0x00000000 error code...
[2013/10/18 14:24:06.307,3652] Nothing to do...
[2013/10/18 14:24:10.525,2228] Connecting to "WCPS-Avast2.WCPS.LAN" server
[2013/10/18 14:24:10.525,2228] Creating server connection socket...
[2013/10/18 14:24:26.525,2228] Connection to server created with 0x000005B4 error code...
[2013/10/18 14:24:26.525,2228] clnConnect() failed with 0x000005B4 error
[2013/10/18 14:24:26.525,2228] Unable to create connection to "WCPS-Avast2.WCPS.LAN" server, error 0x000005B4
[2013/10/18 14:24:26.525,3004] WinSock error 0x00002736 occured while receiving message...

Offline travisrich

  • Newbie
  • *
  • Posts: 5
Re: Performance/Stability Issue
« Reply #3 on: October 18, 2013, 08:28:48 PM »
[2013/10/18 14:25:45.307,1180] Socket 0x00001418 idle for too long - cleaning up
[2013/10/18 14:25:45.307,1180] Socket 0x0000065C idle for too long - cleaning up
[2013/10/18 14:25:45.307,1180] Socket 0x00001328 idle for too long - cleaning up
[2013/10/18 14:25:45.901,2440] Some client requests connection...
Last message repeated 5 time(s)
[2013/10/18 14:25:47.307,1180] Socket 0x00000EF8 idle for too long - cleaning up
[2013/10/18 14:25:47.307,1180] Socket 0x000006CC idle for too long - cleaning up
[2013/10/18 14:25:47.307,1180] Socket 0x000016A4 idle for too long - cleaning up
[2013/10/18 14:25:47.323,2440] Some client requests connection...
Last message repeated 2 time(s)
[2013/10/18 14:25:48.276,3084] Socket 0x000012DC idle for too long - cleaning up
[2013/10/18 14:25:48.354,2440] Some client requests connection...

Offline travisrich

  • Newbie
  • *
  • Posts: 5
Re: Performance/Stability Issue
« Reply #4 on: October 18, 2013, 08:33:24 PM »
I've installed enterprise server on 2012 using the sql express in the installer, on 2008 r2 with sql express in the installer, on 2008 r2 with a separate install of sql express, and on 2008 R2 with a full install of 2008 SQL R2.  Each server crashes like clockwork. 

Does anyone have more than 2000 clients talking to their console?

Offline MMDeveloper

  • Newbie
  • *
  • Posts: 2
Re: Performance/Stability Issue
« Reply #5 on: November 26, 2013, 09:51:12 PM »
I had the exact same problem. I abandoned that server and built a new one utilizing the full blown MS SQL 2008R2 and the stability issue went away.

I updated the avast policies in the old avast console to point the client machines to the new avast server and scheduled a reboot of the old avast server every half hour and eventually the computers got the policy and migrated over. Once the last one migrated over, I just destroyed the old VM.

I think it's SQL Express crapping out and not so much Avast.

Offline Che Johnson

  • Moderator
  • Full Member
  • *
  • Posts: 140
Re: Performance/Stability Issue
« Reply #6 on: December 04, 2013, 03:20:56 PM »
You should only have about 1000 clients pointing towards 1 server, I recommend installing a mirror on the 2nd server and have the clients update from there.