Author Topic: Avast makes my internet connection really Slow!  (Read 45653 times)

0 Members and 1 Guest are viewing this topic.

Offline JohanE

  • Newbie
  • *
  • Posts: 6
Avast makes my internet connection really Slow!
« on: November 05, 2013, 06:32:54 PM »
When I start my computer and check the download speed the speed is 1-2 Mbps. As a temporary solution I turn off the webshield and check the speed again, now it is around 50-55 Mbps. Then I turn the webshield back on. Now the internet speed stays at 50-55 Mbps until the next reboot and I have to repeat the procedure.

Is there a more permanent solution to this problem?

Win7
Asus P87B75-m
Intel Core i5.
12gb ram
GeForce gtx660ti

(And please please please, dont use captcha it really sucks...
All I get is this "The letters you typed don't match the letters that were shown in the picture".)

Offline Secondmineboy

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3651
Re: Avast makes my internet connection really Slow!
« Reply #1 on: November 05, 2013, 06:35:51 PM »
There will be no more Captchas after 3 posts.

Go to settings>active protection>Web shield and check only scan files from known browser processes and look if this solves it.
Windows 10 1909, 4 GB DDR3 RAM, 500 GB 5400 RPM HDD, 1366 by 768 LCD Screen, Intel Core i3 5010U Dual Core, Intel HD Graphics 5500
HUAWEI P30 Pro. Android 10

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5416
  • Spartan Warrior
Re: Avast makes my internet connection really Slow!
« Reply #2 on: November 05, 2013, 06:38:07 PM »
Hi JohanE,

Use of captcha is an anti-spam tool used here in the forums.  Once you've posted three posts, you'll not have to use captcha again.

What version of avast!?
What OS?  SP?
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.1.2397 (build 20.1.5069.559) UI version 1.0.460.

Offline Secondmineboy

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3651
Re: Avast makes my internet connection really Slow!
« Reply #3 on: November 05, 2013, 06:39:19 PM »
OS is Windows 7 as you can see above, but what Service Pack?

Windows 10 1909, 4 GB DDR3 RAM, 500 GB 5400 RPM HDD, 1366 by 768 LCD Screen, Intel Core i3 5010U Dual Core, Intel HD Graphics 5500
HUAWEI P30 Pro. Android 10

Offline JohanE

  • Newbie
  • *
  • Posts: 6
Re: Avast makes my internet connection really Slow!
« Reply #4 on: November 06, 2013, 07:34:02 AM »
I have version 2014.9.0.2006 and Service Pack 1.
I know it is an anti-spam tool but the pictures are nearly impossible to read. I think a spam-bot would do it better.  ;)
Hi JohanE,

Use of captcha is an anti-spam tool used here in the forums.  Once you've posted three posts, you'll not have to use captcha again.

What version of avast!?
What OS?  SP?


Thank you. I will try that.
Go to settings>active protection>Web shield and check only scan files from known browser processes and look if this solves it.

Offline GreggH

  • Jr. Member
  • **
  • Posts: 96
Re: Avast makes my internet connection really Slow!
« Reply #5 on: November 06, 2013, 11:20:35 AM »
Johan.....

You should also update Avast to 9.0.2007 which fixes many firewall problems.

Gregg
Windows 7 Ultimate x64 SP1, AIS2016 SP1(12.3.2280)

Offline JohanE

  • Newbie
  • *
  • Posts: 6
Re: Avast makes my internet connection really Slow!
« Reply #6 on: November 08, 2013, 11:36:55 AM »
Go to settings>active protection>Web shield and check only scan files from known browser processes and look if this solves it.
Did not work.

Johan.....

You should also update Avast to 9.0.2007 which fixes many firewall problems.

Gregg

I updated Avast to 9.0.2007 and tried again. It didnĀ“t help. :(
I turned off the webshield again. This is the result:

Offline azvaarsnti

  • Newbie
  • *
  • Posts: 5
Re: Avast makes my internet connection really Slow!
« Reply #7 on: November 21, 2013, 03:02:26 AM »
I have same problem. My setup:
 - Windows 8.1 64 bit
 - Asus P8B75-M motherboard, i7 processor
 - Avast 2014.9.0.2008

With Web Shield on my internet speed is <2mbps
With Web Shield off my internet speed is >6mbps (which is my connection speed)



Offline Gorg

  • Jr. Member
  • **
  • Posts: 31
Re: Avast makes my internet connection really Slow!
« Reply #8 on: November 21, 2013, 03:12:52 AM »
On the flip side of that, I love avast! Everything turned on here and I get..


Offline JohanE

  • Newbie
  • *
  • Posts: 6
Re: Avast makes my internet connection really Slow!
« Reply #9 on: November 26, 2013, 07:58:44 AM »
Still no solution to this?  :-\

Offline azvaarsnti

  • Newbie
  • *
  • Posts: 5
Re: Avast makes my internet connection really Slow!
« Reply #10 on: November 29, 2013, 08:35:02 AM »
No solution from me. I just now lodged a support ticket. I am using the free version, so I am not expecting a rush fix - I will log back here if any progress.

Offline befo

  • Newbie
  • *
  • Posts: 3
Re: Avast makes my internet connection really Slow!
« Reply #11 on: December 07, 2013, 02:53:28 PM »
I have the same problem since several avast versions. The only workaround I found is switching off the web shield. Since not all users are affected, I suppose it might be some interference with other internet security tools or configurations on my PC:
In addition to avast 2014.9.0.2008, I have running
Windows Defender
Windows Firewall
Fritz!DSL Protect
OS: Windows 7/64 bit Home Premium SP 1
HW: Intel i5 760 2,8 GHz 8 Gb RAM

I would appreciate very much, if Avast would issue an official solution to this annoying problem of many users.

Offline Rohugh

  • Sr. Member
  • ****
  • Posts: 262
Re: Avast makes my internet connection really Slow!
« Reply #12 on: December 07, 2013, 02:58:04 PM »
I have run Avast free with Widows Defender and with the Windows Firewall without any slowdowns.  So I can only suggest you disable Fritz!DSL Protect and see if that is the culprit.
« Last Edit: December 07, 2013, 02:59:35 PM by Rohugh »

Offline JohanE

  • Newbie
  • *
  • Posts: 6
Re: Avast makes my internet connection really Slow!
« Reply #13 on: December 09, 2013, 09:24:41 PM »
I have Avast and windows Firewall. Thats all, and still this problem.

Offline azvaarsnti

  • Newbie
  • *
  • Posts: 5
Re: Avast makes my internet connection really Slow!
« Reply #14 on: December 17, 2013, 07:09:18 AM »
Fixed for me.

Avast support came through with a solution. I am super impressed with Avast because I am only using the free version, although my company pays for the Pro and Linux Server versions at work so I don't feel too guilty.

The step that did the trick for me was to download and run Ccleaner from www.piriform.com, and run registry cleaner. After that my internet speeds were back up with Web Shield turned on. Whoever at Microsoft thought up the whole Registry idea should be given a special place in hell, although hell might be too good for them.

If that does not work, here is my summary of things they suggested. I did all of these too, so if the above did not fix it I would try all of these. Also I noticed it can take a few minutes for Avast Web Shield to activate/deactivate, which can make testing a bit ugly.  If you go into into Avast/Statistics you can see if the shield is checking the download files.

First:
 - uninstall any other antivirus software, or at least turn them off
 - ensure you have the latest version of Avast
 - reboot
 - uninstall Avast (and ensure the avast program directories are empty) and then do full clean reinstall

Then:
1) Run a boot-time scan (Avast>Security>Antivirus>Scan Now)
2) Download and run Ccleaner from www.piriform.com, and run registry cleaner
3) Consider running a shot of malwarebytes and then uninstall it.
4) Make a browser cleanup from inside Avast (Browser Cleanup Tool).

As I did all of these it might be a combination of things, but the registry clean was what did it for me.