Author Topic: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011  (Read 12347 times)

0 Members and 1 Guest are viewing this topic.

julevine

  • Guest
MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« on: December 18, 2013, 09:55:13 PM »
OS: windows xp pro  32bit fully  patched
 avast free antivirus

i installed latest version and   noticed that process  avastsvc.exe  will  not release memory it keeps building up 

i did a repair install  did not help

i had to uninstall and  reinstall previous version 

please  fix this  major issue

thank you
« Last Edit: December 19, 2013, 10:23:15 PM by julevine »

denbois

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #1 on: December 19, 2013, 09:39:54 AM »
Yes I can second that.  AVAST has been hounding me for 2 weeks to update, so tired of getting the messages and have my machine always being slowed down as it checks for currency of the AV version, I decided to install the recent AVAST version 2014.9.0.2011

WHAT A mistake .... immediately after reboot my CPU is constantly hitting 100% CPU at nearly all webpages.

I would estimate that the CPU is in 100% region 10 x more often that with the previous AVAST version.

This makes browsing impossible and frustrating.

*** AVAST, I second the previous comment - PLEASE PLEASE get this right and stop pushing updates on the PUBLIC if you cant. ***

Thanks

denbois

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #2 on: December 19, 2013, 09:43:16 AM »
Oh and my system is also an XP SP2 OS

Offline CraigB

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 11219
  • No support PM's thanks
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #3 on: December 19, 2013, 09:47:58 AM »
Oh and my system is also an XP SP2 OS
Your issue is different from what this topic is about, the issue discussed here is about the gradual increase in memory for the avast service and when browsers are closed this memory doesn't release.

Please start a topic of your own for your separate issue, I would also suggest that you update your XP to SP3 as this is likely the cause of your problem.

julevine

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #4 on: December 19, 2013, 10:22:45 PM »
i hope you guys are working  on a fix

please tell me  know
« Last Edit: December 19, 2013, 10:33:24 PM by julevine »

Avast user 007

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #5 on: December 20, 2013, 02:23:36 PM »
The guidelines for solving of the problem of using too much CPU has always been the same:

1. Check if the avast tray icon is spinning (while CPU usage is high)
2. If it is, click it (wait for the dialog box to open), and check which file is being scanned (spinning icon means a scan is in progress)
3. Find out which of the providers is scanning the file for each of the Shields.

Please download: http://download.sysinternals.com/Files/ProcessExplorer.zip
Run it as administrator, find "AvastSvc.exe" process (avast! service) and when it'll use high CPU, right-click it and choose "Create dump > Full dump". Then compress the dump file and upload it to ftp://ftp.avast.com/incoming/.

You can also use http://public.avast.com/~vlk/hangrep.exe to generate a manual dump of the application (in this case, avastSvc.exe

julevine

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #6 on: December 28, 2013, 09:59:31 PM »
here is  my  full memory dump  of avastsvc.exe

http://www.sendspace.com/file/x5dadr  (updated on  march  9 2014

I did memory dump when it was around 31MB

I  hope you can solve my issue soon 


thanks
« Last Edit: March 09, 2014, 10:17:12 PM by julevine »

peterlaws

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #7 on: December 30, 2013, 12:32:40 PM »
I'm seeing this too.... 6 days uptime, 133mb!

Offline miguelgrado

  • Advanced Poster
  • **
  • Posts: 786
  • Admin ForoAntispyware
    • Foroantispyware
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #8 on: December 30, 2013, 12:48:29 PM »
I'm seeing this too.... 6 days uptime, 133mb!

idem..but always after receiving a vps, the used memory is reduced.Then continues to grow until it receives a new vps 

julevine

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #9 on: January 05, 2014, 09:08:37 PM »
i need  my  full dump file   looked at  so   the bug can be fixed


i uploaded dump  here
http://www.sendspace.com/file/j2djlh

i could not figure out how to upload to the  ftp server

please  reply soon  on a update

thank you 

Goner07

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #10 on: January 17, 2014, 09:14:45 PM »
I was having this same problem on my 2 machines at home. During start up I had my task manager open and a Trusted Installer process (C:\Windows\servicing\Trustedinstaller) starting running 2-3 minutes after boot. I let this run the first couple of times and right after it "automatically" ended Avast would shoot up to 100% CPU and have a memory leak that would go into to 2-3 gig range.
I have now ended the installer manually on both machines during start up and the 100% cpu problem has gone away.
Not too sure if the 2 are related, just too much of a coincidence to ignore that this "fix" worked on both of my machines. Both machines are running Win7 with all updates installed.
I have done a boot time scan and a full system scan on both machines and no viruses were found.

Hope this helps some people.

Avast user 007

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #11 on: January 22, 2014, 11:44:42 PM »
I suggest an installation from scratch:

1. Download the latest version of avast! Uninstall Utility and save it.
2. Download the latest avast! version and save it.
3. Uninstall avast from Control Panel (if possible). If, for any reason, you can't run it, try booting in Safe Mode and doing it from there. Anyway, boot after that.
4. Run the avast! Uninstall Utility saved on 1 in Safe Mode. Boot after you've run it. Repeat this for any major avast! version you have ever installed/upgraded in your computer.
5. Install avast! using the setup saved on 2. Boot.
6. Register your free copy or add the license key for Pro. Or even upgrade your key from old versions.
7. Check and post the results. If, for any reason, you did not solve, try doing the step 3 in Safe Mode anyway.

Offline miguelgrado

  • Advanced Poster
  • **
  • Posts: 786
  • Admin ForoAntispyware
    • Foroantispyware
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #12 on: January 23, 2014, 12:57:24 AM »
New version fix the problem.... :)

julevine

  • Guest
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #13 on: March 07, 2014, 09:26:24 PM »
avast staff please confirm my problem   been fixed

has my problem  been fixed  is  new version   

i need too know   it  been fixed  so i don't  have  same issue when i update it

thanks
« Last Edit: March 07, 2014, 09:32:05 PM by julevine »

Offline CraigB

  • Avast √úberevangelist
  • Serious Graphoman
  • *****
  • Posts: 11219
  • No support PM's thanks
Re: MAJOR PROBLEM AVASTSVC.EXE 2014.9.0.2011
« Reply #14 on: March 07, 2014, 09:35:30 PM »
Well I've seen no reports on the forum of this issue returning so you should be fine, there have been two full stable versions released since your problem occurred.

To be safe you should always make a system image before upgrading and if problems occur then it is simple to revert.