Author Topic: Avast 2014 Free Antivirus blocking web traffic  (Read 38822 times)

0 Members and 1 Guest are viewing this topic.

lord ami

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #15 on: December 19, 2013, 08:51:30 PM »
HI!

Please help me,I try to aply this solution :

[General]
UseStreamFilter=0

in win7Prox64, and when I wish to save the modification sistem said:
ACCES DENIED!

why?

Thanks...
You have to disable avast! self protection (Settings - Troubleshooting). But, temporarily. After restart, re-enable it!

T-man

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #16 on: December 19, 2013, 09:03:21 PM »
I did...but no luck!...I receive the exact: ACCES DENIED mesage when I whish to save the modification...any ideas?...Thanks!

AlexeyK

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #17 on: December 20, 2013, 09:23:04 AM »
I did...but no luck!...I receive the exact: ACCES DENIED mesage when I whish to save the modification...any ideas?...Thanks!

I tried to do so on Win8 x64, result is the same: access denied.
How we can fix this trouble?

Offline Andrey,pro

  • Avast √úberevangelist
  • Ultra Poster
  • *****
  • Posts: 5012
  • Things happen
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #18 on: December 20, 2013, 09:32:04 AM »
I tried to do so on Win8 x64, result is the same: access denied.
How we can fix this trouble?
Did you try to do this modification in Safe mode? Also you can try to disable all shildes before saving modifications into WebShield.ini (of course, avast self defence should be disabled).

T-man

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #19 on: December 20, 2013, 09:48:14 AM »
...safe mode,off all shields...nothing!same access denied!...Avast Free version ,fresh instal on win 7pro x64 clean(only Firefox and Avast is instaled at this moment,nothing else!) get me crazy!when Avast webshield is active...NO WEB BROWSING AT ALL!...Without Avast all is perfect!....please give us one fix for this issues...past 2days and nothing fixed!....Thanks!.... >:(

Same problem in IE8 and FIREFOX...

second time in SAFE MODE work!Now the web browser work ok...but I have one new issue:

...the Avast moon in the Task Bar apear only if I click on the AVAST ICON on the desktop...no automaticaly apear...why?...Thanks!
« Last Edit: December 20, 2013, 10:41:25 AM by T-man »

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89423
  • No support PMs thanks
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #20 on: December 20, 2013, 12:20:55 PM »
I did...but no luck!...I receive the exact: ACCES DENIED mesage when I whish to save the modification...any ideas?...Thanks!

If you use notepad.exe, the only text editor allowed to modify the various avast .ini files, it should be OK. However, windows (7 and above) itself is likely to chip in with the access denied issue. You need to run notepad.exe as the administrator and then open the WebShield.ini to edit it.

Fortunately 2nd time in safe mode (administrator privileges) appears to have worked for you now.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

AlexeyK

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #21 on: December 20, 2013, 12:25:49 PM »
I tried to do so on Win8 x64, result is the same: access denied.
How we can fix this trouble?
Did you try to do this modification in Safe mode? Also you can try to disable all shildes before saving modifications into WebShield.ini (of course, avast self defence should be disabled).

Thanks, modification was successful in Safe mode.

T-man

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #22 on: December 20, 2013, 12:40:29 PM »
...Thanks to all! Now is ok for webshield...but I don't understand why AVAST no start automaticaly after windows reboot...only if I start him manualy?... ???
« Last Edit: December 20, 2013, 12:43:06 PM by T-man »

YaserK

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #23 on: December 20, 2013, 01:43:37 PM »
I am experiencing exactly the same problem after updating to 2014.9.0.2011. Very slow connections. Websites hardly open. I had to disable WebShield in order to work properly. Waiting for a solution..

swag-nyc

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #24 on: December 20, 2013, 11:16:47 PM »
I was having issues with avast blocking some things like video and images (google images) as well as random pages and google api stuff

I'm having trouble understanding why the solution is to edit a config file when all you need to do is turn off the intelligent stream scanner in the web settings.

this corrected the issue for me.
the answer given sounds like unscrewing a bulb to turn out a light when theres a perfectly good switch next to you on the wall

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #25 on: December 21, 2013, 06:39:12 AM »
Swag-nyc, what is your OS, please? Windows XP?

MaDJiK

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #26 on: December 21, 2013, 01:19:33 PM »
Please let us to know if the problem is gone.


Not here... Some sites work and some don't load. I try to add the 2 lines, but the exact same sites are blocked.
(I'm on Win 7 64bits.)


I'm having trouble understanding why the solution is to edit a config file when all you need to do is turn off the intelligent stream scanner in the web settings.

this corrected the issue for me.

And for me!


I did not see the thread about the fix. It seems to correct the problem too.
« Last Edit: December 21, 2013, 01:31:55 PM by MaDJiK »

swag-nyc

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #27 on: December 21, 2013, 06:21:35 PM »
Swag-nyc, what is your OS, please? Windows XP?

7 64

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #28 on: December 21, 2013, 07:01:18 PM »
I've a variation on this theme.

If an admin reckons it needs a new topic, fair enough.


My access to my workplace is through a Barracuda java vpn launch from within the browser, I happen to use chrome.
I can get to the vpn launch ok, i.e. authenticate and login.

Before the rewrite/upgrade this week per http://forum.avast.com/index.php?topic=139112.msg1021944#msg1021944 I could stop my firewall for 10 minutes, i.e. as short as it allowed, then open my rdp connection and restart the firewall.

Post rewrite rather than the rdp timeout/denied type response I see my office desktop start to logon, then nothing. Logs/traffic appears to show my 127.0.0.1 traffic goes out ok but not back. I can see the browser side of that same comms is green ok, but the mstc has the red arrow.

My launcher page gives me other pages to play with aside from rdp, and they render by appear to show dns issues, so the browser otherwise would show the URL as my vpn reference, post new changes that renders as 127.0.0.1/whatever and the on page graphics show a dns issue.

If I hit this page from a non-avast protected system on my network, happens to be fedora 18, I can get the page with no dns issue.
Unfortunately my rdp access form that laptop has always been hit and miss, so I cannot confirm if the launched mstsc from the chrome webpage is denied for local reasons or as a side effect of the rewrite, at least until Monday - however I suspect its the avast changes.
Home and office are both on win7.1x64.

If I stop ALL the active protection one by one or all together to see if I can encourage a new shielded behaviour to stop getting in my way no joy.

I've added the URL to trusted etc and disabled intelligent scanning etc/removed 'other programs' from the scan list etc., and aside from finding I cannot add it as https, it has made no difference. i.e. if I add my https://vpn to the list, the avast adds http to the start of it! So it becomes http://https://..


Pointy

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #29 on: December 22, 2013, 04:46:55 AM »
The December 20th emergency patch seems to have fixed my problem.  :)