Author Topic: Avast 2014 Free Antivirus blocking web traffic  (Read 38870 times)

0 Members and 1 Guest are viewing this topic.

swag-nyc

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #30 on: December 22, 2013, 06:29:58 AM »
Confirming the above post
reactivated Intelligent stream scanning from the GUI and the problem seems to be corrected so far for me

win7 x64
« Last Edit: December 22, 2013, 06:31:49 AM by swag-nyc »

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #31 on: December 22, 2013, 07:27:34 AM »
Engarde, have you tried enabling "ics sharing mode" in firewall settings? It frequently helps with vpns. The fw mode might need to be "private", but I'm not sure about this one.

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #32 on: December 22, 2013, 03:39:11 PM »
ICS has made no difference.

So in terms of the 127.0.0.1 red arrow on the inbound, its actually java.exe. I've got a all connections in/out tcp/udp set for it

In the attachment, 2 of the 443 connections for chrome are for my office vpn, and the blanked out one from the java.exe

Offline MartinK

  • Avast team
  • Jr. Member
  • *
  • Posts: 56
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #33 on: December 22, 2013, 11:27:23 PM »
Hi Engarde,
please, could you check version of file \Windows\System32\Drivers\aswNdisFlt.sys - just for sureness.
Thanks

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #34 on: December 23, 2013, 06:58:36 AM »
9.0.2011.265

Offline Turtlediver

  • Newbie
  • *
  • Posts: 17
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #35 on: December 23, 2013, 05:46:08 PM »
After updating from 2008 to 2011 I experienced the same problems others are reporting.  Couldn't connect to some websites and other sites opened very slowly or not at all.  No problems with Avast turned off!!!  I uninstalled using avastclear, but after reinstalling 2008, it wouldn't go active!  Thank goodness System Restore worked and 2008 is now functioning as before.  It sure doesn't create a warm fuzzy feeling, however.  I think I'll check the forum before rushing to install future program updates.  Running Windows 7 SP1.  ZoneAlarm
« Last Edit: December 23, 2013, 05:58:58 PM by Turtlediver »

Offline engarde

  • Newbie
  • *
  • Posts: 10
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #36 on: December 23, 2013, 07:55:29 PM »
I've removed my install with avastclear, and reinstalled from scratch.
I am now able to rdp etc within my vpn with no custom rules nor ics settings which I could not before. My new version of the driver file is  9.0.2010.245, meaning its a previous generation compared to what I had pre-reinstall (9.0.2011.265)!  If I check for updates there are none!

Offline jursa

  • Avast team
  • Jr. Member
  • *
  • Posts: 39
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #37 on: January 06, 2014, 04:40:59 PM »
I've a variation on this theme.

If an admin reckons it needs a new topic, fair enough.


My access to my workplace is through a Barracuda java vpn launch from within the browser, I happen to use chrome.
I can get to the vpn launch ok, i.e. authenticate and login.

Before the rewrite/upgrade this week per http://forum.avast.com/index.php?topic=139112.msg1021944#msg1021944 I could stop my firewall for 10 minutes, i.e. as short as it allowed, then open my rdp connection and restart the firewall.

Post rewrite rather than the rdp timeout/denied type response I see my office desktop start to logon, then nothing. Logs/traffic appears to show my 127.0.0.1 traffic goes out ok but not back. I can see the browser side of that same comms is green ok, but the mstc has the red arrow.

My launcher page gives me other pages to play with aside from rdp, and they render by appear to show dns issues, so the browser otherwise would show the URL as my vpn reference, post new changes that renders as 127.0.0.1/whatever and the on page graphics show a dns issue.

If I hit this page from a non-avast protected system on my network, happens to be fedora 18, I can get the page with no dns issue.
Unfortunately my rdp access form that laptop has always been hit and miss, so I cannot confirm if the launched mstsc from the chrome webpage is denied for local reasons or as a side effect of the rewrite, at least until Monday - however I suspect its the avast changes.
Home and office are both on win7.1x64.

If I stop ALL the active protection one by one or all together to see if I can encourage a new shielded behaviour to stop getting in my way no joy.

I've added the URL to trusted etc and disabled intelligent scanning etc/removed 'other programs' from the scan list etc., and aside from finding I cannot add it as https, it has made no difference. i.e. if I add my https://vpn to the list, the avast adds http to the start of it! So it becomes http://https://..

Hi, this problem with baracuda VPN should be fixed in latest build. 9.0.2011 -> http://forum.avast.com/index.php?topic=142936.0

Could you please re-test it  ?

Thnx,
David.

fds_

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #38 on: January 19, 2014, 04:55:42 PM »
Hello everyone,

I tried every solution I found on the net. Different browsers. Disabling all extensions and applications. Disabling WebSecurity. Adding "UseStreamFilter=0" to the .ini-File. I literally sat here for about 4 hours trying to fix the bug, that is obviously exisiting since about a month, without any success.
I still can't watch streams on twitch.tv or any other streaming page. The video will just reload every few seconds. Since you aren't capable of fixing
a known bug in about 4 weeks, I asume your so-called customer-friendly company is a fraud and will uninstall your product, since it is heavily
influencing my internet experience in a negative way.

Bye

sleepycal

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #39 on: January 19, 2014, 09:27:47 PM »
Avast WebShield now makes web browsing ridiculously slow, to the point where HTTP requests will timeout.

The `UseStreamFilter=0` trick worked for a while, but now I have to completely disable WebShield to be able to use the web browser. Also poking around the statistics panel causes the Avast UI to lockup/freeze indefinitely, and the process cannot be killed.

I've been an avid user of Avast for over 3 years, but I am seriously considering switching because of this problem.

Please Avast, stop this silliness and fix the bugs.

Cal

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 76029
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #40 on: January 19, 2014, 09:29:50 PM »
Try the new beta: http://forum.avast.com/index.php?topic=144768.0

Problem solved..??
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

sleepycal

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #41 on: January 19, 2014, 09:32:52 PM »
Thanks for the heads up, installing now, will report back in 24 hours

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 76029
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #42 on: January 19, 2014, 09:34:09 PM »
Thanks for the heads up, installing now, will report back in 24 hours

Please do so.
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

fds_

  • Guest
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #43 on: January 20, 2014, 02:57:20 PM »
Installed Beta. Still can't watch streams.

Offline lukor

  • Administrator
  • Super Poster
  • ***
  • Posts: 1884
    • AVAST Software
Re: Avast 2014 Free Antivirus blocking web traffic
« Reply #44 on: January 20, 2014, 03:17:48 PM »
Hi fds_, sorry to hear that, but since you've tried to disable the stream filter and that didn't help - it is expected that fixing the same code wouldn't help either.


You didn't mention that turning WebShield off solves the problem for you. Does it ?


Lukas.