Author Topic: Gmail and Avast Providers  (Read 22093 times)

0 Members and 1 Guest are viewing this topic.

Offline Antigen

  • Jr. Member
  • **
  • Posts: 53
Gmail and Avast Providers
« on: July 07, 2005, 08:04:42 PM »
I'm using Gmail as email address, but it use the SSL protocol to comunicata and Avast is not compatibile. Is possible to eliminate the provider that check the email? In this case is unusued and it only "eat" my memory :D
Bye

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31356
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Gmail and Avast Providers
« Reply #1 on: July 07, 2005, 08:31:38 PM »
Just disable the provider(s) you don't need/want in the on-access control panel.

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
Re: Gmail and Avast Providers
« Reply #2 on: July 07, 2005, 09:30:01 PM »
To set up SSL gmail with avast!, using Stunnel and openSSL, you need to do 3 things:
1) In your email client, use
localhost:11111 for your pop server
localhost:11026 for your smtp server
Do not check "use secure"

2) In avast! email provider add
11111 to the pop3 ports to redirect
11026 to the smtp ports to redirect

3) With a text editor, create Stunnel.conf (or cut/paste below)
Stunnel.conf, the configuration file, looks exactly like this for gmail:


client=yes
# POP3 service, listens on localhost:11111
[gmail-pop3s]
accept=localhost:11111
connect=pop.gmail.com:995

# SMTP service, listens on localhost:11026
[gmail-smtps]
protocol=smtp
accept=localhost:11026
connect=smtp.gmail.com:587

You need to download and install OpenSSL from http://www.openssl.org/related/binaries.html and Stunnel from http://www.stunnel.org/download/binaries.html and install them.  Stunnel can either be installed as a windows service or added to your startup group.  Put stunnel.conf in the same folder as stunnel.

There are a large number of users of secure email with avast! who can help here in the forum if you have problems/questions.  Give it a try!
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline server007

  • Newbie
  • *
  • Posts: 1
Re: Gmail and Avast Providers
« Reply #3 on: August 03, 2005, 09:55:47 PM »
I'm using GMX and so i want to know if OpenSSL and Stunnel are right for this.

I changed in the "Stunnel.conf" file gmail to the correct GMX server but there is no session active in Stunnel.

What should i do?

server007

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67273
Re: Gmail and Avast Providers
« Reply #4 on: August 04, 2005, 03:38:14 AM »
What should i do?
Did you follow sded's instructions?
Anyway, take a look here: http://forum.avast.com/index.php?topic=10428.0 to see how to set up secure email with avast!.
The best things in life are free.

Offline Norm321

  • Jr. Member
  • **
  • Posts: 89
  • Happy avast user (Norton & AVG Convert)
Re: Gmail and Avast Providers
« Reply #5 on: June 24, 2007, 01:51:49 PM »
sded, I need to setup avast with a Att Yahoo SSL connection. I see your instruction here for Gmail. The server settings are obvious but what about the area with [gmail-pop3s] and [gmail-smtps]. Can I just use [AttYahoo-pop3s] and [AttYahoo-smtps]? Here are the instructions from Att.

1.Open your email client program.
2.Locate the email account settings for your particular client.
3.Change the POP server to pop.att.yahoo.com.
4.Change the SMTP server to smtp.att.yahoo.com.
5.Check the option labeled Use an encrypted connection (SSL) and change the SMTP port to 465.
6.Check the option labeled Use an encrypted connection (SSL) and change the POP3 port to 995.
7.Confirm the above settings then click OK.
EMachines T3395, AMD Sempron 3000+
Win XP Home, Version 2002, SP3
768 MB Ram, 80 MB HD, Nvidia onboard graphics
Avast 5.0 Free, MBAM Free
Firefox 3.6, Thunderbird 3.0.3

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67273
Re: Gmail and Avast Providers
« Reply #6 on: June 24, 2007, 05:19:12 PM »
Can I just use [AttYahoo-pop3s] and [AttYahoo-smtps]?
I think so, but I'm not sure.
The other configurations I can't test. My stunnel configuration is:

Code: [Select]
cert = stunnel.pem

# GMail
client=yes

# POP3 service, listens on localhost:11110
[gmail-pop3s]
accept=127.0.0.1:11110
connect=pop.gmail.com:995

# SMTP service, listens on localhost:11025
[gmail-smtps]
protocol=smtp
accept=127.0.0.1:11025
connect=smtp.gmail.com:587
The best things in life are free.

Offline sded

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1718
  • Me llamo Ed
Re: Gmail and Avast Providers
« Reply #7 on: June 25, 2007, 08:25:32 PM »
sded, I need to setup avast with a Att Yahoo SSL connection. I see your instruction here for Gmail. The server settings are obvious but what about the area with [gmail-pop3s] and [gmail-smtps]. Can I just use [AttYahoo-pop3s] and [AttYahoo-smtps]? Here are the instructions from Att.
Should work, per their instructions.  If there is an smtp problem, you may also need to comment out the "protocol=smtp" with a ;--ISPs are sometimes a little loose with TLS vs SSL.  The stuff in the brackets is just the name stunnel uses to identify the section of commands and can be anything.
« Last Edit: June 25, 2007, 08:28:34 PM by sded »
Windows 7 x64HP-SP1-No UAC, Opera 11.51, Avast! Internet Security 6.0.128, Webroot SecureAnywhere latest beta, Windows FW off, MVPS HOSTS, SAS/MBAM offline, Macrium Reflect just in case ;)

Offline Norm321

  • Jr. Member
  • **
  • Posts: 89
  • Happy avast user (Norton & AVG Convert)
Re: Gmail and Avast Providers
« Reply #8 on: June 26, 2007, 02:53:16 AM »
Sounds good, thanks form the info, haven't had much of a chance to mess with it yet.
Busy, busy, busy, Thanks again!!
EMachines T3395, AMD Sempron 3000+
Win XP Home, Version 2002, SP3
768 MB Ram, 80 MB HD, Nvidia onboard graphics
Avast 5.0 Free, MBAM Free
Firefox 3.6, Thunderbird 3.0.3

Offline Norm321

  • Jr. Member
  • **
  • Posts: 89
  • Happy avast user (Norton & AVG Convert)
Re: Gmail and Avast Providers
« Reply #9 on: June 28, 2007, 02:46:46 AM »
Have it setup but am getting a error in Outlook Express.

The host 'localhost:11111' could not be found. Please verify that you have entered the server name correctly. Account: 'SBC Yahoo', Server: 'localhost:11111', Protocol: POP3, Port: 995, Secure(SSL): Yes, Socket Error: 11001, Error Number: 0x800CCC0D

Here is  the stunnel.conf file

client=yes
# POP3 service, listens on localhost:11111
[att-yahoo-pop3s]
accept=localhost:11111
connect=pop.att.yahoo.com:995

# SMTP service, listens on localhost:11026
[att-yahoo-smtps]
protocol=smtp
accept=localhost:11026
connect=smtp.att.yahoo.com:465

Please Help!! Thanks!
EMachines T3395, AMD Sempron 3000+
Win XP Home, Version 2002, SP3
768 MB Ram, 80 MB HD, Nvidia onboard graphics
Avast 5.0 Free, MBAM Free
Firefox 3.6, Thunderbird 3.0.3

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 82548
  • No support PMs thanks
Re: Gmail and Avast Providers
« Reply #10 on: June 28, 2007, 03:04:59 AM »
Based on Tech's settings he is using localhost:11110 and you are using localhost:11111, I have no idea if that is critical or you can choose the localhost port.

Also were Tech uses accept=127.0.0.1:11110 you are just putting in accept=localhost:11111 perhaps you could try the 127.0.0.1:11110
« Last Edit: June 28, 2007, 03:07:40 AM by DavidR »
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 1909 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 19.8.2393 (build 19.8.4257.552) UI-1.0.440/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ WinPatrol+/

Offline Norm321

  • Jr. Member
  • **
  • Posts: 89
  • Happy avast user (Norton & AVG Convert)
Re: Gmail and Avast Providers
« Reply #11 on: June 28, 2007, 03:30:21 AM »
Thanks for the reply DavidR. I tried settings like Tech's but no luck. I also tried 127.0.0.1 instead of localhost in Outlook Express but still no luck. Any other suggestions? Thanks!!
EMachines T3395, AMD Sempron 3000+
Win XP Home, Version 2002, SP3
768 MB Ram, 80 MB HD, Nvidia onboard graphics
Avast 5.0 Free, MBAM Free
Firefox 3.6, Thunderbird 3.0.3

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user
Re: Gmail and Avast Providers
« Reply #12 on: June 28, 2007, 06:57:05 AM »
Norm321,

did you first ensure that you knew how to make the secure connection work between Yahoo and Outlook Express before you tried to insert STunnel in the mix?

You are begging for trouble if you do not.
« Last Edit: June 28, 2007, 07:01:02 AM by alanrf »

Offline Norm321

  • Jr. Member
  • **
  • Posts: 89
  • Happy avast user (Norton & AVG Convert)
Re: Gmail and Avast Providers
« Reply #13 on: June 28, 2007, 01:07:31 PM »
Hey alanrf, yes I have it working right now and had it working before I changed some settings to accomidate Stunnel. I will tinker with it some more. I tried a number of ways so far but have a few more ideas. I have plenty of sticktoittivness and won't give up until I get it. I like how in avast you can add the extra ports to redirect by placing a comma between them. This is great because I have multiple email
accounts.

Thanks!!
EMachines T3395, AMD Sempron 3000+
Win XP Home, Version 2002, SP3
768 MB Ram, 80 MB HD, Nvidia onboard graphics
Avast 5.0 Free, MBAM Free
Firefox 3.6, Thunderbird 3.0.3

Offline Norm321

  • Jr. Member
  • **
  • Posts: 89
  • Happy avast user (Norton & AVG Convert)
Re: Gmail and Avast Providers
« Reply #14 on: June 28, 2007, 01:49:51 PM »
Got it working. Here is the stunnel.conf file and the Outlook Express settings for anyone that needs to get setup for avast to scan ATT Yahoo SSL mail.

#attyahoo

client=yes
# POP3 service, listens on localhost:11110
[att-yahoo-pop3s]
accept=127.0.0.1:11110
connect=pop.att.yahoo.com:995

# SMTP service, listens on localhost:11025
[att-yahoo-smtps]
;protocol=smtp (removed with ; in front of this)
accept=127.0.0.1:11025
connect=smtp.att.yahoo.com:465

In Outlook Express in the Properties for your Account on the Server tab use
127.0.0.1 for both POP and SMTP servers.

Then on the Advanced tab use 11110 for the POP Port
and use 11025 for the SMTP Port. DO NOT check This Server Requires a Secure Connection(SSL).

Then remember to add the ports 11110 and 11025 into the redirect ports in the email section of avast.
EMachines T3395, AMD Sempron 3000+
Win XP Home, Version 2002, SP3
768 MB Ram, 80 MB HD, Nvidia onboard graphics
Avast 5.0 Free, MBAM Free
Firefox 3.6, Thunderbird 3.0.3