Author Topic: Outlook plugin and other problems  (Read 3894 times)

0 Members and 1 Guest are viewing this topic.

tomg

  • Guest
Outlook plugin and other problems
« on: October 31, 2003, 07:55:11 AM »
I installed avast! 4 home on my xppro box (german, sp1a, ol2000).
After the obligate reboot i got a message box before I login:
German: "Entweder existiert kein Standard-Mail-Client, oder der aktuelle Mail-Client kann dieMessaging-Anfrage nicht erfüllen. Bitte führen Sie Microsoft Outlook aus und legen Sie es als Standard-Mail-Client fest"
Translated this means: "Either there is no standard E-Mail-Client or the actual E-Mail-client cannot handle a messaging request. Please run microsoft outlook and define it as standard e-mail client" (You can find the original text in HKLM\software\clients\mail\prefirtsrun")
Outlook is defined as standard e-mail-client in the registry (HKLM\software\clients\mail(standard)
This message is related to the mapi32.dll (found in the exchange-sdk-doc: "the mapi32 stub library)
What is avast doing with mapi befor a user logs in ???
After the login everything seems to work fine but the start of outlook is very very very slow
on my 700Mhz PIII without avast outlook starts in less then two seconds. With avast it needs 10 to 20 seconds!!

After this experience I tried to uninstall the outlook/exchange-protection. No way! Setup hangs my hole box with the progress-bars at 0%.... (big red switch required!)
Same behavior when I try to uninstall avast completly.

Tomg


tomg

  • Guest
Re:Outlook plugin and other problems
« Reply #1 on: October 31, 2003, 08:56:25 AM »
In addition to my first posting:

I searched the google groops for my error message (correct english version): Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client

It seems to be related to the type of outlook installation in the "internet mail only (imo)" version extended mapi is not supported in ol2k

Are you yousing extended mapi calls in avast?

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Outlook plugin and other problems
« Reply #2 on: October 31, 2003, 10:03:15 AM »
Tomg, shoot, I probably know where this is coming from. It must be the initialization of the MAPI unpacker (which internally uses extended MAPI).

Try this: open the file <avast>\deftasks.xml. In the definition of the first task (the Resident Protection) you'll find the following lines:

<OUTLOOK--ScanPackers>All</OUTLOOK--ScanPackers>
<MAIL--ScanPackers>All</MAIL--ScanPackers>
<P2P--ScanPackers>All</P2P--ScanPackers>
<IM--ScanPackers>All</IM--ScanPackers>

Replace them with:

<OUTLOOK--ScanPackers>EXE;ZIP;MIME;RAR;ARJ;TAR;GZ;CAB;ARC;ACE;ZOO;BZIP2;WinExec</OUTLOOK--ScanPackers>
<MAIL--ScanPackers>EXE;ZIP;MIME;RAR;ARJ;TAR;GZ;CAB;ARC;ACE;ZOO;BZIP2;WinExec</MAIL--ScanPackers>
<P2P--ScanPackers>EXE;ZIP;MIME;RAR;ARJ;TAR;GZ;CAB;ARC;ACE;ZOO;BZIP2;WinExec</P2P--ScanPackers>
<IM--ScanPackers>EXE;ZIP;MIME;RAR;ARJ;TAR;GZ;CAB;ARC;ACE;ZOO;BZIP2;WinExec</IM--ScanPackers>

That will disable the MAPI packer (used to scan inside PST files).
After the changes, reboot the machine and see if it helps.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

tomg

  • Guest
Re:Outlook plugin and other problems
« Reply #3 on: November 04, 2003, 09:56:00 AM »
Vlk,
Sorry, did not help

But I solved my problem by installing outlook xp. I think there was thomething wrong with my outlook-Installation. It was set to corporate and internet connections, so extendet mapi should be installed. But it probaly was not installed properly.

cu
Tomg