Author Topic: Event ID 7022 and 7034 errors on system startup  (Read 9435 times)

0 Members and 1 Guest are viewing this topic.

koverturf

  • Guest
Event ID 7022 and 7034 errors on system startup
« on: October 03, 2005, 03:01:32 AM »
After installing Avast Server Edition on a Windows 2003 Terminal Server each time after the system reboots I get Event ID 7022 (the Avast! Antivirus service hung on starting) and Event ID 7034 (the Avast! Antivirus service terminated unexpectedly).  I have tried uninstalling/reinstalling with the same results.  Any ideas what is going on here?  The Windows 2003 OS is at SP1 and is a new install.

willisd

  • Guest
Re: Event ID 7022 and 7034 errors on system startup
« Reply #1 on: October 04, 2005, 06:09:52 PM »
I'm also experiencing the same errors.  Using Win2K3 SP1 with terminal services in application mode.  Have tried reinstalling numerous times.  Ideas?

shawng

  • Guest
Re: Event ID 7022 and 7034 errors on system startup
« Reply #2 on: October 05, 2005, 11:19:59 AM »
well, we (I mean Willisd and I) managed to get this going, only after playing around with it for serveral hours trying out a few things.

FYI:

- When we installed, it REFUSED to start using an account (administrator or even a custom created admin access equivilent). I had to switch it to logon locally and allow it to interact with the desktop in order to get it to function correctly.

- There's a good chance that the license data will be corrupted if the service fails to load or you don't complete the steps after the reboot. This happened to me twice. I found if I chose the option not to restart, set the services to login locally with desktop interaction, then rebooted, the last steps came up fine and I was able to complete the install.

We have it running right now, and it seems to be working fine, but we're off to a rocky start.

koverturf, feel free to contact myself if these instructions are not clear.

koverturf

  • Guest
Re: Event ID 7022 and 7034 errors on system startup
« Reply #3 on: October 05, 2005, 02:25:39 PM »
Willisd,

Thanks for the information.  Our 2003 terminal server is also in application mode.  I will try following your instructions this Friday and see if I can also get it running.  I will let you know...
Thanks again...

Ken

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Event ID 7022 and 7034 errors on system startup
« Reply #4 on: October 10, 2005, 02:25:53 PM »
I can confirm that there's a problem in the current version of avast Server Edition if its service is configured to run under a non-LocalSystem account.

However, switching its log on settings to LocalSystem should do the trick, and shouldn't have any other consequences.


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.