Author Topic: Problems with avast! antivirus screen saver  (Read 7072 times)

0 Members and 1 Guest are viewing this topic.

kecajn

  • Guest
Problems with avast! antivirus screen saver
« on: November 09, 2003, 11:00:10 PM »
I have just started to use avast! 4 Home on my old PC (P120 w/72 MB RAM, NTW 4.0/SP6a+hot fixes). Antivirus software seems to be working correctly (although I also experience "service hung" message at startup, but the software is working so I do not care). But I cannot make screen saver running: I configured it with every standard Windows screen saver and it seems to me it is trying to start but it does not. I need virus scanning only (no VRDB). How can I check what can be wrong? Preview of avast! screen saver function is working correctly!

Best regards,

Jacek
« Last Edit: November 09, 2003, 11:10:24 PM by kecajn »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Problems with avast! antivirus screen saver
« Reply #1 on: November 09, 2003, 11:28:53 PM »
Strange indeed  :-\
If preview of avast! screen saver function is working correctly why do you say that it is not working in normal conditions? Does the screen saver start? If your mouse or keybord sensibility are high, maybe it starts and few moments after it is disabled... Could you post more information?  ;)
The best things in life are free.

kecajn

  • Guest
Re:Problems with avast! antivirus screen saver
« Reply #2 on: November 10, 2003, 04:13:14 PM »
Strange indeed  :-\
If preview of avast! screen saver function is working correctly why do you say that it is not working in normal conditions? Does the screen saver start? If your mouse or keybord sensibility are high, maybe it starts and few moments after it is disabled... Could you post more information?  ;)

When screen saver timeout expires, there is some "movement" in the system that can be interpreted as screen saver start: disk activity, screen flicking (sometimes only wallpaper is visible), etc. But after short period everything returns to normal state.
I assume that screen saver task is trigerred but it cannot run for some reason. I would like to find out the reason. (low memory?)

Best regards,

Jacek

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Problems with avast! antivirus screen saver
« Reply #3 on: November 10, 2003, 07:51:18 PM »
If the screen saver timeout expires, the screen saver must start, not just some "movement" in the system that can be interpreted as screen saver start: disk activity, screen flicking (sometimes only wallpaper is visible), etc.

Does this occur with any other screen saver?

But after short period everything returns to normal state.

What is the normal state? Does the screen saver run or not?

I assume that screen saver task is trigerred but it cannot run for some reason. I would like to find out the reason. (low memory?)

If the screen saver starts and suddenly stops, maybe some disk activity disabled it... I think it is not concerned to low memory. Which OS is installed?
What programs and/or services are running in background when the problem occurs?
The best things in life are free.

kecajn

  • Guest
Re:Problems with avast! antivirus screen saver
« Reply #4 on: November 10, 2003, 08:51:50 PM »
If the screen saver timeout expires, the screen saver must start, [...]

Does this occur with any other screen saver?

No, never. I am using build-in screen savers and few others (including SETI) but they always run properly.

But after short period everything returns to normal state.

What is the normal state? Does the screen saver run or not?
I meant that system behaved as without screen saver.



If the screen saver starts and suddenly stops, maybe some disk activity disabled it... I think it is not concerned to low memory. Which OS is installed?
What programs and/or services are running in background when the problem occurs?
Detailed configuration is in my initial post. System is running several background applications such as:
- Kerio Personal Firewall
- Pam Hot-Sync
Memory utilization has been definitely increased after avast! installation (there is much more page swaps than before). It is system with relatively small RAM (72 MB).

The strangest phenomenon is that yesterday screen saver did not work at all (I restarted and powered on system several times). And today it started to run at least twice. Today PC was working about 30 minutes so I am going to observe if it will "forget" to run later.

Best regards,

Jacek

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Problems with avast! antivirus screen saver
« Reply #5 on: November 10, 2003, 09:47:04 PM »
Sorry, Windows NT is not my best...
Did I read your first post correctly? You are using NT? Do you have only 72 Mb of total RAM? I was thinking that you have 72 Mb of free RAM when the problem occurs... Sorry!
Maybe the problem resides on RAM...  :-\
The best things in life are free.

kecajn

  • Guest
Re:Problems with avast! antivirus screen saver
« Reply #6 on: November 11, 2003, 08:53:23 PM »
...
Did I read your first post correctly? You are using NT? Do you have only 72 Mb of total RAM? I was thinking that you have 72 Mb of free RAM when the problem occurs...
...

Yes, it is NT 4 Workstation with 72 MB of physical RAM and PentiumI 120 MHz. It is performing quite well for my purposes!

I observed screen saver today: It is working. I have no idea why yesterday it did not...  We can assume that the problem is solved. But I have one question: Screen saver always starts scanning from the very beginning. Is there any way to start from the last scan end? (i.e. it should work in pause/resume mode. I have a lot of small files in numerous directories. There is a very small chance that scanning will end on one screen saver run - my PC is not very fast.)

Best regards,

Jacek



Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Problems with avast! antivirus screen saver
« Reply #7 on: November 12, 2003, 02:05:26 AM »
...
Did I read your first post correctly? You are using NT? Do you have only 72 Mb of total RAM? I was thinking that you have 72 Mb of free RAM when the problem occurs...
...

Yes, it is NT 4 Workstation with 72 MB of physical RAM and PentiumI 120 MHz. It is performing quite well for my purposes!

I observed screen saver today: It is working. I have no idea why yesterday it did not...  We can assume that the problem is solved. But I have one question: Screen saver always starts scanning from the very beginning. Is there any way to start from the last scan end? (i.e. it should work in pause/resume mode. I have a lot of small files in numerous directories. There is a very small chance that scanning will end on one screen saver run - my PC is not very fast.)

Best regards,
Jacek

Quite good suggestion. Why donĀ“t you post it in the WISHLIST.

For Screen Saver module, I forgot this suggestion. My ones were:

- set the colors of the window background and text
- the "blue window" could be have transparency effects (Windows 2000/XP)
- the movement of the "blue window" could be set to zero (not only from 1 to 60 seconds)
- the window could be a "scroll line" at the bottom of the Screen Saver. With this behavior it will avoid the "screen refresh" problem of the Saver. For example, with "photos" changing in the screen, the avast! window will not left a distortion of colors behind the movement

Happy that everything is working fine...  ;D
The best things in life are free.

kecajn

  • Guest
Re:Problems with avast! antivirus screen saver
« Reply #8 on: November 18, 2003, 12:14:06 PM »
Happy that everything is working fine...  ;D

Screen saver was working seamlessly for several days. It also worked today morning. But not know (no reboot since morning)...

Best regards,

Jacek