Author Topic: Blocking all stites - "Certifikate not valid"  (Read 9568 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Blocking all stites - "Certifikate not valid"
« on: July 22, 2015, 09:32:35 AM »
Hi,

I just did a fresh install of Win XP Pro 32 bit, SP2 on a PC where all partitions where removed and recreated prior to installation. After installing Avast Free 10.3.2223 it blocks all internet sites with a message that the certifikate is invalid.

Even sites like microsoft.com, google.com and avast.com

Browsers tested ie and Firefox 39.0


Offline mikaelrask

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1556
Re: Blocking all stites - "Certifikate not valid"
« Reply #1 on: July 22, 2015, 01:06:18 PM »
hey and welcome to the avast forum. im using the latest avst i have no poblem with this at all. but i can be something with the new added feture in the latest build that gives you problem (stremfilter) you can try to disable it throught the add/remove program uninstall avast and add/remove compontet from avast. did this solve the problem?

second you should consider upgrade windows xp to win 7,8, or 8.1 seens there is no support from windows xp anymore.  ans sp3 forxp been out for years  ;)
Windows 8.1 amd a10-5700 64 bit
12 GB ram 1 tb hard drive. Avast 18, MBAM

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89420
  • No support PMs thanks
Re: Blocking all stites - "Certifikate not valid"
« Reply #2 on: July 22, 2015, 04:31:46 PM »
There was another topic similar to this (possibly not identical) and they found that their system date wasn't correct (very old) which would invalidate any security certificate.

It would be worth a try check the system date day/month/year and adjust if required.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

REDACTED

  • Guest
Re: Blocking all stites - "Certifikate not valid"
« Reply #3 on: July 23, 2015, 09:01:34 AM »
I don't find any module called "Stremfilter" or "streamfilter" to add or remove when i modify the installation.

This is an old 32bit PC that i brought to life to use as a printer server to a Minolta Color laser where no 64 bit drivers are available, i have a lot of color casettes left and want to keep it alive as long as i have casettes.

The DVD i have for XP is SP2, Microsoft have stopped support, and even windows update, for XP so i can't get any updates including SP3.

Probably have to try another anti virus for this PC...


hey and welcome to the avast forum. im using the latest avst i have no poblem with this at all. but i can be something with the new added feture in the latest build that gives you problem (stremfilter) you can try to disable it throught the add/remove program uninstall avast and add/remove compontet from avast. did this solve the problem?

second you should consider upgrade windows xp to win 7,8, or 8.1 seens there is no support from windows xp anymore.  ans sp3 forxp been out for years  ;)

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76029
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Blocking all stites - "Certifikate not valid"
« Reply #4 on: July 23, 2015, 09:11:49 AM »
Workaround: Disable HTTPS-Scanning in the web shield.
W8.1 [x64] - Avast Free AV 23.3.8047.BC [UI.757] - Firefox ESR 102.9 [NS/uBO/PB] - Thunderbird 102.9.1
Avast-Tools: Secure Browser 109.0 - Cleanup 23.1 - SecureLine 5.18 - DriverUpdater 23.1 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

REDACTED

  • Guest
Re: Blocking all stites - "Certifikate not valid"
« Reply #5 on: July 23, 2015, 09:38:13 AM »
I  am also getting this problem, no web access whatsoever ( Firefox and Chrome )and also blocking email ( Pegasus Mail )
This started a few hours ago so I have removed and re-installed Avast 2015 by restarting the computer in safe mode, running AvastClear.exe, and re-installing the Avast direct from the avast server. the problem persists.
I am also running Win XP sp2 , as are the two other machines on my network, and have no problem with those as I hav'nt updated avast on those and don't intend to until this problem is resolved.

Fault description:
Webaccess blocked because certificate is invalid , the names are mostlyavast
 preceeded with a *

example error reports...
"Avast Web Shield has blocked access to this page because the following certificate is invalid *.google.com " when accessing Google UK
"Avast Web Shield has blocked access to this page because the following certificate is invalid *.mathtag.com " when accessing Ebay.co.uk
"Avast Web Shield has blocked access to this page because the following certificate is invalid www.avast.com " when accessing https://www.avast.com

"Mail shield security exclusion " when trying to use Pegasus Mail to access one.com pop3 server the certificate information says
"issued to *.one.com"
"Issued by COMODO RSA Organisation Validation Secure Server CA"
"Valid From 09/04/2014 to 09/04/2017"

If I disable Avast for 10 mins everything functions as it should.

as noted above, this only started after updating the Avast 2015 program.

any help appreciated.




Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re: Blocking all stites - "Certifikate not valid"
« Reply #6 on: July 23, 2015, 02:42:50 PM »
Please send me the log files StreamFilter.log and Mail.log from avast log folder (C:\Documents and Settings\All Users\Application Data\AVAST Software\Avast\log).
Thanks.

REDACTED

  • Guest
Re: Blocking all stites - "Certifikate not valid"
« Reply #7 on: July 23, 2015, 03:59:41 PM »
Avast has become unusable. If I want to look at anything with any web browser I must disable Avast.
This is on two different computers.  We better Not update Avast on the last computer.
Keep getting the "Certificate not valid" on all sites including Avast, Google and even our Church website.
I know that our Church keeps the "Certificates" current....


Offline Mike23

  • Jr. Member
  • **
  • Posts: 55
Re: Blocking all stites - "Certifikate not valid"
« Reply #8 on: July 23, 2015, 06:05:16 PM »
 
Quote
...... so i can't get any updates including SP3.
tomme,
SP3 is available here...& has been for years.
> http://windows.microsoft.com/en-us/windows/service-packs-download#sptabs=xp


REDACTED

  • Guest
Re: Blocking all stites - "Certifikate not valid"
« Reply #9 on: July 23, 2015, 06:40:09 PM »
Please send me the log files StreamFilter.log and Mail.log from avast log folder (C:\Documents and Settings\All Users\Application Data\AVAST Software\Avast\log).
Thanks.
I would if I could, no reply option was presented. how about a valid email address. I have the files requested waiting on my desktop

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89420
  • No support PMs thanks
Re: Blocking all stites - "Certifikate not valid"
« Reply #10 on: July 23, 2015, 08:39:07 PM »
Please send me the log files StreamFilter.log and Mail.log from avast log folder (C:\Documents and Settings\All Users\Application Data\AVAST Software\Avast\log).
Thanks.
I would if I could, no reply option was presented. how about a valid email address. I have the files requested waiting on my desktop

In the information to the left of the post is an email icon (see attached image, click to expand), when you click on that icon it should open an email style interface.

Click on that email address and it should open your email program and the recipient address already filled in. You can then attach your logs to that email and send it/them.
« Last Edit: July 23, 2015, 08:42:45 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

REDACTED

  • Guest
Re: Blocking all stites - "Certifikate not valid"
« Reply #11 on: July 24, 2015, 06:15:01 AM »
I see if this could be cause of SSL scanning. Try turning off that and see if you face any issues.

check the image below. its under setting . avast protection ---> web sheild

Offline davexnet

  • Poster
  • *
  • Posts: 540
Re: Blocking all stites - "Certifikate not valid"
« Reply #12 on: July 24, 2015, 06:16:16 PM »
I thought HTTPS scanning wasn't even an option for XP ?
Al least in 2015.10.2.2218.
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89420
  • No support PMs thanks
Re: Blocking all stites - "Certifikate not valid"
« Reply #13 on: July 24, 2015, 06:30:30 PM »
I thought HTTPS scanning wasn't even an option for XP ?
Al least in 2015.10.2.2218.

Previously it wasn't an option, but it has been for a while.

EDIT: In the previous beta testing and the 10.3.2223 R3 release.
https://www.avast.com/en-gb/release-history
« Last Edit: July 24, 2015, 06:33:34 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline davexnet

  • Poster
  • *
  • Posts: 540
Re: Blocking all stites - "Certifikate not valid"
« Reply #14 on: July 24, 2015, 07:01:27 PM »
Thanks DavidR,
I'm still on 2218.  I'm going to do a clean install of the latest release on my XP
box and check it out.
AMD FX-4300 4GB DDR3
avast free 2279 (Windows XP), MBAM free