Author Topic: "Secure DNS cannot run on this network"  (Read 14933 times)

0 Members and 1 Guest are viewing this topic.

Offline jakob_vejle

  • Newbie
  • *
  • Posts: 8
"Secure DNS cannot run on this network"
« on: August 13, 2015, 07:08:28 PM »
Hi

My Avast says I'm protected, but it does say that Secure DNS cannot run on my network. This happened after installing Win10. How do I solve this?

Furthermore, after installing Win10 Avast told me that there was a problem with AvastSvc.exe and I should check if the firewall blocked it. How do I check this? And is Windows Firewall and Avast Firewall compatible in Win10?

Please answer all three questions. Thank you :-)


/Jakob

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 36992
Re: "Secure DNS cannot run on this network"
« Reply #1 on: August 13, 2015, 07:29:44 PM »
Quote
And is Windows Firewall and Avast Firewall compatible in Win10?
I assume windows firewall is compatibel with there own product windows10   ;D    and so is avast firewall   ;)

have you done a couple of reboots after installing win10 ?

still same message?




Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5417
  • Spartan Warrior
Re: "Secure DNS cannot run on this network"
« Reply #2 on: August 14, 2015, 08:14:49 PM »
I believe I've found a workaround for this error:

Simply put, if I am not already connected at system boot, and already am finding this error, it will persist even with multiple reboots.

Solution:  Connect the system (CAT5 cable) before a cold boot and boot.  Seems avast checks and registers the system early in the boot process for Secure DNS, and will only work if this is done this way.  Any other way is potluck, may work, may not.  Have not checked to see if this works if an automatic wireless connection is made at logon, but suspect this may work also.

No need to be connected after any subsequent start-ups, you can leave the system disconnected if you like.
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.10.2442 (build 20.10.5824.618) UI version 1.0.591.

Offline Nicholas_

  • Newbie
  • *
  • Posts: 2
Re: "Secure DNS cannot run on this network"
« Reply #3 on: October 05, 2015, 12:51:12 AM »
I believe I've found a workaround for this error:

Simply put, if I am not already connected at system boot, and already am finding this error, it will persist even with multiple reboots.

Solution:  Connect the system (CAT5 cable) before a cold boot and boot.  Seems avast checks and registers the system early in the boot process for Secure DNS, and will only work if this is done this way.  Any other way is potluck, may work, may not.  Have not checked to see if this works if an automatic wireless connection is made at logon, but suspect this may work also.

No need to be connected after any subsequent start-ups, you can leave the system disconnected if you like.

Hello mchain,

Please, could you be more specific?

I don't understand why i should connect the cat5 cable before the boot if it is already connected. Do you mean "during the boot"?
It seems like this problem started after the last avast upgrade for no reason, since i haven't change a thing in my network.

I already tried to "fix problems" at the control panel but it didn't help.

Hope you can help me.

Best regards

Offline cruiser25

  • Jr. Member
  • **
  • Posts: 72
Re: "Secure DNS cannot run on this network"
« Reply #4 on: October 05, 2015, 10:46:28 PM »
 Hello I just want to tell you that I have the same problem since 2015-10-03. And have not installed any Windows 10. I´m still using windows 7. There is another thread on this issue if you look after earlier posts from a few days ago on the same subject.
But unfortunally no valid explanation of the problem as far as I can see. Maybe it´s some server issue on the avast side of the connection ? My own concern is if this affects the safety in the safe zone browser so it is safe to use it even if the secure DNS don´t work. And just like you I haven´t done any changes in network settings.

Offline edt

  • Jr. Member
  • **
  • Posts: 26
Re: "Secure DNS cannot run on this network"
« Reply #5 on: October 06, 2015, 05:09:51 PM »
Hello
I am also having the same problem. I am running Avast Premier and the same message appears on the Overview page. I have checked on the Settings under Active Protection and it is telling me secure DNS is active. I am well and truly perplexed  ::)
I have Windows 8.1.
Any help would be greatly appreciated.

Offline diogo5

  • Newbie
  • *
  • Posts: 16
Re: "Secure DNS cannot run on this network"
« Reply #6 on: October 06, 2015, 05:37:56 PM »
Same here. Earlier today when i turned on my computer that message was just there on Avast homepage... "Secure DNS cannot run on this network". But on the settings it says it is on. Hmmmm a friend told me that since i'm using Google's DNS service Avast cant also run its DNS service on my computer. Thing is, why does it say "ON" on the setting, then? And why did that message on the front screen at Avast user interface only came up today when i didn't change ANYTHING in quite some time?

Thanks in advance.

Edit: I'm using Avast Internet Security

Offline streim

  • Full Member
  • ***
  • Posts: 186
  • Kindness goes a long way
Re: "Secure DNS cannot run on this network"
« Reply #7 on: October 06, 2015, 08:47:44 PM »
I posted about this exact issue a few days ago and was told to do an Avast Repair in the control panel.   Well I did and (snarky) I have no clue if it's fixed because my AV firewall will not turn on.
 ???  Now I know it's going through the entire process of doing a clean reinstall.   Ugh...  wasting time.
Intel Core2Duo E4500/Win7 HomePremium SP1/ Avast IT Security 17.5.2303 /Firefox 54.0.2 /NoScript/AdBlockPlus/MBAM and WinPatrol free(all up to date)

Offline diogo5

  • Newbie
  • *
  • Posts: 16
Re: "Secure DNS cannot run on this network"
« Reply #8 on: October 07, 2015, 03:51:07 PM »
So... not even a reply even when a nice bunch of users(in my case a PAYING CUSTOMMER) have the same issue going on. Lots of respect from the Avast "team", no doubts. Maybe i'll just stop using it and move on to a more Custommer friendly AV company.

Offline N@URINE

  • Full Member
  • ***
  • Posts: 167
Re: "Secure DNS cannot run on this network"
« Reply #9 on: October 07, 2015, 06:21:29 PM »
I also have the same issue !!




NourinE

Offline mchain

  • Avast Evangelist
  • Ultra Poster
  • ***
  • Posts: 5417
  • Spartan Warrior
Re: "Secure DNS cannot run on this network"
« Reply #10 on: October 07, 2015, 06:51:32 PM »
I believe I've found a workaround for this error:

Simply put, if I am not already connected at system boot, and already am finding this error, it will persist even with multiple reboots.

Solution:  Connect the system (CAT5 cable) before a cold boot and boot.  Seems avast checks and registers the system early in the boot process for Secure DNS, and will only work if this is done this way.  Any other way is potluck, may work, may not.  Have not checked to see if this works if an automatic wireless connection is made at logon, but suspect this may work also.

No need to be connected after any subsequent start-ups, you can leave the system disconnected if you like.

Hello mchain,

Please, could you be more specific?

I don't understand why i should connect the cat5 cable before the boot if it is already connected. Do you mean "during the boot"?
It seems like this problem started after the last avast upgrade for no reason, since i haven't change a thing in my network.

I already tried to "fix problems" at the control panel but it didn't help.

Hope you can help me.

Best regards

If you are already connected at startup with the CAT5 cable connected, then this workaround should already have worked for you.  If not working then try the second option below.

Seems if offline for a couple of days will impact whether avast secure dns server will automatically connect to system here as I did see the 'cannot connect dns error' for about two minutes into fresh new boot.  After two minutes passed, dns status changed to connected.

Suggest initiating a new manual virus and definitions update and see if dns status changes along with getting newest definitions.  That sometimes seems to work as this will force the avast program to connect to the server(s).  Worth a try.
Windows 10 Home 64-bit 1909 Avast Premier Security version 20.10.2442 (build 20.10.5824.618) UI version 1.0.591.

Offline cruiser25

  • Jr. Member
  • **
  • Posts: 72
Re: "Secure DNS cannot run on this network"
« Reply #11 on: October 07, 2015, 09:45:49 PM »
Ok we are some avast users with the same problem and it seems to have apeared about the same time. None of the so called workarounds works for me anyway. I remember some time ago when it was problem connecting to the avast update servers and that affected people in many different countries. I don´t know if this problem we have now can have something to do with avast servers on their side ? But I find it strange that several people get the same error message at the same time without having done any changes in our network settings. The earlier problem that I refered to took several weeks to fix on the Avast side of the line
and suddenly everything was back to normal. But ofcourse no explanation were given to their users. But comunicating with customers seems not to be the strong side among antiviruscompanies.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 45128
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: "Secure DNS cannot run on this network"
« Reply #12 on: October 08, 2015, 01:01:36 AM »
Reported to Moderators let's see if that get a reply from Avast. :)
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline edt

  • Jr. Member
  • **
  • Posts: 26
Re: "Secure DNS cannot run on this network"
« Reply #13 on: October 08, 2015, 11:33:20 AM »
Reported to Moderators let's see if that get a reply from Avast. :)
Thanks Bob. The problem still persists so any help will be greatly appreciated.

Offline beegolden

  • Full Member
  • ***
  • Posts: 132
Re: "Secure DNS cannot run on this network"
« Reply #14 on: October 08, 2015, 04:11:57 PM »
Reported to Moderators let's see if that get a reply from Avast. :)
Thanks Bob. The problem still persists so any help will be greatly appreciated.

I have the same problem and would appreciate any help. I've tried the suggestions to fix and they don't work.
Thanks!
Win 7 SP1 64-bit; Avast, Free