Author Topic: Update to avast-2.0.0-1  (Read 6998 times)

0 Members and 1 Guest are viewing this topic.

REDACTED

  • Guest
Update to avast-2.0.0-1
« on: October 04, 2015, 12:24:27 PM »
Hi all!
Avast was working fine.
I updated avast to 2.0.0-1 (from avast repository).
And avast service not starts.
Oct  4 20:10:31 mhub avast: Starting daemon.
Oct  4 20:10:31 mhub avast: avldrGetDefinitionsFolder(): Invalid argument
Oct  4 20:10:31 mhub avast: Fatal error. Exiting.

Centos 6.5
avast is licensed.
where is to search problem?
HELP pls!

REDACTED

  • Guest
Re: Update to avast-2.0.0-1
« Reply #1 on: October 04, 2015, 02:49:34 PM »
Problem is solved

Fully remove avast from server:
#yum remove avast

Install newly avast 2.0.0-1
#yum install avast

Chown -R avast:avast on all avast folders.

Offline tumic

  • Avast team
  • Advanced Poster
  • *
  • Posts: 723
Re: Update to avast-2.0.0-1
« Reply #2 on: October 04, 2015, 08:27:57 PM »
Hi,
The standard update with "yum update" should work as well. If it didn't
in your case then there is either some bug there in the update scripts or
you have some system setup that prevents the update from succeeding
(SELinux, AppArmor, non-standard paths/permissions, ...)

It would be interesting to see some logs (eg. log the update process), but
I guess everything is already "gone"?

Offline Frank122

  • Newbie
  • *
  • Posts: 11
Re: Update to avast-2.0.0-1
« Reply #3 on: October 05, 2015, 02:39:49 PM »
I'm using my own update server and had also a problem to update to 2.0.0.1
After changing the update script on my update server from

Code: [Select]
wget -r -N -e robots=off -nH --cut-dirs=2 "http://download.ff.avast.com/lin/`uname -i`/vps/"
to
Code: [Select]
wget -r -N -e robots=off -nH --cut-dirs=2 "http://download.ff.avast.com/lin/`uname -i`/vps9/"
and run a
Code: [Select]
/var/lib/avast/Setup/avast.vpsupdate
on my client server everything works fine again.
So it seemed that the new version need new pattern files and directly after the update there must be done a pattern update before restarting Avast

I didn't find this information in the documentation.
Here for example  http://deb.avast.com/lin/doc/techdoc.pdf
I can find still the old wget command.

So I'm not sure if this is the recommended way for the update to change the wget command from "vps" to "vps9" ?

Offline tumic

  • Avast team
  • Advanced Poster
  • *
  • Posts: 723
Re: Update to avast-2.0.0-1
« Reply #4 on: October 05, 2015, 05:52:22 PM »
So I'm not sure if this is the recommended way for the update to change the wget command from "vps" to "vps9" ?

It's like you suppose - the new 2.x.x version of avast uses different virus definitions that are located
in a different directory ("vps9" ) on the update server. I will update the documentation to reflect this.