Author Topic: Two issues with avast for Linux  (Read 23827 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Two issues with avast for Linux
« on: December 23, 2005, 08:48:47 PM »
Two questions I can't find the answer:

1. How can I enter the license as root?
    Seems to be the only way of making avast! not asking for the license number any time I start the application.

2. Why does the thorough scanning with archive files checked always stop, for me, at /var/run/dbus/pid and does not show the report?
The best things in life are free.

Offline Vlk

  • Moderator
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Two issues with avast for Linux
« Reply #1 on: December 23, 2005, 09:10:04 PM »
1. I don't understand the question. :)
2. Are you saying it HANGS on this file? Or is the program responsive?
If at first you don't succeed, then skydiving's not for you.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #2 on: December 23, 2005, 09:19:03 PM »
1. I don't understand the question. :)
I'll post a screenshot that I see everytime I start avast.

2. Are you saying it HANGS on this file? Or is the program responsive?
Just stop like you see the screenshot. Other programs are running. I can't kill or close avast. No one buttom work. Stop gets 'stopping' forever. Pause pauses but continuing does nothing because the number of tested files stay there in the same, forever.
I don't know how to kill avast... I need to logoff linux to see and post the screenshot.
Wait...
The best things in life are free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #3 on: December 23, 2005, 09:30:34 PM »
After 'crashing' a message about a deleted file appears; Deleted stale lock file '/home/<user>/.vast/lockfile-<user> where <user> is my name.
Besides this one, the other, about avast registration.
Sorry, I'm a newbie when the subject is Linux... learning all the time, frightened and each step...  :-[
« Last Edit: December 23, 2005, 09:33:10 PM by Tech »
The best things in life are free.

Culpeper

  • Guest
Re: Two issues with avast for Linux
« Reply #4 on: December 24, 2005, 06:57:34 AM »
All I can say is that I don't get the license key prompt when I start "avastgui"  It seems to be working fine on my machine.  Did you install using the the rpm file?

But you can start avast as root in Konsole to get your license key file installed properly.

#su
#password
#avastgui

You may also have a file or folder permission conflict where Avast is installed?

« Last Edit: December 24, 2005, 06:59:41 AM by Culpeper »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #5 on: December 24, 2005, 11:44:44 AM »
All I can say is that I don't get the license key prompt when I start "avastgui"  It seems to be working fine on my machine.  Did you install using the the rpm file?
Yes, installation went fine as far I could noticed...

But you can start avast as root in Konsole to get your license key file installed properly.

#su
#password
#avastgui

You may also have a file or folder permission conflict where Avast is installed?
I've installed it at the default folder.
I'll check when I boot Linux later. Now Windows running here  ;D
The best things in life are free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #6 on: December 30, 2005, 02:03:18 PM »
Vlk, the problems persists:

1. If the Linux session is being closed - both in root and user account - and avast GUI is opened, next login with show the message Deleted stale lock file '/home/root/.vast/lockfile-root or Deleted stale lock file '/home/<user>/.vast/lockfile-<user>

2. Scanning is halted (GUI cannot be closed, scanning could not be stopped, pause button is not working) both in root and user account as described before.

3. Update works perfectly both in root and user account.
The best things in life are free.

Dublin

  • Guest
Re: Two issues with avast for Linux
« Reply #7 on: January 03, 2006, 06:09:44 PM »
ad2)
can you try to overwrite installed avast4workstation-1.0.1/lib/avast4workstation/lib/libavastengine-4.so.6.0.2 library with this library version:
http://www2.asw.cz/~mensik/libavastengine-4.so.6.0.7.tar.gz

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #8 on: January 03, 2006, 06:14:06 PM »
ad2)
can you try to overwrite installed avast4workstation-1.0.1/lib/avast4workstation/lib/libavastengine-4.so.6.0.2 library with this library version:
http://www2.asw.cz/~mensik/libavastengine-4.so.6.0.7.tar.gz
When I boot on Linux I'll take a look on this... Thanks Dublin.  ;)
The best things in life are free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #9 on: January 06, 2006, 03:58:42 AM »
Strange or not, my installation does not have this library, but only libavastengine.so.4.5.12.
How do I update to 6.0.2 version? Sorry for the 'extra' work Dublin.
The best things in life are free.

Culpeper

  • Guest
Re: Two issues with avast for Linux
« Reply #10 on: January 07, 2006, 09:36:30 PM »
Techie:

Try looking here for the library:

/usr/lib/avast4workstation/lib/

Remove libavastengine-4.so.6.0.2

copy libavastengine-4.so.6.0.7

rename to libavastengine-4.so.6.0.2

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #11 on: January 07, 2006, 09:48:51 PM »
Remove libavastengine-4.so.6.0.2
But I have only libavastengine.so.4.5.12
Is it the same?
I'm on Windows, need to reboot later. Thanks anyway Culpeper.
The best things in life are free.

Culpeper

  • Guest
Re: Two issues with avast for Linux
« Reply #12 on: January 07, 2006, 10:07:37 PM »
I doesn't matter because dublin's suggestion doesn't work.  The scanner is still stalling in the same place.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Two issues with avast for Linux
« Reply #13 on: January 07, 2006, 10:55:58 PM »
I doesn't matter because dublin's suggestion doesn't work.  The scanner is still stalling in the same place.
Well... this is funny (or ridiculous)  ;D

Dublin, does Alwil want to release the Linux version in other languages? If so, let me know  :)
The best things in life are free.

Culpeper

  • Guest
Re: Two issues with avast for Linux
« Reply #14 on: January 07, 2006, 11:51:56 PM »
 ;D  Maybe!