Author Topic: avastrelay-Permission denied  (Read 4354 times)

0 Members and 1 Guest are viewing this topic.

latifa

  • Guest
avastrelay-Permission denied
« on: January 19, 2006, 01:06:48 PM »
Hi everybody,

I still have a lot of problems with avast :'(
currently I can't send email because of  permission denied. I run avastrelay as avrelay
avastrelay -i localhost:10025 -I localhost:10026 -a /var/run/avast4mailscanner.sock -l /var/log/avast4/avastrelay -u avrelay
then I tryed to send an email on port 10025 :
[root@telecom root]# telnet localhost 10025
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 telecom SMTP avastrelay v1.0.8 - Service ready
helo localhost
250 telecom
mail from: latifa@telecom.test.com
250 Ok
rcpt to: postmater@telecom.test.com
250 Ok
rcpt to: jallal@telecom.test.com
250 Ok
data
451 Message processing failed: Permission denied
Connection closed by foreign host.

when I run avastrelay as root instade of  avrelay I can send the e-mail.
what's the utility  to run avastrelay as an unprevilaged user? and hwo can I resolve problem of permession.

latifa.

Dublin

  • Guest
Re: avastrelay-Permission denied
« Reply #1 on: January 24, 2006, 01:33:41 PM »
Please, check permissions of avastrelay spool directory! The directory must be writeable for avrelay user and readable for avastd daemon.