Author Topic: Avast Firewall Blocking miracast display  (Read 12797 times)

0 Members and 1 Guest are viewing this topic.

Offline zoppl

  • Newbie
  • *
  • Posts: 9
Avast Firewall Blocking miracast display
« on: July 12, 2016, 11:06:30 PM »
Windows 10 miracast display (windows 10 project to wireless screen)  is being block by Avast Firewall and i can not get it to unblock as can confirm its Avast firewall by turn  its firewall off and connection went through then turn avast firewall back on the connection disconnected. i do not know how to  set avast firewall to ignore  Microsoft  vitriol wireless connection. as  the firewall settings is  very nonuser friendly. and turning me off Avast a all together I'm about ready to remove this  app as it very frustrated that it blocks local  windows content. >:(

Offline zoppl

  • Newbie
  • *
  • Posts: 9
Re: Avast Firewall Blocking miracast display
« Reply #1 on: July 13, 2016, 01:35:53 AM »
Windows 10 miracast display (windows 10 project to wireless screen)  is being block by Avast Firewall and i can not get it to unblock as can confirm its Avast firewall by turn  its firewall off and connection went through then turn avast firewall back on the connection disconnected. i do not know how to  set avast firewall to ignore  Microsoft  vitriol wireless connection. as  the firewall settings is  very nonuser friendly. and turning me off Avast a all together I'm about ready to remove this  app as it very frustrated that it blocks local  windows content. >:(


even tho I try to unblock what I think  works Just don't work at or it dos not  read firewall rules  as it stats allow But still blocks  the wireless connection.




Offline andy1494marshall

  • Newbie
  • *
  • Posts: 8
Re: Avast Firewall Blocking miracast display
« Reply #2 on: May 28, 2017, 12:42:45 PM »
Am getting same issue with my surface pro trying to connect to TV, remove a vast it works

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31341
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast Firewall Blocking miracast display
« Reply #3 on: May 28, 2017, 01:00:46 PM »
Setting a exclusion also works (or at least it should if you set it correctly)

Offline andy1494marshall

  • Newbie
  • *
  • Posts: 8
Re: Avast Firewall Blocking miracast display
« Reply #4 on: May 28, 2017, 02:02:14 PM »
XDo you how to add it as never done before


Offline naeem.kaka

  • Newbie
  • *
  • Posts: 1
Re: Avast Firewall Blocking miracast display
« Reply #6 on: July 22, 2017, 08:00:37 PM »
Hi,

I'm having the same problem. When I turn off the firewall the miracast works fine, but with the firewall on it doesn't connect. I know a help link has been posted and have tried to follow it but can't fathom out how to make an exception for miracast. A step by step idiots guide would be appreciated. My operating system is Windows 10.

Many thanks.

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 68624
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast Firewall Blocking miracast display
« Reply #7 on: July 22, 2017, 08:48:32 PM »
Update to the latest version (17.5.2303): https://forum.avast.com/index.php?topic=205786.0
Win8.1 [x64] - Avast PremSec 21.1.2443.B#1 [UI.594] - EEK - Firefox ESR 78.6.1 [NS/uBO/PB] - TB 78.6.1
Avast-Tools: Secure Browser 87.1 - Cleanup P 20.1 - SecureLine 5.9 - Driver Updater 20.2 - CCleaner 5.75
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline pieter32

  • Newbie
  • *
  • Posts: 1
Re: Avast Firewall Blocking miracast display
« Reply #8 on: November 19, 2017, 06:12:53 PM »
Hi Guys,

I am not sure if you are still struggling with these multicast issues. I have a Samsung TV and windows 10 on my laptop. It took me a while, but I finally found that when mirroring your laptop to your TV, your laptop creates a new network connection and my avast by default set that to public a public network. All I  had to do was change it to a private network and boom! My screen mirroring worked like a dream. I hope this helps.

Offline ColinWB

  • Jr. Member
  • **
  • Posts: 27
Re: Avast Firewall Blocking miracast display
« Reply #9 on: April 07, 2018, 12:46:43 PM »
Thanks for this input, it has helped......one thing: should I reset Privacy Setting to Public Network when finished with the screencast?

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 36879
Re: Avast Firewall Blocking miracast display
« Reply #10 on: April 07, 2018, 12:52:08 PM »
FAQ  https://support.avast.com/en-eu

FAQ firewall  https://support.avast.com/en-eu/article/Antivirus-Firewall-Application-Rules

Quote
Private: a lower level of security suitable for when your PC is connected to a trusted network such as your home or work network. This profile enables better connectivity, and permits all communication within the network.


Public: a higher level of security suitable for when your PC is connected to a public network such as in a cafe or airport. Because public networks present greater security risks, no incoming communication is permitted when this profile is set.



Offline grqassim

  • Newbie
  • *
  • Posts: 1
Re: Avast Firewall Blocking miracast display
« Reply #11 on: February 15, 2020, 08:41:28 PM »
Thanks for this input, it has helped......one thing: should I reset Privacy Setting to Public Network when finished with the screencast?

I have same issue and i do same above solution every time need to cast my laptop screen over my TV, but recently after windows upgrade (Version   10.0.18363 Build 18363
)  I unable to find miracast network to change it from Public to Private, your recommendation highly appreciated

Offline nfgr00lz

  • Newbie
  • *
  • Posts: 1
Re: Avast Firewall Blocking miracast display
« Reply #12 on: April 04, 2020, 12:45:01 AM »
I found a solution that worked for me using Avast Premium 20

I combined a lot of the solutions mentioned here and tested with & without each of the below.

1. Go to Protection -> Firewall and set your Network to Private
2. Below that, click Settings and check Internet Connection Sharing Mode
3. On the same page, click System Rules and set both Allow Windows File and Printer sharing & Allow remote desktop connections to this computer to Enabled. Click OK
4. Click Packet Rules and add 4 new rules: (see attached image)
     UDP Local port 67
     UDP Local port 68
     UDP Remote port 67
     UDP Remote port 68
5. Restart your computer for settings to take effect.

The fourth instruction I didn't find on this forum, but I did see a mention of it on this page:
https://knowledge.broadcom.com/external/article?legacyId=tech234761

Not doing any one of these broke it for me...

Works for me, hope it helps you all!