Author Topic: Avast 2014 blocking Sonos  (Read 6462 times)

0 Members and 1 Guest are viewing this topic.

Offline pcblues

  • Newbie
  • *
  • Posts: 7
Avast 2014 blocking Sonos
« on: October 17, 2013, 10:08:58 AM »
Hi,

I just updated to Avast 2014 and for the first time has caused an issue with my Sonos system. I work in tech support for Sonos and am an Avast user for t least 20 years. I am always recommending Avast to customers because there is never a need to add any tcp/udp ports under packet rules. Avast has always worked extremely well with Sonos, until now.
I entered the tcp/udp ports this time but it made no difference.

Here is a link to the Sonos Firewall Support page where they list the ports and also where customers can select their firewall/security product and configure it themselves: https://sonos.custhelp.com/app/answers/detail/a_id/692/kw/firewall/session/L3RpbWUvMTM4MTk5Njg4MS9zaWQvV0NvbHFfQ2w%3D

Could you have a look at this and see how Avast and Sonos can be made compatible again?

Regards

John

Offline pcblues

  • Newbie
  • *
  • Posts: 7
Re: Avast 2014 blocking Sonos
« Reply #1 on: October 18, 2013, 10:06:48 AM »
 I was hoping for a response so I would be in a better position to help Avast/sonos customers who may experience the same issue. I do not really want to resort to advising customers to uninstall Avast.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 66882
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast 2014 blocking Sonos
« Reply #2 on: October 18, 2013, 10:19:44 AM »
Win 8.1 [x64] - Avast PremSec 20.8.2428.B#3 [UI.562] - CC 5.72 - EEK - FF ESR 78.3 [NS/AOS/uBO/PB] - TB 68.12 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline jpcaraco

  • Newbie
  • *
  • Posts: 3
Re: Avast 2014 blocking Sonos
« Reply #3 on: October 27, 2013, 05:30:58 AM »
I am having the same issue.  would love to see a solution

Offline doubledoom

  • Newbie
  • *
  • Posts: 13
Re: Avast 2014 blocking Sonos
« Reply #4 on: October 30, 2013, 08:18:38 PM »
Just to add that I have the same issue.  When firewall is disabled it works.  When firewall enabled it will not.

Offline jpcaraco

  • Newbie
  • *
  • Posts: 3
Re: Avast 2014 blocking Sonos
« Reply #5 on: October 31, 2013, 08:29:21 PM »
I got this reply this morning from Avast!

Quote
Dear Customer,

Thank you for your e-mail and for using avast! as your antivirus solution.

If you are sure that file or program is safe and can’t damage your computer, but the File system shield in avast! for some reason prevents it from running, you can add this file to exclusions in avast! settings. Open the avast! user interface and…
1. Click the ‘SETTINGS’ tab from the pane on the left
2. A new window for ‘Settings’ will appear. From the left pane choose ‘Active protection’. You can see a list of shields available in avast! antivirus. Click on the sprocket-wheel symbol next to the File system shield. A new window 'File system shield settings' will appear.
3. Click on the ‘Exclusion’ tab on the left. You can modify the list of locations which will not be scanned.
4. Click an empty field under the list (or click the ‘Add’ button) and type or browse for path to the file which should be excluded from scanning.
5. Click ‘OK’ to confirm changes.

If I can be of further help in this matter, please do not hesitate to get in touch with me.

i have not tried it yet

Offline jpcaraco

  • Newbie
  • *
  • Posts: 3
Re: Avast 2014 blocking Sonos
« Reply #6 on: October 31, 2013, 08:42:29 PM »
unfortunately, this did not solve the issue for me. 
Please let me know if it works for any of you.  i wonder if there is something additional with my PC or if this solution does not work for any of you.

thanks

Offline pfnoergel

  • Newbie
  • *
  • Posts: 1
Re: Avast 2014 blocking Sonos
« Reply #7 on: November 01, 2013, 12:10:38 PM »
It is a problem with the firewall  :(
If you uninstall only the firewall of avast 2014 it will work, but then you have just the windows firewall  :( :(
I did this on my systems and it runs. I do not know which port/protocol is blocked.
For the moment I have no time for further investigations.

Update: I have three computers. Only one of them has this problem. The 32-bit systems (Vista&Win7)  doesn't show this problem.
Only the Win7 64bit computer has this problem, but sometoimes it runs too ???????
« Last Edit: November 01, 2013, 03:25:21 PM by pfnoergel »

Offline doubledoom

  • Newbie
  • *
  • Posts: 13
Re: Avast 2014 blocking Sonos
« Reply #8 on: November 08, 2013, 06:25:09 PM »
It is fixed version 2014.9.0.2007

Offline Chris597

  • Newbie
  • *
  • Posts: 1
Re: Avast 2014 blocking Sonos
« Reply #9 on: November 08, 2016, 01:58:47 PM »
Avast are completely hopeless when it comes to support weeks of repeating that you need to set up the firewall to accommodate SONOS despite me explaining repeatedly that we have tried everything listed

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Avast 2014 blocking Sonos
« Reply #10 on: November 08, 2016, 02:05:10 PM »
If you set the correct rules in the firewall it is working without a problem.
https://www.avast.com/faq.php?article=AVKB25

Note:
Sonos need to update the information.
Updated 10/24/2016 02:16 PM
Yeah right, and they only show avast IS 2010(!) and 2014(!)