Author Topic: Problema vulnerabilità Rom 0  (Read 14637 times)

0 Members and 1 Guest are viewing this topic.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31345
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: Problema vulnerabilità Rom 0
« Reply #15 on: December 10, 2016, 11:16:19 PM »
Aggiornare il firmware del router se vi è una versione che risolve la vulnerabilità o ottenere un altro router che non ce l'ha.

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #16 on: December 10, 2016, 11:35:19 PM »
Cambiare router quindi risolve definitivamente il problema? Volevo prendere il modem router DLINK 2750B. È un buon router? È affetto dal bug Rom 0?

Ultima cosa, queste sono le voci del virtual server (all'interno del router). Seguendo le indicazioni di Avast (scritte nei precedenti topic) cosa devo piazzare nella voce application?

---

Virtual Server for: Single IP Account
         
Rule Index: 1
   
Application:
FTP oppure SSH, TELNET, HTTPS_Server ecc...

Start Port Number:
   
End Port Number:
   
Local IP Address:

Grazie per l'aiuto!
« Last Edit: December 11, 2016, 10:26:15 AM by FuryAtom »

Offline vianello_85

  • from Italy
  • Full Member
  • ***
  • Posts: 115
Re: Problema vulnerabilità Rom 0
« Reply #17 on: December 11, 2016, 10:27:16 AM »
Verifica anche che il servizio UPnP, se presente, sia disattivato

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #18 on: December 11, 2016, 10:37:06 AM »
Verifica anche che il servizio UPnP, se presente, sia disattivato

Sì ho controllato ed è disattivato. Secondo te comunque il modem router dlink2750b è un buon acquisto? Cambiare router dovrebbe risolvere il problema?

Offline vianello_85

  • from Italy
  • Full Member
  • ***
  • Posts: 115
Re: Problema vulnerabilità Rom 0
« Reply #19 on: December 11, 2016, 10:57:43 AM »
Farei altri tentativi prima di acquistare un nuovo router

Segui i consigli scritti http://www.ilsoftware.it/articoli.asp?tag=DNS-modificati-sul-router-e-redirect-verso-pagine-malevole-come-risolvere_11213 in questa pagina, che sono più o meno quelli standard.

Altrimenti un consiglio che anche in altri forum do è contattare direttamente il produttore, così da capire se c'è qualche "alternativa" per trovare una soluzione, senza provvedere all'acquisto di un nuovo router.

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #20 on: December 11, 2016, 11:01:28 AM »
In questi giorni ho provato a fare delle scansioni in mod provvisoria con Hitman Pro (versione di prova).

Mi ha indicato un driver come minaccia.

Ho rimosso capimg.sys (che si trovava in C:/windows/System 32/Drivers).

Ora, facendo una nuova scansione, mi ha trovato xinputhid.sys (sempre in C:/windows/System 32/Drivers).

Può essere in qualche modo collegato alla vulnerabilità Rom 0 e/o alla pagina che si apre?

Offline vianello_85

  • from Italy
  • Full Member
  • ***
  • Posts: 115
Re: Problema vulnerabilità Rom 0
« Reply #21 on: December 11, 2016, 11:18:46 AM »
Farei molta attenzione a toccare dentro a system32, se tocchi qualcosa di errato puoi avere problemi con il pc con il rischio di formattare tutto.

La falla rom 0 è limitata al router, certo che sei poi ti cambiano dns e quel che ne consegue l'attacco può avvenire nel tuo pc.

Una cosa che non riesco a capire è se i dns te li sei già trovati cambiati,
altrimenti potresti averti beccato un adware https://it.wikipedia.org/wiki/Adware che sono facili a cambiarti la home del tuo browser, reindizzandoti su altri siti.

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #22 on: December 11, 2016, 11:44:47 AM »
Infatti è quello che non riesco a capire neanche io. Ho chiesto aiuto in un altro forum e ho provato praticamente di tutto. Scansione con tutti i programmi più famosi, scansione con Farbar e OTL, installazione di Windows (con e senza chiavetta usb), reset del router.

Dopo aver eliminato varie voci, il problema della pagina che si apre è sempre rimasto (anche dopo la formattazione).

Facendo poi una scansione con Avast, mi ha indicato la vulnerabilità Rom 0 e ho provato in tutti i modi a risolverla ma non riesco. Adesso, anche con i DNS di Google o altri DNS, la pagina si apre sempre.

Ho letto appunto che la vulnerabilità Rom 0 riesce a dirottare il router senza avere le credenziali. Però anche io, dopo aver provato tutto, non capisco più cosa devo fare XD.

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #23 on: December 11, 2016, 11:45:47 AM »
Vi chiedo gentilmente se per caso qualcuno ha voglia di provare a dirmi se c'è qualche utente specializzato in grado di risolvere la questione.

Ho due richieste specifiche e vi chiedo se riuscite a rispondere a tutto.

Ho provato a cambiare modem/router per risolvere la questione vulnerabilità Rom 0.

Ho preso il modem router dlink2750b che non presenta più la vulnerabilità Rom 0 ma la pagina si apre comunque (anche dopo la formattazione con chiavetta).

Per quanto riguarda il router, anche se inserisco una password diversa da admin/admin durante la configurazione guidata, Avast alla fine mi segnala sempre che la mia password è debole.

Avast mi segnala che il mio router è infetto. Mi dice di cambiare la password del pannello da admin/admin ma anche se la cambio mi segnala sempre l'errore.

Un po' di giorni fa (prima di cambiare il router) mi hanno suggerito di formattare tramite chiavetta (ma il problema è rimasto), cosa devo fare?

Comunque quando ho formattato c'erano due partizioni che non sono riuscito a formattare. Forse è lì il problema?

C'è quindi qualche file che rimane dopo la formatazzione tramite chiavetta e infetta il router?
« Last Edit: December 15, 2016, 01:23:47 PM by FuryAtom »

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #24 on: December 15, 2016, 12:37:18 PM »
Ho aggiornato il topic precedente, se per caso qualcuno è pratico di Farbar (o altri programmi) posso inviargli il log (ditemi voi).

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: Problema vulnerabilità Rom 0
« Reply #25 on: December 15, 2016, 03:15:49 PM »
prova a generare una password forte con questo
https://identitysafe.norton.com/it/password-generator

prova a postare l'immagine del finto sondaggio che ti compare
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #26 on: December 15, 2016, 09:23:33 PM »
Non credo sia un problema di password, in sostanza il router è stato infettato subito dopo l'installazione. Anche prima, le password non sono state mai cambiate da un attacco esterno. È forse un problema simile a quello Rom 0 (cioè la connessione viene dirottata senza avere le credenziali del router). Ma ovviamente è solo una supposizione, ho provato praticamente tutto ma il problema è rimasto.

O c'è un virus nel pc che genera l'adware, oppure è un problema legato esclusivamente a impostazioni di connessione. Oppure la causa è un'altra.

Ho fatto uno screen con lo stumento di cattura. Come faccio a piazzare l'immagine?
 

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: Problema vulnerabilità Rom 0
« Reply #27 on: December 16, 2016, 08:21:48 AM »
hai provato a cambiare la password come suggerito?

per postare la pagina segui le istruzioni nel primo link https://forum.avast.com/index.php?topic=144453.0
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline FuryAtom

  • Jr. Member
  • **
  • Posts: 32
Re: Problema vulnerabilità Rom 0
« Reply #28 on: December 16, 2016, 08:22:01 PM »
hai provato a cambiare la password come suggerito?

per postare la pagina segui le istruzioni nel primo link https://forum.avast.com/index.php?topic=144453.0

Sì il problema si presenta con qualunque tipo di password. In sostanza quando clicco su un sito, vengo reindirizzato verso il finto sondaggio. Avast mi dice che i miei DNS sono compromessi ma nessuna password è stata cambiata.

Forse è un problema di accesso remoto (tramite la porta 80) o magari è un virus che è riuscito a resistere alla formattazione e ha infettato nuovamente il router. Ho provato praticamente tutto ma non sono riuscito a risolvere il problema.


Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: Problema vulnerabilità Rom 0
« Reply #29 on: December 19, 2016, 08:24:50 AM »
hai già eseguito il browser cleanup di avast?
hai già eseguito una scansione all'avvio con avast?
succede con tutti i browser (firefox, internet explorer, etc.)?
che sistema operativo hai ? E' aggiornato?
Prova ad eseguire anche una scansione completa con MBAM free.
Se fai ipconfig /all vedi sempre i dns di google o altri?
Se entri nella configurazione del router vedi i dns di google o altri?
« Last Edit: December 19, 2016, 08:29:57 AM by giogio »
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52