Author Topic: Behaviour shield turns off  (Read 15583 times)

0 Members and 1 Guest are viewing this topic.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 66715
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Behaviour shield turns off
« Reply #15 on: October 11, 2017, 05:06:25 AM »
I've even used the Avastclear utility to completely remove Avast, restarted, and downloaded the latest program version (17.7.2314), and it's STILL doing this. I love Avast, and it's the only anti-virus I've used for the last 10 years. But this is becoming worrysome.
Follow the link in Reply #12 and provide your logs.
Win 8.1 [x64] - Avast PremSec 20.8.2427.B#2 [UI.560] - CC 5.71 - EEK - FF ESR 68.12 [NS/AOS/uBO/PB] - TB 68.12 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline maia225

  • Newbie
  • *
  • Posts: 9
Re: Behaviour shield turns off
« Reply #16 on: November 14, 2017, 04:06:14 PM »
This problem started for me only the last two month but I see it is an older bug, still not fixed.
I am using Avast internet security (paid), with windows 7 pro, also for more than 10 years. When can we expect a fix?

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 66715
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Behaviour shield turns off
« Reply #17 on: November 15, 2017, 05:36:54 AM »
This problem started for me only the last two month but I see it is an older bug, still not fixed.
I am using Avast internet security (paid), with windows 7 pro, also for more than 10 years. When can we expect a fix?
Follow instructions: https://support.avast.com/article/33/
Win 8.1 [x64] - Avast PremSec 20.8.2427.B#2 [UI.560] - CC 5.71 - EEK - FF ESR 68.12 [NS/AOS/uBO/PB] - TB 68.12 - SB/CP/SL/DU.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline PDI

  • Avast team
  • Full Member
  • *
  • Posts: 115
Re: Behaviour shield turns off
« Reply #18 on: November 16, 2017, 02:39:01 PM »
Hi all,

we are looking for a volunteer with this problem who is willing to share with us performance log from the system. The best match for the volunteer is that the shield is off every time you reboot/start the system.

So far we can see that the problem of the start is not connected to the shield itself (it tries to run but the system is not responsive as in our environment). Therefore we cannot fix the issue (if it's in the Avast code base) w/o your help.

To maia225: we can fix only issue if we can recreate it on our systems. Unfortunately this is not the case with this issue.

Thanks for cooperation,
PDI

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44082
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Behaviour shield turns off
« Reply #19 on: November 16, 2017, 02:58:35 PM »
Hi all,

we are looking for a volunteer with this problem who is willing to share with us performance log from the system. The best match for the volunteer is that the shield is off every time you reboot/start the system.

So far we can see that the problem of the start is not connected to the shield itself (it tries to run but the system is not responsive as in our environment). Therefore we cannot fix the issue (if it's in the Avast code base) w/o your help.

To maia225: we can fix only issue if we can recreate it on our systems. Unfortunately this is not the case with this issue.

Thanks for cooperation,
PDI
I spent hrs. with Lucas sending many logs, etc. Never solved the problem while I used the Regular Avast release.
I wen't back to the current beta and no longer have the problem.
Don't know what the difference is but if I use the regular (stable) release, Behavior Shield is off after you reboot the system.
When I use the beta, as I am now, All shields are on when the system starts. ??? ??? ???

Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline PDI

  • Avast team
  • Full Member
  • *
  • Posts: 115
Re: Behaviour shield turns off
« Reply #20 on: November 16, 2017, 03:28:02 PM »
Hi Bob3160,

the biggest group of reports is from W7 users and you are W10 user. I may be wrong of course.

We appreciate your help and sharing the system logs. Your system logs were checked by couple of ppl and the root cause was not found in them. The problem in your case is not related to the Behavioral Shield. It suffers only because of someone else and the system didn't even let it to start.

To my request: even if we found the possible issue in your logs. Others may suffer the same symptoms but the root cause may be different and we'd like to compare the logs from more than one user.

Regards,
PDI




Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44082
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Behaviour shield turns off
« Reply #21 on: November 16, 2017, 05:35:00 PM »
Hi Bob3160,

the biggest group of reports is from W7 users and you are W10 user. I may be wrong of course.

We appreciate your help and sharing the system logs. Your system logs were checked by couple of ppl and the root cause was not found in them. The problem in your case is not related to the Behavioral Shield. It suffers only because of someone else and the system didn't even let it to start.

To my request: even if we found the possible issue in your logs. Others may suffer the same symptoms but the root cause may be different and we'd like to compare the logs from more than one user.

Regards,
PDI
So why don't I have any problems running Avast Beta 17.8.2318
But I have a problem running Avast 17.8.2318


.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83749
  • No support PMs thanks
Re: Behaviour shield turns off
« Reply #22 on: November 16, 2017, 09:19:08 PM »
Hi Bob3160,

the biggest group of reports is from W7 users and you are W10 user. I may be wrong of course.

We appreciate your help and sharing the system logs. Your system logs were checked by couple of ppl and the root cause was not found in them. The problem in your case is not related to the Behavioral Shield. It suffers only because of someone else and the system didn't even let it to start.

To my request: even if we found the possible issue in your logs. Others may suffer the same symptoms but the root cause may be different and we'd like to compare the logs from more than one user.

Regards,
PDI
So why don't I have any problems running Avast Beta 17.8.2318
But I have a problem running Avast 17.8.2318


.

Just another example of why I get so bloody annoyed when a supposed beta versions gets released and has the same versions number.

How the hell can it have the same version number and the beta works but the regular release with the same version number doesn't. 

If nothing changed (the definition of the same version number) then nothing should be broken surely ?
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.595) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline PDI

  • Avast team
  • Full Member
  • *
  • Posts: 115
Re: Behaviour shield turns off
« Reply #23 on: November 18, 2017, 09:49:17 PM »
Hi guys,

there may be small differences in the content for the offers as the beta is using different servers than release build but there isn't change in the code between the beta and release builds.

To Bob2160: the problem in your case is the slow start-up of the whole system (it starts in a matter of minutes for both beta and release) and the behavioral shield startup problem is just a consequence of it (the system doesn't give a chance to run the service in release) and to be honest I'm surprised that the shield is running on the beta build. We don't have any proof to say it's because of the Avast AV or it's because other software.

Regards,
PDI

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44082
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Behaviour shield turns off
« Reply #24 on: November 18, 2017, 10:15:35 PM »
Hi guys,

there may be small differences in the content for the offers as the beta is using different servers than release build but there isn't change in the code between the beta and release builds.

To Bob2160: the problem in your case is the slow start-up of the whole system (it starts in a matter of minutes for both beta and release) and the behavioral shield startup problem is just a consequence of it (the system doesn't give a chance to run the service in release) and to be honest I'm surprised that the shield is running on the beta build. We don't have any proof to say it's because of the Avast AV or it's because other software.

Regards,
PDI
All I can add is that since being back on the beta I've never had the Behavior Shield not start at boot time.
While on the regular build, I always needed to turn the Behavior Shield on manually.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v1909 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline chris..

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2267
Re: Behaviour shield turns off
« Reply #25 on: November 18, 2017, 11:46:01 PM »
Hi guys,
...as the beta is using different servers than release build ...
Hi,
Does the agent must access the server before being enabled by system?
is there a faster access to the beta servers at system startup which could explain the system gives a chance to run the service in beta but doesn't in release ?

Offline PDI

  • Avast team
  • Full Member
  • *
  • Posts: 115
Re: Behaviour shield turns off
« Reply #26 on: November 19, 2017, 10:47:38 AM »
Hi Chris05,

no, it doesn't. The comment was to answer general comments about the code difference between beta and release builds with the same build number made by Bob and David. It wasn't related the problem with the shield start at all.

Regards,
PDI

Offline anton.hodge

  • Newbie
  • *
  • Posts: 4
Will Avast every sort this problem out?
« Reply #27 on: November 19, 2017, 02:19:18 PM »
How many months, AVAST? >:(

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4510
  • Whatever will be, will be.
Re: Behaviour shield turns off
« Reply #28 on: November 20, 2017, 12:25:41 PM »
Hi all,

we are looking for a volunteer with this problem who is willing to share with us performance log from the system. The best match for the volunteer is that the shield is off every time you reboot/start the system.

So far we can see that the problem of the start is not connected to the shield itself (it tries to run but the system is not responsive as in our environment). Therefore we cannot fix the issue (if it's in the Avast code base) w/o your help.

To maia225: we can fix only issue if we can recreate it on our systems. Unfortunately this is not the case with this issue.

Thanks for cooperation,
PDI
Hi PDI, what logs you want? There is a Japanese user who is suffered by this issue and I can ask him/her for help.
Main: Win10 Pro 2004 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 20 Premier Beta / Comodo Firewall 12
Mobile: Win10 Pro 2004 32bit, Vista SP2 32bit / Core 2 Duo SU9300 1.2GHz / 4GB RAM / Avast 20 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline cruiser25

  • Jr. Member
  • **
  • Posts: 73
Re: Behaviour shield turns off
« Reply #29 on: December 23, 2017, 10:18:33 PM »
After followng the link I suppose there is no fix in sight in the near or far future. So I might as well get used to turn it on myself. I´m a little confused that they (avast team) can´t recreate the problem. But i´m not an technician so what do I know. As I  recall the problem started after an update of the avast version. I do not longer recall if it was when the bahavior sheild was introduced or if it was at a later time.

Merry Christmas