Author Topic: Insecure Word Press CMS - malware....  (Read 890 times)

0 Members and 1 Guest are viewing this topic.

Offline polonus

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 33576
  • malware fighter
Insecure Word Press CMS - malware....
« on: August 31, 2017, 06:12:48 PM »
See: WordPress Version
4.2.15
Version does not appear to be latest 4.8.1 - update now.

Provider: UK Government Department for Work and Pensions.

Warning User Enumeration is possible
The first two user ID's were tested to determine if user enumeration is possible.

ID   User   Login
1   kandohi@wps-tech.com   kandohiwps-tech-com
2   -   -
It is recommended to rename the admin user account to reduce the chance of brute force attacks occurring. As this will reduce the chance of automated password attackers gaining access. However it is important to understand that if the author archives are enabled it is usually possible to enumerate all users within a WordPress installation.

Warning Directory Indexing Enabled
In the test we attempted to list the directory contents of the uploads and plugins folders to determine if Directory Indexing is enabled. This is an information leakage vulnerability that can reveal sensitive information regarding your site configuration or content.

/wp-content/uploads/ enabled
/wp-content/plugins/ disabled
Directory indexing was tested on the /wp-content/uploads/ and /wp-content/plugins/ directores. Note that other directories may have this web server feature enabled, so ensure you check other folders in your installation. It is good practice to ensure directory indexing is disabled for your full WordPress installation either through the web server configuration or .htaccess.

-http://expleos.com
Detected libraries:
jquery-migrate - 1.2.1 : -http://www.expleos.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1
Info: Severity: medium
http://bugs.jquery.com/ticket/11290
http://research.insecurelabs.org/jquery/test/
jquery - 1.11.2 : (active1) -http://www.expleos.com/wp-includes/js/jquery/jquery.js?ver=1.11.2
Info: Severity: medium
https://github.com/jquery/jquery/issues/2432
http://blog.jquery.com/2016/01/08/jquery-2-2-and-1-12-released/
jquery.prettyPhoto - 3.1.5 : (active1) -http://www.expleos.com/wp-content/themes/inside/js/jquery.prettyPhoto.js?ver=4.2.15
Info: Severity: high
https://github.com/scaron/prettyphoto/issues/149
https://blog.anantshri.info/forgotten_disclosure_dom_xss_prettyphoto
(active) - the library was also found to be active by running code
3 vulnerable libraries detected

F-Grade status: https://observatory.mozilla.org/analyze.html?host=expleos.com

Still a benign web rep report here: https://www.scamadviser.com/check-website/expleos.com

Consider though: http://www.domxssscanner.com/scan?url=http%3A%2F%2Fwww.expleos.com

errors in -http://www.expleos.com/wp-content/themes/inside/js/jquery.hoverIntent.minified.js?ver=4.2.15

Quote
decodingLevel=0] found JavaScript
     error: undefined variable jQuery
     error: undefined variable $.fn
     error: line:1: SyntaxError: missing ; before statement:
          error: line:1: var $.fn = 1;
          error: line:1: ....^
  Adguard blocks and warns on this code...

iFrame detected: -<iframe src="htxps://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d3403.2871367863745!2d74.4346138!3d31.461286599999998!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x391908ea21581ddb%3A0xc85620adf233b3a1!2sAskari+XI%2C+Lahore%2C+Pakistan!5e0!3m2!1sen!2s!4v1432706489362" width="1920" height="350" frameborder="0" style="border:0"></iframe>

See attached txt file for XSS attack detected in this code

And the insecurity plum to top it all: nameserver from an infostealer - hxtp://webairy.com/  really unknown sharing company  :-[

polonus volunteer website security analyst and website error-hunter)
« Last Edit: August 31, 2017, 08:30:15 PM by polonus »
Cybersecurity is more of an attitude than anything else. Avast Evangelists.

Use NoScript, a limited user account and a virtual machine and be safe(r)!