Author Topic: Why is Avast Shield Behavor using so much memory?  (Read 3204 times)

0 Members and 1 Guest are viewing this topic.

Offline Clint18

  • Newbie
  • *
  • Posts: 2
Why is Avast Shield Behavor using so much memory?
« on: November 23, 2017, 03:17:24 AM »
Hi.

I would like to know what is causing this application to use all my physical memory until my computer is no longer operational? What I have recently discovered is that the aswbIDSAgent file is the main culprit, as it was the only application climbing and using large amounts of physical memory.
This is the first time it has happened to me. See picture below.

What I would like to know is what steps I can do, to resolve this problem if it happens again?

I've tried stopping or disabling this service at startup, but windows will not allow me. The same can be said about clicking the "end task" button under "task manager" with no success either.
Restarting the computer does not resolve this either and logging on/off until I try and load my browser again.


Offline ApoC

  • Avast team
  • Jr. Member
  • *
  • Posts: 26
Re: Why is Avast Shield Behavor using so much memory?
« Reply #1 on: November 23, 2017, 03:47:56 PM »
Hello,

you can purge the internal cache by stopping the service and deleting content of "C:\ProgramData\AVAST Software\Avast\IDS\malwareprofile" directory. I would also like to ask what version of product are You using?

We would appreciate if You provide us with the nodes.dat (located on mentioned path) for further analysis of the root cause.

Best Regards.

Offline Clint18

  • Newbie
  • *
  • Posts: 2
Re: Why is Avast Shield Behavor using so much memory?
« Reply #2 on: November 26, 2017, 04:18:42 AM »
Hi.

Thanks for your reply.

My Avast Antivirus is the "free"version. Attached is a copy of my nodes. dat file as a (txt file). Secondly, I have been unsuccessful in trying to "purge" (by stopping or deleting - if that's what you want me to do) as suggested.

The method I am currently using at the moment is, not having Avast boot up when Windows starts, so will require me to start the Avast Antivirus application manually. After doing this, I am able to reconnect successfully online and establish a stable connection with my browser properly. Several times, the Avast Behavior shield has accessed my physical memory again. If this happens, I empty my internet cache, and restart my computer using the above method (where Avast does not load during Windows on start up).

Thanks