Author Topic: Can't use phone, stuck at loading PIN  (Read 777 times)

0 Members and 1 Guest are viewing this topic.

Offline sasasa

  • Newbie
  • *
  • Posts: 3
Can't use phone, stuck at loading PIN
« on: February 09, 2018, 08:52:03 PM »
Hey,

Avast locked my phone, because some jerk made too many wrong unlock attempts (I didn't know that this is activated). I then tried to find the correct PIN (I have about four different in use) but after the fourth attempt or so it doesn't check anymore. If I type a (random) combination of four digits there's a rotating circle, which obviously indicates loading, but nothing happens, even after hours. Resetting the PIN also doesn't work, because of this OAuth issue in Webview. I also tried installing TWRP, but unfortunately the OEM-option is not active in developer options, so flashing doesn't work. Does anyone have an idea what I can do? I'm really giving up on this.

Offline sasasa

  • Newbie
  • *
  • Posts: 3
Re: Can't use phone, stuck at loading PIN
« Reply #1 on: February 10, 2018, 03:28:09 PM »
I forgot to add: Samsung S5 Neo, Marshmallow

Offline sasasa

  • Newbie
  • *
  • Posts: 3
Re: Can't use phone, stuck at loading PIN
« Reply #2 on: February 12, 2018, 09:43:44 PM »
I have to say, that the support of Avast is very dissapointing. I understand that I have to pay to get premium support, but at least a contact form for obvious, bigger, non-trivial issues like mine or some kind of feedback here in the forum would be appropriate, considering Avast is making money with me anyway (ads, user data) and is somehow responsible for the software, especially serious bugs, they produce.

However, I managed to find a kind of workaround, which allowed me to rescue the data of the internal sd card at least, although stuff like contacts and SMS, which are stored in some other paths, are still lost. I connected the phone to my laptop (Ubuntu 17.10) and noticed, that there is a kind of exploit allowing me to mount the sd card even with Anti-Theft locking my phone. If I reboot my phone, there is a delay of a few seconds until Avast starts (SIM removed) where I'm able to unlock my phone and change settings or so. Unfortunately I wasn't quick enough to disable OEM-protection but I found a way to mount, in my case, the sd card instead, which I describe below.

You have to remove the SIM card, reboot the phone and connect it to a computer via USB. When booting is finished quickly unlock your phone, after a few seconds the Avast-PIN window should pop up and your PC shows your device with no folders mounted, because you have to allow data access or something like that on your phone, which you can't, because the PIN screen overlays the corresponding dialogue. But if you click on your device and another folder in turns in nautilus, the PIN screen dissapears, after a few switches, for a short time allowing to quickly accept the dialogue and mount the sd card. This worked once or twice per boot for me, so if you missed it you have to reboot and try again. I don't know, but doubt it, that this works with Windows too.