Author Topic: <SOLVED> Secure Websocket (wss) blocked, can not connect to revocation server  (Read 5848 times)

0 Members and 1 Guest are viewing this topic.

josezulu@hotmail.com

  • Guest
Avast Free Antivirus: 18.1.2326 (build 18.1.3800.0)

Internet Explorer 11 (Windows 7): when accessing an https secure website, the page loads correctly, without issues. However, the sercure websocket (wss://) connection that the browser attempts to do to the same secure host.domain (different port) fails with this error:

"SCRIPT12057: WebSocket Error: Network Error 12057, It was not possible to connect to the revocation server or a definitive response could not be obtained."

Webshield has "Enable HTTPS Scanning" enabled. When I disabled it, the secure websocket connection works fine.

On another PC I have with Windows 7 and IE11, this problem doesn't exist, the page loads and the wss connection is successful.

I noticed one difference between the SSL certificates shown on the PCs:

* when viewing the certificate for the site on the PC that connects to wss, the certificate path shows: Avast Web/Mail Shield Root -> *.google.com -> secure.domain

* but on the PC that doesn't connect to wss, the certificate path shows: Avast Web/Mail Shield Root -> secure.domain
(it's missing the *.google.com step)

Note: the PC where the connection to wss doesn't work had Avast installed for many years, and updated. I removed it with the 'clear' app from Avast and reinstalled the latest version today, but the problem persists. On the PC where wss works, I have installed Avast today for the first time.
Chrome doesn't show this problem, nor do other antiviruses on IE11 (tested on 2 other PCs with other AV brands).

Is there a way to reinstall or flush the certificates? Or any other way to address this issue without having to turn off https scanning?
« Last Edit: February 26, 2018, 07:39:36 PM by J90 »

josezulu@hotmail.com

  • Guest
Re: Secure Websocket (wss) blocked, can not connect to revocation server
« Reply #1 on: February 26, 2018, 07:37:40 PM »
I've fixed this issue:

I'm running a NodeJs https Server with the Websocket attached to it.
The configuration options for the https server only had the "key" and "cert" certificates, I was missing the "ca" certificate.
After I added the "ca" certificate, it worked just fine on IE11.

I hope this may help others in the future, since not everyone is suggesting on their tutorials to add the "ca" certificate, hell not even the Node docs do it.