Author Topic: UI Failed to load.  (Read 738 times)

0 Members and 1 Guest are viewing this topic.

Offline One_Hapless_Gamer

  • Newbie
  • *
  • Posts: 8
UI Failed to load.
« on: January 08, 2019, 08:31:59 AM »
Hey everyone.  So... I'v encountered a sudden, annoying issue with my Avast Premier program.  Now... I've got the subscription for Premier, I have the web browser (not as my primary browser mind you), as well as Avast Cleanup, but after I updated my antivirus definitions in Avast and restarted as it instructed, I now have a red x on my Avast icon in my and it says I'm not protected.  Right clicking says all my shields are on, but trying to go to the user interface, the update/settings page, etc all results in a "UI Failed to load." screen.  Clicking on something like one of the two update options when right clicking the icon gives me an error saying "The RPC server is unavailable".

I tried the simple restart option on that window and it yields no results.  I also tried to use the update as well as the repair option when using the Apps menu to access the uninstall options for Avast - no change in the results.  In fact, with the Repair option, it shows an error of "http server returned error" with no success in trying to repair.  I just wanted to ask before I even consider attempting a clean install - is anyone experiencing a similar issue after updating definitions?  If so, have you been able to resolve this without a clean reinstallation?  If so, please, I'm all ears. .... Eyes.... Digital ears?  You get my meaning.

If I need to clean reinstall though - that includes the browser and Cleanup, doesn't it?  -_-  I really don't want it to come down to that if there is an easier way to resolve this annoyance. 

And miscellaneous information if pertinent - my only other program is MalwareBytes, I recently checked to see if Windows Defender was updated but this was after the issue arose and I thought there was a conflict by Microsoft itself (though it said no definition update to Windows Defender could be done before another restart I made then it said everything was updated), and everything was fine and dandy before my prompt by Avast to restart. 

Edit: Correction... checking the Windows updates again, the same prompt for a Definition Update for Windows Defender Antivirus came up.  Though after going back and checking to see if it would install, it then said I'm up to date.  Odd...
« Last Edit: January 08, 2019, 08:39:37 AM by One_Hapless_Gamer »