Author Topic: version 19.1.2360 - DHCP issue  (Read 1200 times)

0 Members and 1 Guest are viewing this topic.

Offline pfriedel

  • Newbie
  • *
  • Posts: 5
version 19.1.2360 - DHCP issue
« on: January 29, 2019, 11:27:50 PM »
Hi,

I am using a free version of Avast antivirus, so I choose this form of report:

on version 19.1.2360 (build 19.1.4142.454) (OS Win 10 Pro / Home), a DHCP client problem (on multiple installations) has been detected. The system with Avast installed generates a number of Discover requests after ipconfig /release and subsequent ipconfig /renew (the first one is served by DHCP server - the offer, request, ack packets are detected with Wireshark on network together with the packet recording on the Mikrotik router). On next Discover requests with other ID DHCP server respond to them, but client no longer respond to, because a cliento is already "satisfied". On the DHCP server side, the lease record is subsequently discarded by the other MACs and the lease is not registered with other unfinished queries. Once Avast is uninstalled, then everything works as it should. Turning off components/shields does not help. I'm using the free version of the product (used in home environments, by friends or family members). I have been using Avast for 10 years, this is the first serious issue.

Similar/same issue is registered at: https://forum.avast.com/index.php?topic=224540.0

In case of interest, I can provide captured packets for analysis. The first Discover packet looks as full Windowd DHCP discover, others/next are shorter, and requires "only" the Subnet Mask (1) and the Router (3).

I would not want to end the use of the product (after so many years of positive experience and product recommendation) due to this serious error (impact on the functionality of the DHCP client on the operating system and then possible network traffic complications on LAN segment).

thank you for your response
« Last Edit: January 29, 2019, 11:29:54 PM by pfriedel »

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 60372
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: version 19.1.2360 - DHCP issue
« Reply #1 on: January 30, 2019, 05:50:54 AM »
You could try the latest beta: https://forum.avast.com/index.php?board=15
Windows 8.1 [x64] - Avast PremSec 19.7.2388.BC - CC 5.61 - EEK - Firefox ESR 60.8 [NS/AOS/uBO] - TB 60.8 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline pfriedel

  • Newbie
  • *
  • Posts: 5
Re: version 19.1.2360 - DHCP issue
« Reply #2 on: January 30, 2019, 08:45:36 AM »
You could try the latest beta: https://forum.avast.com/index.php?board=15

Tried next steps:
- upgrade of current version to last Beta 19.2.2362 (build 19.2.4172.404) without change - issue persists (multiply DHCP Discover ...)
- uninstall Avast from Win 10 Pro system, after reboot - issue disappeared, everything works as it should (DHCP Discover, Offer, Request, ACK)
- clean install of last Beta, the DHCP behavior changed during installation - issue is back/persist (multiply DHCP Discover ...)

The last Beta contains the same issue.

I do not know from which version the problem occurs, I registered it about 14 days ago in troubleshooting network problems.

Any other recommendation

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 60372
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: version 19.1.2360 - DHCP issue
« Reply #3 on: January 30, 2019, 10:17:28 AM »
Similar/same issue is registered at: https://forum.avast.com/index.php?topic=224540.0
My bad, that's a business version. You'd need to install a business client.
Windows 8.1 [x64] - Avast PremSec 19.7.2388.BC - CC 5.61 - EEK - Firefox ESR 60.8 [NS/AOS/uBO] - TB 60.8 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline pfriedel

  • Newbie
  • *
  • Posts: 5
Re: version 19.1.2360 - DHCP issue
« Reply #4 on: January 30, 2019, 12:01:06 PM »
Similar/same issue is registered at: https://forum.avast.com/index.php?topic=224540.0
My bad, that's a business version. You'd need to install a business client.


I do not care whether the issue is on a business version (https://forum.avast.com/index.php?topic=224540.0) or on a free version (my case), in any case generally Avast business and Avast free by their installation will cause problems with DHCP queries of operating system, and in both cases, causes the same network problems.

I understand that support for a free version can not be adequate to business support. I just try to find a problem and eventually point out and help solve it. As you can see, this is not a unique problem with my installations alone.

In the attachments, I give a preview (Wireshark) of the packet network analysis of the issue, along with the second file (dump of packets - manually added .log extension to attach). This occurs not only on presented LAN, the same occurs on another network with another DHCP server.

Issue occurs only when client interface has no assigned IP (after boot, after ipconfig /release command, and client use Discover - during this generates multiply Discover packets, as I wrote earlier), when client interface has on interface assigned IP (but on DHCP server there is no valid lease for this IP), the renewing works OK (client use only Request and DHCP server reply with ACK)

It is not a good sign that Avast's installation will disrupt the functionality of a substantial network service.
Maybe my contribution will help find the cause and fix the issue.

Thanks for your help and effort

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 60372
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: version 19.1.2360 - DHCP issue
« Reply #5 on: January 30, 2019, 12:06:40 PM »
Problem is that Avast Free isn't designed for such a use case.
Windows 8.1 [x64] - Avast PremSec 19.7.2388.BC - CC 5.61 - EEK - Firefox ESR 60.8 [NS/AOS/uBO] - TB 60.8 [EM] - ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline pfriedel

  • Newbie
  • *
  • Posts: 5
Re: version 19.1.2360 - DHCP issue
« Reply #6 on: January 31, 2019, 08:31:30 AM »
Problem is that Avast Free isn't designed for such a use case.

I understand that, I repeat that I am trying to clarify the findings and contribute to a possible solution.


edit (supplemented information):

By the way:
with the next versions of Avast works everything OK - no DHCP issue:
- 18.2.2328 (build 18.2.3827.0)
- 18.7.2354 (build 18.7.4041.0)

with this versions a DHCP issue (about which I write in posts) occured:
- 18.8.2356 (build 18.8.4084.409)
- 19.1.2360 (build 19.1.4142.454)
« Last Edit: January 31, 2019, 09:13:07 AM by pfriedel »

Offline Jiří Šembera

  • Avast team
  • Jr. Member
  • *
  • Posts: 46
  • Developer/Malware Analyst, former VPS maintainer
Re: version 19.1.2360 - DHCP issue
« Reply #7 on: January 31, 2019, 11:21:46 AM »
Hello pfriedel,

first of all thank you for your time spent on gathering all the details. I've passed this thread to our Windows team for investigation.

Jiri