Author Topic: email protection and ssh tunnel  (Read 2703 times)

0 Members and 1 Guest are viewing this topic.

Offline eider

  • Newbie
  • *
  • Posts: 2
email protection and ssh tunnel
« on: January 12, 2004, 02:02:23 PM »
Hi,

   I use a ssh tunnel to get logged  into my pop3 server, and Avast tries to bind to port 110/25 in my machinne, which conflicts with my tunnel.

  How can I configure avast so I can use my pop3 client, the ssh tunnel and avast?

[]s

Eider

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:email protection and ssh tunnel
« Reply #1 on: January 12, 2004, 02:43:58 PM »
Open the file "C:\Program Files\ALWIL Software\Avast4\DATA\avast4.ini" and add such lines under [MailScanner]:
PopListen=127.0.0.1:111
SmtpListen=127.0.0.1:26

This will change the ports that avast uses. Set these ports also in your mail program.

Offline eider

  • Newbie
  • *
  • Posts: 2
Re:email protection and ssh tunnel
« Reply #2 on: January 12, 2004, 02:49:20 PM »
And avast will conect to my tunnel at 110/25?

Another question: If I have 2 accounts, but only one of them uses the tunnel?

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:email protection and ssh tunnel
« Reply #3 on: January 12, 2004, 06:00:50 PM »
I'm not quite sure how the tunnel works, but if it is a kind of a mail proxy, then the username in the account settings has to be set like this:
NAME#127.0.0.1
It will make avast connect to the address 127.0.0.1, port 110 where the tunnel listens

For the account without the tunnel, it has to be
NAME#POPSERVER

Some info here: http://www.avast.com/forum/index.php?board=2;action=display;threadid=1602;start=0