Author Topic: Excessive Memory Usage  (Read 513 times)

0 Members and 1 Guest are viewing this topic.

Offline kenrbnsn

  • Newbie
  • *
  • Posts: 3
Excessive Memory Usage
« on: September 16, 2019, 02:03:05 AM »
Windows 7 (laptop) Lastest Microsoft updates applied
8Gb memory
1 TB internal disk (170 Gb free)
2 TB external disk

Since the last version 19.7.2388 was installed on September 9th, Avast has been using way too much memory.
See the jpg at the following URL:
https://kenrbnsn_general_files.s3.amazonaws.com/Avast%20Problem.jpg

I've rebooted a few times. Normally after a reboot, my machine is at about 40% memory utilization, now after a reboot it's at close to 80%. I can hardly start up Chrome. It's also using between 25% & 50% of my CPU, which is also unusual.

I have the paid version.

What can I do to remedy this situation?

Thanks in advance,
Ken Robinson

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 61053
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Excessive Memory Usage
« Reply #1 on: September 16, 2019, 08:04:09 AM »
Repair Avast:
1. Avast GUI -> Settings -> Troubleshooting
2. Click on 'REPAIR APP'.
3. Follow instructions.
4. Reboot.
Win 8.1 [x64] - Avast PremSec 19.9.2394.B1 - CC 5.62 - EEK - Firefox ESR 60.9 [NS/AOS/uBO] - TB 68.1.1 [EM] - ABS/ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline rocksteady

  • Sr. Member
  • ****
  • Posts: 378
Re: Excessive Memory Usage
« Reply #2 on: September 16, 2019, 02:50:17 PM »
Ken,
FYI, people on here can be reluctant to click on 3rd party links to view your screenshot photos.
It is easy to upload photo as attachment to your post, just click on "Attachments and other options" below the text box.

Offline kenrbnsn

  • Newbie
  • *
  • Posts: 3
Re: Excessive Memory Usage
« Reply #3 on: September 17, 2019, 04:35:21 AM »
I did the repair as instructed. It's better, but Avast still seems to be taking up more memory than it did a few weeks ago. See attached image.

Sorry about posting the URL to my pic, but it was unclear that clicking on the link below would let me attach images. Most forums I've delt with allow embedded images.

Also, please replace the captcha with a better one.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 61053
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Excessive Memory Usage
« Reply #4 on: September 17, 2019, 07:38:27 AM »
- Other security related software installed..?
- Which AV(s) did you use before Avast..?

PS: Captcha is only needed for your first 3 posts. (Spam protection)
Win 8.1 [x64] - Avast PremSec 19.9.2394.B1 - CC 5.62 - EEK - Firefox ESR 60.9 [NS/AOS/uBO] - TB 68.1.1 [EM] - ABS/ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline kenrbnsn

  • Newbie
  • *
  • Posts: 3
Re: Excessive Memory Usage
« Reply #5 on: September 17, 2019, 01:40:56 PM »
I have used Avast on this machine for as long as I've had it -- over 2 years. It has been the only one I've ever run.

I also run SpyBot and have for years.

One thing I noticed last night and fixed this morning -- the windows icon cache was corrupted, and after following the directions on Microsoft to delete it and reboot, Avast seems to be behaving itself again. So that may have been the root of my problem all along, not Avast.

Re: captcha -- even though it's only displayed for the first 3 posts, you really should try to replace it with re-captcha. The style you use is extremely hard to use -- the first time I saw it, I got it wrong multiple times.


Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 61053
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Excessive Memory Usage
« Reply #6 on: September 17, 2019, 01:49:09 PM »
One thing I noticed last night and fixed this morning -- the windows icon cache was corrupted, and after following the directions on Microsoft to delete it and reboot, Avast seems to be behaving itself again. So that may have been the root of my problem all along, not Avast.
Sounds good, thanks for the feedback.
Win 8.1 [x64] - Avast PremSec 19.9.2394.B1 - CC 5.62 - EEK - Firefox ESR 60.9 [NS/AOS/uBO] - TB 68.1.1 [EM] - ABS/ACP/ASB/ASL.BC
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11704
    • AVAST Software
Re: Excessive Memory Usage
« Reply #7 on: September 17, 2019, 02:37:32 PM »
That's quite interesting if it's connected (could also be a coincidence)...
You don't happen to have a backup of the corrupted cache file, do you?