Author Topic: ashSimpl.exe keeps crashing  (Read 8605 times)

0 Members and 1 Guest are viewing this topic.

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
ashSimpl.exe keeps crashing
« on: September 02, 2006, 04:54:53 PM »
Hello Alwil team !

I tried to fix this problem for the last two days, but it simply won't go away. My Pro license has expired on Sepetember 1st, and I switched back to avast! Home edition. After that, all I've got are some problems.

Config info: Windows XP Professional SP2, up to date on my end. Latest Microsoft Data Access Components (MDAC) 2.8 installed as well as Microsoft Jet Drivers. Besides avast! I have only Ad-Aware and SpywareBlaster installed on my system. It is unbelievable clean and I've never ever had any problems with spyware or adware, nor with viruses. Also, not a single other antivirus ever touched my system... avast! from the beginning.

I also completely uninstalled avast! numerous times... Uninsalled it, rebooted, cleaned reg keys that avast! left behind, rebooted again. Reinstalled avast! from the scracth, and same thing keeps crashing when trying to scan my system.

These are two lines from my avast4.ini file:

Code: [Select]
Database=SQLT
StorageMigratedOK=1

Whenever I try to scan my system, it crashes when scaning hits my partition D:

I think I have a minidump file, but have no clue where and to whom I'm supposed to send it.

Here are few screenshots:









So, please... can someone from Alwil shed some light on this and what do I need to do to make avast! work as it used to ?

Thanks in advance !
« Last Edit: September 02, 2006, 05:23:28 PM by S.Z.Craftec »
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: ashSimpl.exe keeps crashing
« Reply #1 on: September 02, 2006, 06:04:20 PM »
I tried it again, and it happened again.

MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11585
    • AVAST Software
Re: ashSimpl.exe keeps crashing
« Reply #2 on: September 02, 2006, 08:52:22 PM »
I've done a fix that might help (or more precisely, I fixed a problem that might result in sort of random crashes). I'll try to persuade Vlk to release the updated build as beta during the next week, when he comes back from the holidays - so you can check if it helps.

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: ashSimpl.exe keeps crashing
« Reply #3 on: September 02, 2006, 08:57:40 PM »
Ok thanks for prompt respond Igor, you are incredible. I appreciate it a lot !!! ;)

Listen, if it's not too much to ask... what's that problem about ? I mean, why that started to happen after I switched to Home Edition after Pro version was installed on my system for last two years. It was also always up to date and I really never ever had this sort of problems before...

Is it something that's just Home Edition specific or is it just me ?

Thanks again !
Sasha
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11585
    • AVAST Software
Re: ashSimpl.exe keeps crashing
« Reply #4 on: September 02, 2006, 08:59:23 PM »
No, it's rather related to scanned data (which might have changed on your disk in between). Of course, it might be a completely different problem, I'm just guessing.
But there really shouldn't be any difference between Home and Pro version.

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: ashSimpl.exe keeps crashing
« Reply #5 on: September 02, 2006, 09:06:17 PM »
Yes no problems, I was just guessing too...

The problem is my D: partition contains just my backup files (Flash, avast! skins, graphics and some music files). I don't even remember when I was updating it last time, no changes on those files at all. It happened always to crash while scanning partition D:

I also have partition C: and E: and F:

E: and F: are external hard drive.
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11585
    • AVAST Software
Re: ashSimpl.exe keeps crashing
« Reply #6 on: September 09, 2006, 12:50:22 AM »
So, the beta is out... does it help?
Thanks!

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: ashSimpl.exe keeps crashing
« Reply #7 on: September 09, 2006, 12:58:19 AM »
I can't wait to try it... Thanks Alwil !!!

Rebooting... thmmmmmmm... I'm gonne booting to Vista... almost... I better go...  ;D  ;D
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s

Offline szc

  • Avast Evangelist
  • Starting Graphoman
  • ***
  • Posts: 6957
Re: ashSimpl.exe keeps crashing
« Reply #8 on: September 09, 2006, 07:40:19 AM »
So, the beta is out... does it help?
Thanks!


Hi Igor !

ashSimpl.exe does not crash on my system any more, but there are some other issues with manual update when new beta release is installed. It actually downgrades to the previous version of avast! but I am sure you guys are already on it.

See here:
http://forum.avast.com/index.php?topic=23424.msg193246#msg193246
MB: GIGABYTE GA-Z77X-UD3H Intel 7 Series  - LGA1155, CPU: Intel Core i5-3570K - Quad Core, 3.40GHz (3.80GHz Max Turbo), CPU COOLER: Cooler Master Hyper 212 EVO Direct Heat Pipe R2, RAM: 16 GB Kingston HyperX Blu DDR3, VIDEO CARD: Galaxy GeForce GTX 560 Ti - 1GB, GDDR5, POWER SUPPLY: Corsair Enthusiast Series TX750 V2 - 750 Watts, HD: Seagate Barracuda - 2TB, 7200RPM, 64MB, SATA 6Gb/s