Author Topic: Problems with Firewall and internet newtork  (Read 6541 times)

0 Members and 1 Guest are viewing this topic.

Offline omarquo

  • Newbie
  • *
  • Posts: 8
Re: Problems with Firewall and internet newtork
« Reply #15 on: April 09, 2020, 07:12:54 AM »
Is your home network set to private?

Yes, it's set to private but I can not connect my PC to my internet network.

What I have ti do?
I hope this problem will be fix soon

Offline lackschuh

  • Newbie
  • *
  • Posts: 9
Re: Problems with Firewall and internet newtork
« Reply #16 on: April 09, 2020, 10:18:51 AM »
Me too. Worst desktop firewall ever!
Avast go back to version 19.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86678
  • No support PMs thanks
Re: Problems with Firewall and internet newtork
« Reply #17 on: April 09, 2020, 11:01:54 AM »
@  omarquo & lackschuh

Have both of you tried IDF's resolution in Reply #12, not that far above your posts ?

EDIT: Information from an Avast Team member in another topic.
Has the problem with the Firewall been addressed in this version?
The forum is loaded with reports of Firewall issues. Thanks

Hi Bob, if you mean the two problems with Firewall, one related to RDP and one related to its starting as a component, then both of the issues are resolved via microupdate in 20.2 and also we doublechecked it is resolved in this 20.3 BETA version as well. If you refer to different FW problems, please let us know more information. Thank you and have a nice day!

Try restarting your systems, that should trigger the Micro Update and or action it after the restart.
« Last Edit: April 09, 2020, 11:05:18 AM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline lackschuh

  • Newbie
  • *
  • Posts: 9
Re: Problems with Firewall and internet newtork
« Reply #18 on: April 09, 2020, 11:52:08 AM »
@DavidR
I'm gonna try now. Feedback follows.

Offline omarquo

  • Newbie
  • *
  • Posts: 8
Re: Problems with Firewall and internet newtork
« Reply #19 on: April 11, 2020, 12:38:44 PM »
In the last days I restarted a lot of times my PC, I turned off/turned on the firewall on Avast, I repaired the app on the settings but nothing changed.

My PC, I think It depends on the firewall, can not connect on my internet network and the firewall automatically switch everytime from private to public!

It's possibile to have all these troubles with an update?! Some months ago, like I wrote before, there were problems with the bank mode and now this. It's not acceptable for a thing that you had paid for.

I can't believe I paid for this until 2022...

When will be fix?
« Last Edit: April 11, 2020, 12:40:51 PM by omarquo »

Offline IDF

  • Jr. Member
  • **
  • Posts: 34
Re: Problems with Firewall and internet newtork
« Reply #20 on: April 11, 2020, 04:24:27 PM »
You might try what I did.

Stopping/re-starting the Firewall is not helpful.
I never tried the Repair option.

Try this:

Menu > Settings > General > Troubleshooting

Click Add/Modify Components

UNCHECK Firewall
Click Change button

I believe you will then have to restart the computer

When you reboot, Avast will no longer have the firewall component installed. You will not see it in Protection or in Settings. And - your Internet access should now work, because nothing will be blocked.

If your Internet still doesn't work, it's probably not the fault of Avast. You'd probably have to uninstall Avast completely to test that though.

Now, go back to the same settings screen and Add the Firewall back.
You may have to restart Windows, I don't remember.

At this point you'll have to set up the Firewall - set the network to Private and let it rescan.  If you have any custom rules or preferences, you'd need to set them up again.

Offline IDF

  • Jr. Member
  • **
  • Posts: 34
Re: Problems with Firewall and internet newtork
« Reply #21 on: April 11, 2020, 04:42:27 PM »
@DavidR, I think you might have confused things with your Edit, "diluting" or distracting from your suggestion that the OP try the fix that worked for me.

I don't know what the Micro Update is or was that you referred to, but I'm on 20.2.2401 (build 20.2.4.5130.566), release date April 1, 2020 12:55 AM, and it says it is "up to date." "Check for updates" finds nothing new. The firewall in this release is broken - probably their update left some incompatible elements behind, and removing/adding it back forces in a compatible firewall component.

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 47171
  • 62 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Re: Problems with Firewall and internet newtork
« Reply #22 on: April 11, 2020, 05:19:04 PM »
@DavidR, I think you might have confused things with your Edit, "diluting" or distracting from your suggestion that the OP try the fix that worked for me.

I don't know what the Micro Update is or was that you referred to, but I'm on 20.2.2401 (build 20.2.4.5130.566), release date April 1, 2020 12:55 AM, and it says it is "up to date." "Check for updates" finds nothing new. The firewall in this release is broken - probably their update left some incompatible elements behind, and removing/adding it back forces in a compatible firewall component.
David's suggestion was valid. Restarting the system will trigger the micro update.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast Free 22.5, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86678
  • No support PMs thanks
Re: Problems with Firewall and internet newtork
« Reply #23 on: April 11, 2020, 05:58:38 PM »
@DavidR, I think you might have confused things with your Edit, "diluting" or distracting from your suggestion that the OP try the fix that worked for me.

I don't know what the Micro Update is or was that you referred to, but I'm on 20.2.2401 (build 20.2.4.5130.566), release date April 1, 2020 12:55 AM, and it says it is "up to date." "Check for updates" finds nothing new. The firewall in this release is broken - probably their update left some incompatible elements behind, and removing/adding it back forces in a compatible firewall component.

Not sure if I diluted your suggestion, having given your posts location, Reply #12.

Micro Updates are fixes that generally don't need a full blown program update and in general restarting should trigger it.  So first I would have try that (if I had the Avast Firewall) to see if it worked, otherwise move on to the more complex step.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline IDF

  • Jr. Member
  • **
  • Posts: 34
Re: Problems with Firewall and internet newtork
« Reply #24 on: April 11, 2020, 06:58:30 PM »
"Edit" implies to me the new content overrides the prior. But I can see your point too. I wasn't sure why my idea wasn't tried, but perhaps people don't post when fixes work for them.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86678
  • No support PMs thanks
Re: Problems with Firewall and internet newtork
« Reply #25 on: April 11, 2020, 07:37:17 PM »
"Edit" implies to me the new content overrides the prior. But I can see your point too. I wasn't sure why my idea wasn't tried, but perhaps people don't post when fixes work for them.

The EDIT was because I saw the post by an Avast Team member and quoted it, I wanted to give this further information without creating another post in isolation.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline chris..

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2674
Re: Problems with Firewall and internet newtork
« Reply #26 on: April 11, 2020, 08:02:34 PM »
"Edit" implies to me the new content overrides the prior. But I can see your point too. I wasn't sure why my idea wasn't tried, but perhaps people don't post when fixes work for them.
As long as for the procedure you specify, you have to reboot your system, it's hard to know what will solve the problem:
- uninstall / re-install the firewall
or
- emergency update applied

That said, to go in your direction, a simple disabling / enabling of the firewall (without rebooting) had allowed me just after the  program update to recover internet
https://forum.avast.com/index.php?topic=233119.msg1541844#msg1541844
« Last Edit: April 11, 2020, 08:11:39 PM by chris.. »

Offline IDF

  • Jr. Member
  • **
  • Posts: 34
Re: Problems with Firewall and internet newtork
« Reply #27 on: April 11, 2020, 10:44:57 PM »
The chances that anyone having this problem didn't reboot their system seems low to me. I probably rebooted a half dozen times. At first I thought the problem was that Parallels lost connectivity to the Mac, so I also rebooted the Mac multiple times and then the Windows VM. If there is a micro update at Windows VM boot time, it doesn't fix the problems described in this thread. It was on a whim that I finally removed the firewall component.

What you are implying is that a person rebooted only once, after they uninstalled the firewall. That's possible... seems unlikely but possible.

Also, the people posting here including me observed numerous bugs in turning the firewall on or off. On some screens it could not only not be turned on (for instance, the Alerts screen which always said it was off regardless of Settings), but also when they tried to turn it on it reported "Firewall not available." So, turning it on and off, which everyone tried, is a futile endevaor.

Anyway, that's the situation in this thread. Other threads are reporting other problems, like rules not being learned or being learned and then forgotten.

But - that said, I'm just frustrated, and actually do appreciate the efforts by several of you to offer suggestions! You don't have to do so, so thank you for chiming in.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 76239
  • Urlaub/Vacation
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Problems with Firewall and internet newtork
« Reply #28 on: April 12, 2020, 07:42:36 AM »
I don't know what the Micro Update is or was that you referred to, but I'm on 20.2.2401 (build 20.2.4.5130.566), release date April 1, 2020 12:55 AM, and it says it is "up to date." "Check for updates" finds nothing new.
Reboot twice. (Note, the latest build# is 20.2.5130.568)
W8.1 [x64] - Avast PremSec 22.7.7366.BC [UI.713] - Firefox ESR 91.11 [NS/uBO/PB] - Thunderbird 91.11
Avast-Tools: Secure Browser 103.0 - Cleanup 22.2 - SecureLine 5.18 - DriverUpdater 22.2 - CCleaner 6.01
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline chris..

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2674
Re: Problems with Firewall and internet newtork
« Reply #29 on: April 12, 2020, 08:46:47 AM »
I don't know what the Micro Update is or was that you referred to, but I'm on 20.2.2401 (build 20.2.4.5130.566), release date April 1, 2020 12:55 AM, and it says it is "up to date." "Check for updates" finds nothing new.
Reboot twice. (Note, the latest build# is 20.2.5130.568)
Yes, this update was done yesterday at noon for me.
https://forum.avast.com/index.php?topic=233350.msg1542247#msg1542247

Nobody is distributed at the same time, so it is difficult to draw obvious conclusions for universal solutions.
Moreover, for the last few days I have not seen any more topics saying that people are encountering the problem of internet access.
We have moved on to the "ask" problem.
Maybe yesterday's update was made for this problem?
I have just put the parameters back on "ask", I'll keep you informed if the problem is still present or not.

edit:No, the update didn't change anything, there are still tons of requests for the same applications.
« Last Edit: April 12, 2020, 05:03:52 PM by chris.. »