Author Topic: Avast cannot start core shields as the "Allow" button not in System Preferences  (Read 1313 times)

0 Members and 1 Guest are viewing this topic.

Offline jsn.harris

  • Newbie
  • *
  • Posts: 4
I'm running MacOS Catalina, 10.15.5 and Avast Security 14.5. I have uninstalled and reinstalled.

When I try to switch on Core Shields, Avast asks mw to open "System Preferences" but when. I do, there 's no "Allow" button displayed. I have tried running:
sudo /Applications/Avast.app/Contents/Backend/hub/modules/014_fileshield.sh fix; echo $? which results in:
+ BASE_DIR=/Applications/Avast.app/Contents/Backend
+ PLIST=/Applications/Avast.app/Contents/Backend/launch/com.avast.fileshield.plist
+ SERVICE_ID=com.avast.fileshield
+ FILESHIELD_BIN=/Applications/Avast.app/Contents/Backend/services/com.avast.fileshield
+ ESHELPER_BIN=/Applications/Avast.app/Contents/Backend/utils/com.avast.Antivirus.EndpointSecurity.app/Contents/MacOS/com.avast.Antivirus.EndpointSecurity
+ RUN_DIR='/Library/Application Support/Avast/run'
+ PID_FILE='/Library/Application Support/Avast/run/fileshield.pid'
+ KEXT_ID=com.avast.FileShield
+ KEXT=/Applications/Avast.app/Contents/Backend/drivers/AvastFileShield.kext
+ case "$1" in
+ /sbin/kextload /Applications/Avast.app/Contents/Backend/drivers/AvastFileShield.kext
/Applications/Avast.app/Contents/Backend/drivers/AvastFileShield.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

but the 'Allow' button still does not display

Offline bob3160

  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 44522
  • 60 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
Reported to Avast. Let's see if that helps.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 10 Pro v20H2 64bit, 24 Gig Ram, 1TB SSD, AvastOmni 20.7.xxx, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq

Offline jsn.harris

  • Newbie
  • *
  • Posts: 4
Thanks!

Offline denise607

  • Newbie
  • *
  • Posts: 1
I have a similar problem, the Allow button shows but does not 'Allow' the exception. While we wait for Avast does anyone know if the protection is working or I should get something else? Thanks!

Offline .: Mac :.

  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5087
jsn.harris and denise607,

Did you click the lock icon in the bottom left and enter your password? The option requires admin rights to apply see the link below for step by step walk through:

https://support.avast.com/en-eu/article/Mac-Security-High-Sierra-allow-extensions
"People who are really serious about software should make their own hardware." - Alan Kay

Offline jsn.harris

  • Newbie
  • *
  • Posts: 4
Yes, I definitely unlocked the padlock icon with an admin password and the 'Allow' button does _not_ appear.

Offline jakub.bednar

  • Avast team
  • Jr. Member
  • *
  • Posts: 37
Hello,

the System Preferences and the entire Allowance process is completely in Apple's hands. We are just trying to guide you through it. We do know about one bug in the System Preferences. When the System Preferences are already open, the Allow button does not appear. You need to close System Preferences and then open them again.

If it still does not help then I am afraid there is not much we can do and you need to report that bug to Apple.

One of you mentioned that the Allow button is there but you can't click it. This was an issue in High Sierra and we have no reports about it in Catalina. A fix for that is here: https://www.youtube.com/watch?v=XrkiUFtgdYE you can try it out. Maybe it resolves your issue.

Best regards,

Jakub

Offline jsn.harris

  • Newbie
  • *
  • Posts: 4
Hi Jakub,

I've just fixed a similar kext problem with another App. Extensions weren't allowed and no 'Allow' button was displayed. I had to:
  • Start the machine in recovery mode (CMD R)
  • Open Terminal from Utilities
  • run `spctl kext-consent add PXPZ95SK77`
    where PXPZ95SK77 is the team-id for the App
  • restart the machine[\li]π
    • Uninstall and re-install the App

    Could you post the Team ID for Avast to see if the same process works for Avast?

Offline jakub.bednar

  • Avast team
  • Jr. Member
  • *
  • Posts: 37
Hi,

you can get team ID of any signed app by running codesign -dv <path_to_app>.
For Avast it gives TeamIdentifier=6H4HRTU5E3

Best regards,

J.

Offline ddabrahim

  • Newbie
  • *
  • Posts: 19
I also had a similar issue, not sure if it related though.

When I installed Avast few weeks ago on macOS Catalina it was throw me a warning for not being able to enable core shields because of missing permission and asked for my admin password, after was told Avast require full disk access. It was open the System Preferences for me where Avast was shown in the list for requesting permission to access full disk but the box next to it was unchecked.
I checked the box but regardless I was not able to enable core shields and got the warning again about Avast require full disk access even though system preferences shown that Avast did have full disk access.

So what I did is this:

Open System Preferences
Go to Security and Privacy
Select the Privacy tab
Select Full Disk Access
Unlock the padlock
If you have Avast in the list, remove it
Click the + button and select Avast
Check the box next to Avast if not already checked
Lock the padlock
Restart the system

This is how I got the core shields enabled but again, not sure if it related maybe it was something else and I got only lucky.
This whole terminal magic people are posting here is ridiculous, how on earth an application require recovery mode and terminal commands to get it working?
And of course devs blame Apple..LOL
I really would love to see Avast published in the App Store and go through Apple review and yes I would pay 30% extra just to see Avast being forced by Apple to get things done properly.
« Last Edit: August 20, 2020, 11:46:48 AM by ddabrahim »

Offline Philip219

  • Newbie
  • *
  • Posts: 1
ddabrahim: I've tried the System Preferences method, but not working for me. At least as of yet.

I've restarted multiple times.

Agreed, having to use a command line solution seems extreme.

First noticed this issue when I upgraded to OS 10.14. No issues prior to that.

.