Author Topic: Unable to update Virus Definitions in Avast 18.8  (Read 573 times)

0 Members and 1 Guest are viewing this topic.

Offline Odins Eye

  • Newbie
  • *
  • Posts: 14
Unable to update Virus Definitions in Avast 18.8
« on: August 16, 2020, 05:51:10 AM »
Hello, I'm having an issue with Avast Free Anti-virus v18.8.2356 (build 18.8.4084.0). I'm currently running Windows XP MCE SP3. I'm unable to download virus definitions as it gets stuck on "Initializing, please wait...".  However, I can still download and update the definitions via the Download Update section of the Avast website. I've searched the forum and haven't found any info that helps.

I was having the same problem with an older version of Avast (for some reason I can not remember which version it was, I think it was v12) a couple of weeks ago. I tried fixing it by reinstalling but that didn't work so I tried uninstalling Avast and it just gave me an error. After that I used the uninstall utility, removed Avast v12, installed Avast v18 and was fine for awhile. With the new v18 I was able to download the definitions for about 3 days then it started the "Initializing" problem again. Thinking maybe there was a problem with the install of v18 and/or a conflict with all the Avast add-ons I had installed, I decided to uninstall and reinstall as well as only use the minimum amount of components (so I currently only have the 4 Shields and Rescue Disc installed and running). And 3 days later, I'm still having the same problem.

Oddly enough, I was able to temporarily fix the problem one time by turning off Behavior Shield which allowed me to update. I haven't been able to do it since though.

Does anyone have any clue as to what is going on?

Offline rocksteady

  • Advanced Poster
  • **
  • Posts: 1024
Re: Unable to update Virus Definitions in Avast 18.8
« Reply #1 on: August 16, 2020, 10:34:35 AM »
@Odins Eye.
I have not encountered problems with definition updates with v18 on WinXP SP3, but some have had big issues of 100% CPU hogging with the last issued version 18.8 and have rolled back to a previous version.
This thread is good for Avast 18 and XP advice,
https://forum.avast.com/index.php?topic=220639.0
particularly:
https://forum.avast.com/index.php?topic=220639.msg1484900#msg1484900

Have you tried to Repair Avast via UI, or alternative route via Add/Remove programs?
Have you tried a couple of Restarts (not shutdown/startup)

If you do a re-install of Avast, do use the particular version of avastclear designated for this version. There is a link to the specific uninstaller in the thread I have given you above.


 






Offline Cluster-Lizard2014

  • Sr. Member
  • ****
  • Posts: 303
Re: Unable to update Virus Definitions in Avast 18.8
« Reply #2 on: August 16, 2020, 03:09:58 PM »
This maybe entirely unrelated but sounds vaguely similar.

Out of the blue I found I could not update Malwarebytes definitions, I do that manually on a weekly basis and when I checked it showed they were over a week old. I kept on getting a message that my definitions were older than 7 days and do I want to update; I did and yet when it appeared to check before the download it reported I had the latest definitions.

Several hours of uninstalls, use of restore points and reinstalls later I was left with Malwarebytes having no definitions installed at all. Malwarebytes did away with a definitions updater download years ago. :(

What I was left with though was the conclusion something 'external' was the cause of the problem because I'd discovered it was affecting two other PCs as well.

With help I tracked down the cause as being a DNS issue, specifically, CLOULDFLARENET which is being used by my ISP as primary and secondary DNS. Using a DNS viewer program I discovered they were the only two with working status but an odd report that: "DNS queries are not being consistently answered". That remains the case.

When I swapped the primary/secondary DNS to others the Malwarebytes update problem 'magically' disappeared.

So the primary/secondary DNS status is worth checking at least to rule out that being the cause in this case. 
« Last Edit: August 17, 2020, 01:30:35 PM by Cluster-Lizard2014 »

Offline Odins Eye

  • Newbie
  • *
  • Posts: 14
Re: Unable to update Virus Definitions in Avast 18.8
« Reply #3 on: August 17, 2020, 05:48:47 AM »
rocksteady

I've yet to encounter any problems with heavy CPU usage.

Yes, I used the Add/Remove programs repair option on my first installation of v18, and since it didn't do anything, I performed a complete uninstall and reinstalled v18.

I've also tried restarting and it doesn't do anything but get rid of the "Initializing" message.

Yes, I used the v18.8.4084.0 AvastClear to remove Avast. Also, I thought AvastClear was backwards compatible with the older installations? I believe I used a later version of AvastClear (v16 or v17?) to get rid of my v12 Avast. Huh, that might explain the mystery of why I still have the Avast Screen Saver file in my Windows folder... ???

Cluster-Lizard2014

That's interesting, I hadn't thought about my DNS. Since you brought up DNS I'm now wondering if it has something to do with my router. I currently have a second PC hooked up to the router right now with another version of Avast installed. I never use the buggy thing so I wouldn't know if Avast can update its definitions. I'll definitely have to check these out later when I have the chance.

---

Alright, thank you for your replies rocksteady and Cluster-Lizard2014. Even though this problem is annoying I still have the workaround available. I'm honestly more concerned that this might me malware or something but I've yet to see any evidence this is the case though. I'm not having any problems with MalwareBytes and except for my current problem with Avast, everything works just fine. Does anyone know if there are any log/crash files Avast might have created and where to find them?