Author Topic: Lost System Tray icon  (Read 33266 times)

0 Members and 1 Guest are viewing this topic.

buttoni

  • Guest
Re: Lost System Tray icon
« Reply #15 on: October 01, 2006, 11:06:40 PM »
I have had a desktop icon (properties=ashAvast.exe) that I have been able to use all along (just no tray icons).  I also have ashsimple.exe in the normal location.  Both will invoke the user interface.  But what I'm saying is clicking on Updates the User Simple Interface screen does NOTHING.   The program, when it is freshly installed, with all security realtime  turned off before the install,  is not setting itself up correctly for me, with regards to tray icons, updating, Add/Remove Change/Remove screens, or A-ball right click Context Menu features .   TaskManager shows aswUpdSv.exe is running.   But when I click on update VPS the CPU flickers maybe two times and stops I get no confirmation screens telling me any updating is happening or that I am already up to date.  Nothing, nada, zip.  Does anyone there have a machine they can do a clean uninstall/download/fresh install on to see if ALL downloads are doing this from the website?  There are several people reporting this problem now.  I wiill pm you with email for that zip file, but there is definitely more malfunctioning than just the lack of ashDisp.exe.
« Last Edit: October 02, 2006, 05:15:21 AM by buttoni »

Spiritsongs

  • Guest
Downloaded from filehippo.com
« Reply #16 on: October 01, 2006, 11:16:50 PM »
 :)  Hi All :

      Decided to try the "time-consuming" method of solving
      the "problem" . Used the Avast Uninstall Tool, rebooted,
      used "Search > All files and folders" & the search "term"
     "Avast" that resulted in 8 files found ( 2 were cookies ),
     "Delete(d)" them, ran my registry cleaner which "Fixed"
      more Avast "entries". Then went to www.filehippo.com,
      clicked on the Avast link, Selected the "old" version
      4.7.871 and started the download. When it finished,
       clicked the "exe" to start the installation and thereafter
      the 2 Avast "balls" appeared in the System Tray.
      Generated the VRDB, rebooted & the balls still there.
      Merged the icons, did my Settings, ran a scan ( nothing
      detected ) and rebooted. Icon appeared in System Tray.
      By the way, the GUI showed the latest VPS Update of
      0639-4, whereas what I downloaded from the Avast
      site 2 days ago showed 0639-1 . Also configured the
     "Providers" to my liking, which included "terminating" 2
      of them . At this point in time, still have "a" ball in
      System Tray .
      For the near future, I recommend using the filehippo
      site for downloading Avast .

rv56

  • Guest
Re: Lost System Tray icon
« Reply #17 on: October 01, 2006, 11:22:05 PM »
Just signed up as I have been watching this thread for some time now. Sorry for jumping in on this thread....but yes buttoni...I have done everything you have done so far but still no icon by the clock. I have un-installed avast with the tool and downloaded  avast again with a new register key and still the same results. No icon and no ashDisp any where to be found. All my actions I have done the same as you and all results are pretty much the same.

buttoni

  • Guest
Re: Lost System Tray icon
« Reply #18 on: October 01, 2006, 11:30:36 PM »
@ Spiritsong:

My GUI also showing the 0169-1 signature file from my download at the Alwil website.  Thanks for taking the time to give the details of what worked for you.  But Avast folks need to fix the latest version being downloaded at the main website, too.  We shouldn't have to uninstall and go back to the older version.  I want to wait until VLK or a programmer gives further suggestions before taking any steps that may mess things up worse than they already are.  As more users are reporting this now, I think the ball is in their park now, since the upgrade malfunctioned and the fresh downloads do, too.

@David:  I have tried twice to send you a PM.  Both times it doesn't appear to go through.  My outbox shows empty.  Absolutely nothing has gone right in the last two days! :(
« Last Edit: October 01, 2006, 11:37:16 PM by buttoni »

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user
Re: Lost System Tray icon
« Reply #19 on: October 01, 2006, 11:40:06 PM »
Just as an experiment ...

I downloaded the latest avast setup file from the avast website following the avast home edition links ... saved file setupeng.exe to disk.

I just uninstalled (via add/remove programs) my avast 4.7.892.  After rebooting I ran aswclear.exe to remove any leftovers.

Then I ran the setup file.  I selected typical install.  I allowed avast to install to its default directory choice, it installed without any error messages.  I allowed it to restart the system.

On restart the normal avast new install popup screen, it opened the two icons on the task bar and installed an update to VPS.  ashdisp.exe is present in the avast programs folder and ... all appears to look just like a normal clean avast install.

I am running Windows XP SP2 and the Windows XP firewall (I am also behind a router).

Sorry that I cannot recreate the problem.

Spiritsongs

  • Guest
Avast Servers
« Reply #20 on: October 01, 2006, 11:49:19 PM »
 :)  Hi all :

     In the past I seem to recall, on rare occasions, of 1 of the
     Avast Servers going "bad". It was "fixed" in a relatively
     short period of time . I think my download using Avast
     site 2 days ago was from "download24......" !?
     BUT that does NOT explain, unless the VPS Updates use
     the same Servers as the PROGRAM Updates, why the
     Icon(s) ( ashDisp ) "suddenly" "disappeared" from those
     who were using 4.7.871, as buttoni & I, and NOT the
     latest 4.7.892 !?

sev

  • Guest
Re: Lost System Tray icon
« Reply #21 on: October 02, 2006, 12:05:21 AM »
thanks, message sent.


If it doesn't work, would it be worth going with the previous version of avast until teh problem is resolved?  Is that even a possibility?

sev

  • Guest
Re: Lost System Tray icon
« Reply #22 on: October 02, 2006, 02:07:30 AM »
Fixed the disappearing icons... perhaps not a conventional fix, but it worked.

First, David, thank you for the prompt response and for ashDisp.  I extracted it to the Avast4 folder, rebooted just to see, but no icons.  So, I added ashDisp to Comodo's application monitor (don't know if that was encessary or not), then I used Spybot S&D to add ashDisp.exe to the startup list.  Rebooted and they are there!  Ran msconfig just to be sure, and ashDisp is there on the startup list.

Thanks again!  I'll stay posted in here to see if the original problem is figured out (why ashDisp.exe went away in the first place).  Hopefully my fix is all that I need and it's all good as new.  Hopefully.


 ;D 8)

buttoni

  • Guest
Re: Lost System Tray icon
« Reply #23 on: October 02, 2006, 04:59:14 AM »
Alanrf, I would gladly try yet again, from the www.filehippo.com site this time, if I only could.   :'(   But I am no longer able to uninstall my currupted Avast via Add/Remove programs first.   As I mentioned in an earlier post, when I click the Change/Remove button, I no longer get Uninstall, Repair, etc.  buttons at the left, it goes straight to an Install Avast Setup screen, followed by EULA, etc. sequence of screens which fails with the log shown in red on page one this thread.  Aswclear.exe is now the only uninstaller available to me. 

@David:
I feel certain that a copy of ashDisp.exe isn't going to help me.  I have several corrupted program features.  The file would restore the tray icons, but won't fix the updating problem or the incomplete screen choices in ControlPanel's Add/Remove Change/remove screen.  I need to be able to fully purge the corrupted program copy from my system without the ability to do it in Add/Remove Programs.  I could Search/Manual Delete off HDD and Search/Manual Delete in the Registry, if there are no other options available.  Is aswclear.exe able to do a full uninstall off the hard drive or is written to only go after registry leftovers? Perhaps a Windows Run command with some kind of Avast path designation that would invoke the Windows Uninstaller specifically to uninstall Avast?  
« Last Edit: October 02, 2006, 05:22:41 AM by buttoni »

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user
Re: Lost System Tray icon
« Reply #24 on: October 02, 2006, 06:03:37 AM »
aswclear offers the full uninstall of avast ... you will need to point it to the directory in which avast is currently installed. 

In my case the regular uninstall was available via add/remove programs.  I just used aswclear to ensure there were no file or registry remnants for my test uninstall/reinstall.

buttoni

  • Guest
Re: Lost System Tray icon
« Reply #25 on: October 02, 2006, 03:18:18 PM »
That's good to know about aswclear.exe, Alanrf.  Then it should be getting the crucial bits off my system.  I did notice very little left to manually delete, even in the registry. 

I just keep pluggin' with this.  Last night I tried to download the latest version 4.7.892 once again, but this time from filehippo and exactly the same results, unfortunately.  No Go.  I did notice one thing last night.  After the uninstall via aswclear, during my manual file deletions of remnants, Windows would NOT let me delete ashShell.dll.  Could that be significant here?

Anyway, I think I'm going to uninstall with the means available to me and try installing the older version 4.7.871 from filehippo.com like you did, Alanrf, and see if that version will install properly.  At this point, what else can I try?  I'm convinced this lingering ashShell.dll or some other remnant/function "hidden" to me is preventing a successful install and fuly- functional of 4.7.892.  I'll post back my results.

Oh, BTW I ran a SFC /SCANNOW and no corrupt/missing files in Windows System files were found.  So whatever is going on with Add/Remove in Control Panel appears to be just Avast related.
« Last Edit: October 02, 2006, 06:01:35 PM by buttoni »

irishgodfather

  • Guest
Re: Lost System Tray icon
« Reply #26 on: October 02, 2006, 03:21:24 PM »
Same thing here. I can't uninstall it. All it wants to do is install then I get an error.
Will Avast still update?
« Last Edit: October 02, 2006, 03:23:16 PM by irishgodfather »

buttoni

  • Guest
Re: Lost System Tray icon
« Reply #27 on: October 02, 2006, 03:57:57 PM »
@Alanrf

Well, Alan, I uninstalled 4.7.892 using aswclear.exe just now, did all possible manual file/regkey deletions for keywords Alwil, Avast, Ash,Asw (just those that appeared to only be Avast-related).  Rebooted and installed 4.7.871 like you  from the filehippo.com site.  No go.  Same scenario: no tray icons, only dsktop icon, About shows Ver 4.7.871; TskMgr shows same Avast files running, can't update, can't get on-access scanner screens, can't build VRDB, nothing Avast is in Startup list on msconfig and now Windows Security Center baloon tells me my AV is "out of date & I'm at risk" at each reboot  (which I just close). 

Neither version will install & work properly for me now.  SO I GIVE UP, FOLKS.   I have retried 4-5 times now without success from either site.  I have absolutely no other ideas and am leaving this older version on my system until someone on the Avast team can suggest something else to try.  At least the protection side of the program is working, even if signatures are "out of date" according to Windows Security Center pop-up today.  I think the technical problem is "way over my head at this point".   :(
« Last Edit: October 02, 2006, 07:39:39 PM by buttoni »

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86518
  • No support PMs thanks
Re: Lost System Tray icon
« Reply #28 on: October 02, 2006, 04:16:21 PM »
@ irishgodfather
What was there when you clicked the View setup log ?
Can you post the last 30 lines or so of the setup.log file, perhaps someone from the Alwil Team or others can see what the error is about.

Since this Topic relates to Lost system files, what was your reason for (re)installing avast, since you have 5 posts in the forums, I assume you already had avast installed ?
Is this in anyway related to your Topic on Vista, e.g. installing for the first time under Vista ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

buttoni

  • Guest
Re: Lost System Tray icon
« Reply #29 on: October 02, 2006, 06:23:15 PM »
The only program to ask permission of Comodo to connect for either install has been avast.setup, which I granted OUT access.  Shouldn't other Avast files be asking Comodo to connect, like ashMaiSv.exe, ashWebSV.exe and especially aswUpdSv.exe?  They have not as yet on either version reinstalls done in the last two days.  I can do manually in Comodo if I know the "Parent Application" of the three files.

Don't know if this tells you anything, but in the Setup log, the install, as I read down it, looks like all goes OK.  But I sure don't understand all that technical stuff.  Reads pretty much like I remember it reading in months past.  Then each time Setup shows entries like this section (which I assume are attempts to update itself?)

10:21:21 min/gen  Started: 02.10.2006, 10:21:21
10:21:21 min/gen  Running setup_av_pro-367 (871)
10:21:21 nrm/sys  Operating system: WindowsXP ver 5.1, build 2600, sp 2.0 [Service Pack 2]
10:21:21 vrb/sys  Computer WinName: STUDY
10:21:21 min/sys  Windows Net User: SYSTEM
10:21:21 min/gen  Cmdline: /downloadpkgs /noreboot /updatevps /verysilent
10:21:21 vrb/gen  DldSrc set to inet
10:21:21 vrb/gen  Operation set to INST_OP_UPDATE_GET_PACKAGES
10:21:21 min/gen  Old version: 367 (871)
10:21:21 vrb/gen  Install check: 'C:\Program Files\Alwil Software\Avast4\ashDisp.exe' does NOT exist
10:21:21 nrm/gen  SGW32P::CheckIfInstalled set m_bAlreadyInstalled to 0
10:21:21 vrb/sys  Computer DnsName: STUDY
10:21:21 vrb/sys  Computer Ip Addr: XXX.XXX.X.XX
10:21:21 min/gen  GUID: 8bb577c1-ff39-4372-a833-56e7f66a33c7
10:21:21 min/gen  Default server pseudo definition loaded as ''.
10:21:21 nrm/gen  SelectCurrent: selected server 'FailSafeServer' from 'main'
10:21:21 min/pkg  GetPackages - set proxy for inet
10:21:21 nrm/int  SYNCER: Type: use IE settings
10:21:21 nrm/int  SYNCER: Auth: another authentication, use WinInet
10:21:21 nrm/pkg  Transferred files: 0
10:21:21 nrm/pkg  Transferred bytes: 0

10:21:21 nrm/pkg  Transfer time: 0 ms
10:21:21 vrb/fil  NeedReboot=false
10:21:21 min/gen  Return code: 0x20000019 [Unknown error]
10:21:21 min/gen  Stopped: 02.10.2006, 10:21:21

I'll attach the full Setup.log on the currently installed version 4.7.871 for analysis
« Last Edit: October 02, 2006, 07:58:25 PM by buttoni »