Author Topic: Core shields won't load in Mojave  (Read 1757 times)

0 Members and 1 Guest are viewing this topic.

Offline Uh_Clem

  • Jr. Member
  • **
  • Posts: 28
Core shields won't load in Mojave
« on: March 05, 2021, 02:22:32 AM »
I have checked the other posts with this (or similar) symptoms but they all seem to date back more than a year or two with no resolution.

I have two MacBook Pros --- a mid-2010 model running High Sierra and a mid-2014 model with Mojave recently installed (to be able to run TurboTax which no longer supports any OS lower than 10.14).  Avast is running just fine on the High Sierra machine...as it was on the newer one until I installed Mojave in January or late December.  I hadn't noticed that Avast menu bar icon now showed an exclamation point until today, so I can't be sure that it was the new OS or something else but all three Core Shields now display "We're sorry. Your Mac didn't load our extensions.".  I've tried uninstalling and reinstalling Avast Security (free version) according to the steps given in the article on allowing permissions, since there didn't seem to be any other way to invoke the Setup Wizard.  I noted with some dismay --- as others have reported --- that the Wizard did NOT walk me through the System Preferences step and that, when I opened the Preferences manually, there was no Allow button (nor do I remember having to do this when I went from Sierra to High Sierra).

I tried the sudo kextutil Terminal command and got the results (shown in the attachment) indicating a Memory allocation failure.

I can't see running very long without Core Services, so I'll probably be switching to another Antivirus package unless I can get a quick answer to the problem.

Thank you.

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 394
Re: Core shields won't load in Mojave
« Reply #1 on: March 08, 2021, 09:31:36 AM »
Hello,
unfortunately this is a very old bug in MacOS that Apple has not been able to fix for several years; lately the frequency of occurrences has increased. We can not help you with this; unfortunately it is probable that every other AV will have similar problem with loading their kernel extension.
Kind regards,
Ondrej Kolacek