Author Topic: Prevent web protection / proxy configuration prompt on MacOS  (Read 1754 times)

0 Members and 1 Guest are viewing this topic.

Offline avaskedb4

  • Newbie
  • *
  • Posts: 2
Prevent web protection / proxy configuration prompt on MacOS
« on: March 30, 2021, 12:59:23 AM »
Hi,

I use my personal MacBook for work (BYOD).  I use most features of Avast but I don't want to use the web browsing threat protection (the company I work for mandated the installation of MalwareBytes Endpoint Protection & BrowserGuard for this).

I would like to disable the notifications that keep popping up where Avast is asking to install proxy configurations for the web protection (see the screen grab below).  Can anyone advise how to achieve this please?



Thanks in advance

Offline ondrej.kolacek

  • Avast team
  • Sr. Member
  • *
  • Posts: 394
Re: Prevent web protection / proxy configuration prompt on MacOS
« Reply #1 on: March 31, 2021, 09:17:52 AM »
Hello,

unfortunately currently there is no GUI flow that allows you to avoid allowing this, however you can
1) allow it
2) disable Web shield, Mail shield (and Real Site for paid product) in the GUI
3) go to System Preferences, Network, and in the list there remove all items with Avast Security (do not forget to click Apply before leaving!)
This will revert the state to the one you are in right now.

An alternative would be to run the following commands in Terminal:
Code: [Select]
sudo /Applications/Avast.app/Contents/Backend/utils/com.avast.cfgctl -f com.avast.proxy.conf -t mailshield -v enabled -b false
sudo /Applications/Avast.app/Contents/Backend/utils/com.avast.cfgctl -f com.avast.proxy.conf -t webshield -v enabled -b false
sudo /Applications/Avast.app/Contents/Backend/utils/com.avast.cfgctl -f com.avast.securedns.conf -t securedns -v enabled -b false
sudo killall -hup com.avast.proxy
sudo killall -hup com.avast.securedns
killall Avast

The reason why this is so awkward is because of a chicken egg problem - you need to turn off all the components which need you to allow the network traffic interception, however our GUI only displays the on/off button when the component is running or disabled, not in an error state (which is which you are in right now until you allow it). Changing this would require going through our GUI designers, which is a daunting task :) and the issue has been deemed as a low priority. I will try to escalate it.

Kind regards,
Ondrej Kolacek