Author Topic: Problem with redirect POP ports at Avast 4.7 Home Edition  (Read 11929 times)

0 Members and 1 Guest are viewing this topic.

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Problem with redirect POP ports at Avast 4.7 Home Edition
« on: January 14, 2007, 01:13:17 AM »
Dear Collegues!
I am sorry, my English very bed.....
I have Mozilla TB 1.5.0.9 and Avast 4.7 Home Edition
I have two accounts - Gmail and standart mail account with POP3 (port 110) and SMTP (port 25)
I installed and configured Stunnel. This configuration works OK.
my stunnel.conf
client = yes
Service-level configuration
[gmail-pop3s]
accept  = 12110
connect = pop.gmail.com:995
[gmail-smpt]
accept  = 12025
connect = smtp.gmail.com:587

my TB Setting
1.Standard account  POP3 and SMTP - worked correct
2. Gmail account
a) POP - servername - localhost, port -12110, login loginname@gmail.com
b) SMTP  -  servername - localhost, port -12025, login loginname@gmail.com
When I turned off avast the mail accounts worked correct - they either send and recieved mail - everything ti's OK

After setup Stunnel and Mozzila TB i wrote in avast4.ini next lines
[MailScanner]
Log=20
SmtpListen=127.0.0.1:12025
PopListen=127.0.0.1:12110
PopRedirectPort=110,12110
SmtpRedirectPort=25,12025
ImapRedirectPort=143
NntpRedirectPort=119
IgnoreAddress=
IgnoreLocalhost=0
AutoRedirect=1
StartPop=0
StartSmtp=1
StartImap=0
StartNntp=1
ShowTrayIcon=1
When I turn on Avast, I can sent and recieved mail from my standart account (POP3:110 and SMTP:25), which Avast scaned - incoming and outcoinmg mail, its OK
When I wrote mail and  I sent from Gmail account - it's OK, avast scaned this outcomig mail - it's OK.
But when I want incoming mail on Gmail account I see next TB message - POP server internal error and stunnel log write:
2007.01.14 03:04:06 LOG5[3536:2344]: gmail-pop3s accepted connection from 127.0.0.1:1401
2007.01.14 03:04:06 LOG5[3536:2344]: gmail-pop3s connected remote server from 10.126.1.2:1402
2007.01.14 03:04:07 LOG5[3536:2344]: Connection closed: 66 bytes sent to SSL, 216 bytes sent to socket
Pese, advise me to solve this problem....
Best Regards, Vadim Mc 

Offline sergofun

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1640
  • Hello, world>_
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #1 on: January 14, 2007, 01:25:41 AM »
I'm not sure but I think you need to add in avast4.ini ports 1401 and 1402.
Also I don't think that avast! is the reason of this problem. Do you have a firewall?

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #2 on: January 14, 2007, 01:37:22 AM »
I'm not sure but I think you need to add in avast4.ini ports 1401 and 1402.
Also I don't think that avast! is the reason of this problem. Do you have a firewall?

This ports aren't constant values, see more big stunnel log

2007.01.14 02:36:25 LOG5[3536:1840]: gmail-pop3s accepted connection from 127.0.0.1:1351
2007.01.14 02:36:25 LOG5[3536:1840]: gmail-pop3s connected remote server from 10.126.1.2:1352
2007.01.14 02:36:31 LOG5[3536:1840]: Connection closed: 72 bytes sent to SSL, 252 bytes sent to socket
2007.01.14 02:41:26 LOG5[3536:2276]: gmail-pop3s accepted connection from 127.0.0.1:1360
2007.01.14 02:41:26 LOG5[3536:2276]: gmail-pop3s connected remote server from 10.126.1.2:1361
2007.01.14 02:41:27 LOG5[3536:2276]: Connection closed: 66 bytes sent to SSL, 217 bytes sent to socket
2007.01.14 02:46:26 LOG5[3536:2384]: gmail-pop3s accepted connection from 127.0.0.1:1370
2007.01.14 02:46:26 LOG5[3536:2384]: gmail-pop3s connected remote server from 10.126.1.2:1371
2007.01.14 02:46:27 LOG5[3536:2384]: Connection closed: 66 bytes sent to SSL, 216 bytes sent to socket
2007.01.14 02:51:26 LOG5[3536:2544]: gmail-pop3s accepted connection from 127.0.0.1:1392
2007.01.14 02:51:26 LOG5[3536:2544]: gmail-pop3s connected remote server from 10.126.1.2:1393
2007.01.14 02:51:27 LOG5[3536:2544]: Connection closed: 66 bytes sent to SSL, 217 bytes sent to socket
2007.01.14 02:56:26 LOG5[3536:304]: gmail-pop3s accepted connection from 127.0.0.1:1394
2007.01.14 02:56:26 LOG5[3536:304]: gmail-pop3s connected remote server from 10.126.1.2:1395
2007.01.14 02:56:27 LOG5[3536:304]: Connection closed: 66 bytes sent to SSL, 217 bytes sent to socket
2007.01.14 03:01:26 LOG5[3536:3008]: gmail-pop3s accepted connection from 127.0.0.1:1399
2007.01.14 03:01:26 LOG5[3536:3008]: gmail-pop3s connected remote server from 10.126.1.2:1400
2007.01.14 03:01:27 LOG5[3536:3008]: Connection closed: 66 bytes sent to SSL, 217 bytes sent to socket
2007.01.14 03:04:06 LOG5[3536:2344]: gmail-pop3s accepted connection from 127.0.0.1:1401
2007.01.14 03:04:06 LOG5[3536:2344]: gmail-pop3s connected remote server from 10.126.1.2:1402
2007.01.14 03:04:07 LOG5[3536:2344]: Connection closed: 66 bytes sent to SSL, 216 bytes sent to socket

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #3 on: January 14, 2007, 09:44:31 AM »
Who have any ideas about solve this problems?

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #4 on: January 14, 2007, 10:33:57 AM »
I am sorry I cannot help with the setup for STunnel but I'm sure some others here will soon.

I find it much easier to use the Webmail extensions of Thunderbird for GMail.  The code only runs when Thunderbird is in use and it requires just one check in the user interface of avast to get the mail scanned.


Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #5 on: January 14, 2007, 01:14:26 PM »
This ports aren't constant values, see more big stunnel log
These ports are used by Stunnel but they aren't shown in any other configuration.

I think problem is on security used by TB to communicate.
You should NOT use secure communication option into TB settings.
The best things in life are free.

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #6 on: January 14, 2007, 02:26:28 PM »
This ports aren't constant values, see more big stunnel log
These ports are used by Stunnel but they aren't shown in any other configuration.

I think problem is on security used by TB to communicate.
You should NOT use secure communication option into TB settings.
What does this mean?
Ether mail account use POP3 - first uses standart 110 port, Gmail - 12110 port.....
There is standrt acount incoming and outcoming mail scans Avast, everyting OK...
Gmail account does'n recive mail (sorry, I made mistake when I wrote - when Avast TurnOn) but sends outcoming message, which Avast scan....
Wnen I turn off Avast - Gmail accounts work OK and sent and recieve message....   
« Last Edit: January 14, 2007, 07:23:20 PM by Vadim Mc »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #7 on: January 14, 2007, 02:52:20 PM »
I think problem is on security used by TB to communicate.
You should NOT use secure communication option into TB settings.
Please, go TB, Tools > Accounts (configuration) > Server folder of settings and post a screenshot here.

To know how to post a screenshot, see http://forum.avast.com/index.php?topic=8982.0
You can use WinSnap to get a screenshot (http://www.ntwind.com/software/winsnap.html).

POP3 uses 110, ok.
GMail with Stunnel will use, in your settings, 12110, ok.
The other ports listed there seems to be 'internal' communication between Stunnel and Thunderbird, and NOT external ports (from Stunnel to Internet).
The best things in life are free.

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #8 on: January 14, 2007, 07:44:56 PM »
I think problem is on security used by TB to communicate.
You should NOT use secure communication option into TB settings.
Please, go TB, Tools > Accounts (configuration) > Server folder of settings and post a screenshot here.

To know how to post a screenshot, see http://forum.avast.com/index.php?topic=8982.0
You can use WinSnap to get a screenshot (http://www.ntwind.com/software/winsnap.html).

POP3 uses 110, ok.
GMail with Stunnel will use, in your settings, 12110, ok.
The other ports listed there seems to be 'internal' communication between Stunnel and Thunderbird, and NOT external ports (from Stunnel to Internet).
I have a Russian localization TB, see this picture

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #9 on: January 14, 2007, 07:52:15 PM »
My PC placed in local homenetwork....
All users use local smtp server - that don't spam from lolcal machine
I use fo Gmail account our intrenal smtp mail server with 25 port
The mail oiutcoming from Gmai account ok and checking Avast....
The major problem - scan incoming mail...
See second picture

Offline sergofun

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1640
  • Hello, world>_
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #10 on: January 14, 2007, 08:56:05 PM »
Vadim Mc, а почему бы не попробовать пообщаться на русскоязычном форуме http://avast.ru/forum/ ? :)
(Vadim Mc, why we can't discuss this subject on Russion language in the forum http://avast.ru/forum/ ? :) )
« Last Edit: January 14, 2007, 09:43:26 PM by sergofun »

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #11 on: January 14, 2007, 10:22:30 PM »
Привет, земляк...
Потому что я там не нашел обсуждения этих тем - искал по POP and Gmail....
Да и наши земаны как то все агрессивно настроены к друг другу, а мне вообще то дельный совет нужен а не флейм и флудерство, прочитал ветку почему Аваст бесплатен - как то расхотелось задавать вопросы на русском форума:)
В принципе, когда не сканер  Аваст не включен на сканирование входящей почты работает и стандартный ПОП и  Gmail.... Стоит только включить сканер входящей почты - даже по одному 110 порту (не добавляя в редирект 12110)  - стандартный ПОП работает, а Gmail начинает выдавать такую надпись
Вроде бы я по английски нормально все объясняю... Проблема именно с входящей почтой Gmail по порту 12110

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #12 on: January 14, 2007, 10:29:13 PM »
Vadim, I can't understand a word in Russian  :'(
But comparing with the same positions in my TB windows, your configurations seems ok.
Are you sure Stunnel is running at that time, are you sure you've allowed Stunnel and avast mail provider to connect the Internet into your firewall settings?
The best things in life are free.

Offline Vadim Mc

  • Newbie
  • *
  • Posts: 14
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #13 on: January 14, 2007, 10:37:14 PM »
Sorry, I translate my pictures to English

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: Problem with redirect POP ports at Avast 4.7 Home Edition
« Reply #14 on: January 14, 2007, 11:05:40 PM »
Sorry, I translate my pictures to English
As I've stated before, I can compare the windows... no need to translate.
Maybe you can add the following line to the [MailScanner] section of <avast>\data\avast4.ini:

Log=20

Then generate some traffic, simulate the problem (i.e. force the avast mail scanner to time out by sending an email with attachment) and then post here the contents of the file <avast>\data\log\aswMaiSv.log
The best things in life are free.