Author Topic: Avast Home with Web Washer Classic  (Read 6374 times)

0 Members and 1 Guest are viewing this topic.

Offline se224141

  • Full Member
  • ***
  • Posts: 199
Avast Home with Web Washer Classic
« on: August 31, 2007, 04:08:18 AM »
I wish to use Avast Home with Web Washer Classic for ad blocking.

Web Washer Classic uses proxy as localhost:8080 and Avast's web shield localhost:12080.

How do I configure Web Washer Classic and my browser in order to use both the programs?



Avast Home Edition

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67249
Re: Avast Home with Web Washer Classic
« Reply #1 on: August 31, 2007, 02:33:24 PM »
For IE - broadband users: - Tutorial - Web Shield Proxy Set-up for IE
For IE - dialup users - Tutorial - Web Shield Proxy Set-up for IE (Dial-up)
For Firefox users - Tutorial - Web Shield Proxy Set-up for Firefox

Into avast! WebShield settings uncheck the option 'Ignore local communication' in the first 'Basic' tab.
Then enter the number for the redirected HTTP port, in your case, 8080.
Configure your browser to use a proxy (like if you do not have avast!). I mean:

Internet Explorer: Tools > Internet Options > Connections > Lan Settings > Check 'Use a proxy server'.
Firefox: Tools > Options > General > Connections Settings > UnCheck 'Direct connection to the Internet' and check the proxy.

Then, use:
Server: 127.0.0.1
or
localhost
and the port used: 8080.

It's easy...  8)
The best things in life are free.

Offline se224141

  • Full Member
  • ***
  • Posts: 199
Re: Avast Home with Web Washer Classic
« Reply #2 on: August 31, 2007, 03:33:36 PM »
Thanx. Do I also have to edit .ini file to include the following?

OptinProcess=wwasher.exe


For IE - broadband users: - Tutorial - Web Shield Proxy Set-up for IE
For IE - dialup users - Tutorial - Web Shield Proxy Set-up for IE (Dial-up)
For Firefox users - Tutorial - Web Shield Proxy Set-up for Firefox

Into avast! WebShield settings uncheck the option 'Ignore local communication' in the first 'Basic' tab.
Then enter the number for the redirected HTTP port, in your case, 8080.
Configure your browser to use a proxy (like if you do not have avast!). I mean:

Internet Explorer: Tools > Internet Options > Connections > Lan Settings > Check 'Use a proxy server'.
Firefox: Tools > Options > General > Connections Settings > UnCheck 'Direct connection to the Internet' and check the proxy.

Then, use:
Server: 127.0.0.1
or
localhost
and the port used: 8080.

It's easy...  8)
Avast Home Edition

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85572
  • No support PMs thanks
Re: Avast Home with Web Washer Classic
« Reply #3 on: August 31, 2007, 03:39:10 PM »
I wouldn't think so as by default adding the 8080 port to the redirects that traffic will be scanned.

You should only need to OptinProcess for unsupported 'browsers.'
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline se224141

  • Full Member
  • ***
  • Posts: 199
Re: Avast Home with Web Washer Classic
« Reply #4 on: September 01, 2007, 03:32:44 AM »
I wouldn't think so as by default adding the 8080 port to the redirects that traffic will be scanned.

You should only need to OptinProcess for unsupported 'browsers.'

Thanx David for your reply. However, I have the following two queries:

1) If I use both the ports 80 and 8080, does this not mean Avast will scan traffic between Internet and Web Washer i.e. port 80 and between Web Washer and Browser i.e. port 8080? If my contention is correct, the same content is being scanned twice. Is this correct to do?

2) What if I use only port 80 with 'Ignore local communication' checked. My assumption is in this case traffic between Web Washer and Internet will be scanned and this is what I want. Am I correct?

Please enlighten.

Thanx/SE224141
Avast Home Edition

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85572
  • No support PMs thanks
Re: Avast Home with Web Washer Classic
« Reply #5 on: September 01, 2007, 04:02:37 AM »
avast supports multiple ports to be redirected, there needs to be a comma separating the ports and you must uncheck the 'Ignore local communication.'

These settings are for the web shield if you do the manual settings in your browser to use the webwasher proxy, then that browser won't be using port 80 so there is no duplicate scanning, because you are using a local proxy, that is a local communication which needs to be scanned.

Leaving the port 80 in the web shield shouldn't hurt but you can remove it, I would tend to leave it there as a belt and braces if you use another browser and you haven't set that to use the webwasher proxy or something else tries to use port 80 it will be intercepted.

If you change the browser to use port 8080 yet leave the web shield set to redirect only port 80 and leave 'Ignore local communication' set, then avast won;t scan the webwasher content.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Glass

  • Jr. Member
  • **
  • Posts: 41
Re: Avast Home with Web Washer Classic
« Reply #6 on: September 01, 2007, 09:19:21 AM »
I use a different local proxy called naviscope.
My browser used the proxy port 81 (naviscope) and naviscope uses the port 12080 (avast). Works fine for me.