Author Topic: Weird MSDTC Problem in Windows 2003 Enterprise cluster  (Read 5803 times)

0 Members and 1 Guest are viewing this topic.

danny2001s

  • Guest
Weird MSDTC Problem in Windows 2003 Enterprise cluster
« on: May 26, 2007, 06:35:47 PM »
Hello,

I have a BIG issue. The installation of Avast Server was ok, no errors at all. Everything looks ok. I installed Avast Server on Windows 2003 Server Enterprise with SP2, active node of cluster.

But after reinstall and reboot (at night) I get several strange errors in Events Logs about MSDTC cannot start, MSDTC is not properly configured in cluster, etc., and the MSDTC Service is gone from service list. I tried to run "msdtc -install" but with no luck.
All the information at Microsoft Support refers How to configure MSDTC, but no specific problems ID reported in log.
Also, when I try to see COM properties of server, just entering the COM+ tab shows error "cannot connect to MSDTC". And the DTC tab is gone from properties.

I detected this problem the very next day, because SQL Server got crazy (4 CPUs reached 97%) and slow. I decided to uninstall avast until solve this issue, but the MSDTC problem remains. Since then, I had 2 more problems with SQL (same behavior, higher CPUs and slow).

I don't know how to fix this, do you have a solution? Reinstalling the whole server is a real problem right know, the other node is being fixed because a controller failure.

Thanks for a quick response,

Daniel   :-[
http://www.interdesigner.com
http://www.comparatorfast.com
http://www.networkclipboard.com
http://www.shutdowntools.com