Author Topic: Web Shield not recognising accessibility settings, so cannot turn it on  (Read 438 times)

0 Members and 1 Guest are viewing this topic.

Offline m_parfitt

  • Newbie
  • *
  • Posts: 3
If I click on the notification "warning !  Issues detected" I am told that Web Shield is off.  When I click on the ENABLE button I am told to :-

 ■ open Settings/Accessibility
 ■ add Avast
 ■ turn it on

But Settings/Accessibility/Installed_Services already has an entry for Avast and the switch is ON.  When I then navigate to Avast/Settings the Web Shield is still not enabled

If I attempt to switch Web Shield on via Avast/Settings/Web_Shield the same loop occurs.

If I go via Avast/Home and click on the big red Resolve_Issue button the same loop occurs.

Can I switch Web Shield on ?  If so, how ?  I'm using the free version but it doesn't appear to be a premium/subscription option.

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 1439
Hi,

Would you mind trying this once again:
Please close Avast Mobile security then go to your device's phone Settings > Accessibility > Installed Services> Avast Mobile Security and make sure to turn it Off and On


Offline m_parfitt

  • Newbie
  • *
  • Posts: 3
No luck.  I went into :-
 ■ Settings/Developer_Options/Running_Services and stopped both Avast entries
 ■ Settings/Apps and did a force stop
Then into Settings/Accessibility/Installed_Services (Avast was already OFF) then into the Avast entry and switched it ON - then I got a popup about needing to grant the Full Access permission, which I granted.

The Avast/Settings/Protection list showed Web Shield to be off, but when I clicked on the slider I was back in the same loop as before.

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 1439
No luck.  I went into :-
 ■ Settings/Developer_Options/Running_Services and stopped both Avast entries
 ■ Settings/Apps and did a force stop
Then into Settings/Accessibility/Installed_Services (Avast was already OFF) then into the Avast entry and switched it ON - then I got a popup about needing to grant the Full Access permission, which I granted.

The Avast/Settings/Protection list showed Web Shield to be off, but when I clicked on the slider I was back in the same loop as before.


Hi,

Please try to reset Accessibility.
To do so, go to your device's phone Settings > General management> Reset> Reset accessibility settings (since each device is different you might have to search for "Reset")


Offline m_parfitt

  • Newbie
  • *
  • Posts: 3
This didn't work on the first attempt.  By random chance I eventually got it to work.

Within the Android Settings app I went into Apps/Avast then did a Force_Stop, then into General_Management/Reset/Reset_Accessibility (which worked) then back to Apps/Avast then did Open and went into Avast/Settings/Protection where Web_Shield was still off as previously.

So I tried the slider which launched the Enable loop and in the Android Settings app I went into Accessibility/Installed_Services and switched Avast OFF.  Then I switched it back ON and went back to Avast/Settings/Protection where Web_Shield was still off as previously.

With no expectations, I tried to enable it.  This time the slider actually moved without entering the usual loop.

The ignored issues count went down from 2 to 1.

I have just re-checked and Web Shield is still enabled.

Thanks.

Offline r@vast

  • Avast team
  • Super Poster
  • *
  • Posts: 1439
This didn't work on the first attempt.  By random chance I eventually got it to work.

Within the Android Settings app I went into Apps/Avast then did a Force_Stop, then into General_Management/Reset/Reset_Accessibility (which worked) then back to Apps/Avast then did Open and went into Avast/Settings/Protection where Web_Shield was still off as previously.

So I tried the slider which launched the Enable loop and in the Android Settings app I went into Accessibility/Installed_Services and switched Avast OFF.  Then I switched it back ON and went back to Avast/Settings/Protection where Web_Shield was still off as previously.

With no expectations, I tried to enable it.  This time the slider actually moved without entering the usual loop.

Hi,

Thank you for the update

The ignored issues count went down from 2 to 1.

I have just re-checked and Web Shield is still enabled.

Thanks.