Author Topic: Latest version update - Package Broken?  (Read 3848 times)

0 Members and 1 Guest are viewing this topic.

Offline putty

  • Newbie
  • *
  • Posts: 13
  • I'm a llama!
Latest version update - Package Broken?
« on: February 27, 2004, 07:30:37 PM »
Hi, the auto updater informed me that there is a new version of Avast.  It downloads then I get a warning telling me the package is broken.

Here is the debug info

27.02.2004 18:26:08 general: Started: 27.02.2004, 18:26:08
27.02.2004 18:26:08 general: Running setup_av_pro-165 (357)
27.02.2004 18:26:08 system: Operating system: WindowsXP ver 5.1, build 2600, sp 1.0 [Service Pack 1]
27.02.2004 18:26:08 system: Computer WinName: xxx
27.02.2004 18:26:08 system: Windows Net User: SYSTEM
27.02.2004 18:26:08 general: Cmdline: /downloadpkgs /noreboot /silent /progress
27.02.2004 18:26:08 general: DldSrc set to inet
27.02.2004 18:26:08 general: Operation set to INST_OP_UPDATE_GET_PACKAGES
27.02.2004 18:26:08 general: Old version: 156 (342)
27.02.2004 18:26:08 file: Direct delete of file: C:\WINDOWS\TEMP\_av_proI.tm~a01404\onefile
27.02.2004 18:26:08 general: SGW32P::CheckIfInstalled set m_bAlreadyInstalled to 1
27.02.2004 18:26:09 system: Computer DnsName:27.02.2004 18:26:09 system: Computer Ip Addr: xxx.xx.xx.xxx
27.02.2004 18:26:09 internet: SYNCER: Type: -1
27.02.2004 18:26:09 internet: SYNCER: Auth: 0
27.02.2004 18:26:09 package: Part prg_av_pro-165 is installed
27.02.2004 18:26:09 package: Part vps-40203 is installed
27.02.2004 18:26:09 package: Part news-3a is installed
27.02.2004 18:26:09 package: Part setup_av_pro-165 is installed
27.02.2004 18:26:09 general: Old version: 156 (342)
27.02.2004 18:26:10 file: SetExistingFilesBitmap: 314->111->51
27.02.2004 18:26:10 general: GUID: a13d23f0-3609-48fe-b3ed-0a3669cdbe7d
27.02.2004 18:26:10 general: Server definition(s) loaded for 'main': 7 (maintenance:0)
27.02.2004 18:26:10 general: SelectCurrent: selected server 'Download1 AVAST server' from 'main'
27.02.2004 18:26:10 general: Entered SetupProcessPro::Do( INST_OP_UPDATE_GET_PACKAGES )
27.02.2004 18:26:10 general: Entered SetupProcessWin32Avast::Do( INST_OP_UPDATE_GET_PACKAGES )
27.02.2004 18:26:10 general: Entered SetupProcessWin32::Do( INST_OP_UPDATE_GET_PACKAGES )
27.02.2004 18:26:10 general: Entered SetupProcess::Do( INST_OP_UPDATE_GET_PACKAGES )
27.02.2004 18:26:10 general: progress thread start
27.02.2004 18:26:10 general: progress start - 1
27.02.2004 18:26:10 general: progress start - 2
27.02.2004 18:26:10 general: Server definition(s) loaded for 'main': 7 (maintenance:0)
27.02.2004 18:26:10 general: SelectCurrent: selected server 'Secondary ASW server' from 'main'
27.02.2004 18:26:11 package: LatestPartInfo: news = news-3a
27.02.2004 18:26:11 package: LatestPartInfo: program = prg_av_pro-165
27.02.2004 18:26:11 package: LatestPartInfo: setup = setup_av_pro-165
27.02.2004 18:26:11 package: LatestPartInfo: vps = vps-40203
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp413', containing 3 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp405', containing 9 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'winsys', containing 1 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp415', containing 3 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp407', containing 3 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp416', containing 3 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp409', containing 9 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll40A', containing 10 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll40e', containing 4 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'avscan', containing 15 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp40A', containing 4 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_pro', containing 10 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp40e', containing 3 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_skins', containing 2 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll410', containing 10 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll411', containing 2 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_core', containing 13 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll405', containing 10 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll413', containing 4 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll407', containing 4 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll415', containing 4 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll416', containing 4 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'winsysgui', containing 1 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_dll409', containing 10 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp410', containing 9 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'av_pro_hlp411', containing 2 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'vpsm', containing 1 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'vps', containing 9 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'news405', containing 1 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'news409', containing 1 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'setif_av_pro', containing 13 subversions
27.02.2004 18:26:11 package: Loaded pkg info 'setup_av_pro', containing 13 subversions
27.02.2004 18:26:11 general: progress end - 1
27.02.2004 18:26:11 package: IsFullOkay: setup_av_pro-165.vpu - is okay
27.02.2004 18:26:11 package: IsFullOkay: setif_av_pro-165.vpu - is okay
27.02.2004 18:26:11 package: FilterOutExistingFiles: 110 & 51 = 59
27.02.2004 18:26:11 package: IsFullOkay: setif_av_pro-165.vpu - is okay
27.02.2004 18:26:11 package: IsFullOkay: setup_av_pro-165.vpu - is okay
27.02.2004 18:26:11 package: IsFullOkay: av_pro_core-149.vpu - not okay
27.02.2004 18:26:11 package: SetDownloadBits: av_pro_core setting 1 diffs to process
27.02.2004 18:26:11 package: IsFullOkay: av_pro_dll409-b9.vpu - not okay
27.02.2004 18:26:11 package: SetDownloadBits: av_pro_dll409 setting 1 diffs to process
27.02.2004 18:26:11 package: IsFullOkay: av_pro_hlp409-11f.vpu - not okay
27.02.2004 18:26:11 package: SetDownloadBits: av_pro_hlp409 setting 1 diffs to process
27.02.2004 18:26:11 package: IsFullOkay: avscan-d5.vpu - not okay
27.02.2004 18:26:12 package: SetDownloadBits: avscan setting 1 diffs to process
27.02.2004 18:26:12 package: IsFullOkay: vps-40200.vpu - is okay
27.02.2004 18:26:12 package: IsFullOkay: vpsm-40203.vpu - is okay
27.02.2004 18:26:12 package: IsFullOkay: news409-29.vpu - is okay
27.02.2004 18:26:12 package: FilterOutExistingFiles: 110 & 51 = 59
27.02.2004 18:26:12 package: IsFullOkay: setif_av_pro-165.vpu - is okay
27.02.2004 18:26:12 package: IsFullOkay: setup_av_pro-165.vpu - is okay
27.02.2004 18:26:12 package: IsFullOkay: av_pro_core-149.vpu - not okay
27.02.2004 18:26:12 package: SetDownloadBits: av_pro_core setting 1 diffs to process
27.02.2004 18:26:12 package: IsFullOkay: av_pro_dll409-b9.vpu - not okay
27.02.2004 18:26:12 package: SetDownloadBits: av_pro_dll409 setting 1 diffs to process
27.02.2004 18:26:12 package: IsFullOkay: av_pro_hlp409-11f.vpu - not okay
27.02.2004 18:26:12 package: SetDownloadBits: av_pro_hlp409 setting 1 diffs to process
27.02.2004 18:26:12 package: IsFullOkay: avscan-d5.vpu - not okay
27.02.2004 18:26:12 package: SetDownloadBits: avscan setting 1 diffs to process
27.02.2004 18:26:12 package: IsFullOkay: vps-40200.vpu - is okay
27.02.2004 18:26:12 package: IsFullOkay: vpsm-40203.vpu - is okay
27.02.2004 18:26:12 package: IsFullOkay: news409-29.vpu - is okay
27.02.2004 18:26:47 package: DldPackage: C:\Program Files\Alwil Software\Avast4\Setup\av_pro_core-149-13c.vpu, returned 0x20000011
27.02.2004 18:26:47 package: ERROR: Diff av_pro_core-149-13c failed
27.02.2004 18:26:47 package: Removed obsolete file av_pro_core-13c.vpu
27.02.2004 18:26:47 package: IsFullOkay: av_pro_core-149.vpu - not okay
27.02.2004 18:26:47 package: Full of package av_pro_core was set to 1
27.02.2004 18:26:47 package: FilterOutExistingFiles: 110 & 51 = 59
27.02.2004 18:26:47 package: IsFullOkay: setif_av_pro-165.vpu - is okay
27.02.2004 18:26:47 package: IsFullOkay: setup_av_pro-165.vpu - is okay
27.02.2004 18:26:47 package: IsFullOkay: av_pro_core-149.vpu - not okay
27.02.2004 18:26:47 package: IsFullOkay: av_pro_core-149.vpu - not okay
27.02.2004 18:26:47 package: Full of package av_pro_core was set to 1
27.02.2004 18:26:47 package: IsFullOkay: av_pro_dll409-b9.vpu - not okay
27.02.2004 18:26:47 package: SetDownloadBits: av_pro_dll409 setting 1 diffs to process
27.02.2004 18:26:47 package: IsFullOkay: av_pro_hlp409-11f.vpu - not okay
27.02.2004 18:26:47 package: SetDownloadBits: av_pro_hlp409 setting 1 diffs to process
27.02.2004 18:26:47 package: IsFullOkay: avscan-d5.vpu - not okay
27.02.2004 18:26:47 package: SetDownloadBits: avscan setting 1 diffs to process
27.02.2004 18:26:47 package: IsFullOkay: vps-40200.vpu - is okay
27.02.2004 18:26:47 package: IsFullOkay: vpsm-40203.vpu - is okay
27.02.2004 18:26:47 package: IsFullOkay: news409-29.vpu - is okay
27.02.2004 18:27:16 package: DldPackage: C:\Program Files\Alwil Software\Avast4\Setup\av_pro_core-149.vpu, returned 0x20000011
27.02.2004 18:27:16 general: progress end - 0
27.02.2004 18:27:16 general: progress thread end
27.02.2004 18:27:16 general: Err:The package is broken.
27.02.2004 18:27:16 general: errordlg: 375,96

Offline Colin

  • Jr. Member
  • **
  • Posts: 20
Re:Latest version update - Package Broken?
« Reply #1 on: February 27, 2004, 09:33:10 PM »
I got same message. I run NT4 with SP6a and have recently downloaded all of MicroSloth's latest "fix all the backdoors we accidently left in" packages
Went to log file, but nothing there - could be my settings in log file!

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re:Latest version update - Package Broken?
« Reply #2 on: February 27, 2004, 11:00:53 PM »
Could you manually update your avast! now?
I mean, maybe the error was corrected because I updated my installation without trouble this afternoon  :-\
The best things in life are free.

Offline putty

  • Newbie
  • *
  • Posts: 13
  • I'm a llama!
Re:Latest version update - Package Broken?
« Reply #3 on: February 27, 2004, 11:15:54 PM »
Manually updated without any problem..  :)

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Latest version update - Package Broken?
« Reply #4 on: February 27, 2004, 11:20:29 PM »
If it said package is broken, it means package was broken :) I.e. the file got probably somehow screwed en route...

Mere retry should in most cases rectify the problem...

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.