Author Topic: "Delay loading of avast services" has stopped being effective  (Read 8836 times)

0 Members and 1 Guest are viewing this topic.

Offline MrRAlan

  • Full Member
  • ***
  • Posts: 195
"Delay loading of avast services" has stopped being effective
« on: September 09, 2007, 04:11:36 PM »
A short time back, one of the avast updates installed and then upon starting my pc, it started taking about one minute before my Networking icon would appear in the system task tray.  The next avast came out and had the "Delay loading of avast services" option which I checked and the problem went away immediately.  Recently, the Networking icon has started taking about one minute again before appearing.  I checked the option and it is still checked AND the .ini file value is also correct.  I disabled avast services and the Networking icon appears instantly again.  What changed which is causing this delay?  I have version 4.7.1029.  Thanks.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84559
  • No support PMs thanks
Re: "Delay loading of avast services" has stopped being effective
« Reply #1 on: September 09, 2007, 05:32:53 PM »
Well the first thing I would suggest is that you do a manual program update as version 4.7.1043 is the latest version only released recently.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: "Delay loading of avast services" has stopped being effective
« Reply #2 on: September 09, 2007, 08:07:22 PM »
Also, what INI option are you talking about, exactly?
If at first you don't succeed, then skydiving's not for you.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67259
Re: "Delay loading of avast services" has stopped being effective
« Reply #3 on: September 09, 2007, 09:40:41 PM »
Vlk, isn't it AlwaysConnectedWaitSeconds value?
The best things in life are free.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: "Delay loading of avast services" has stopped being effective
« Reply #4 on: September 10, 2007, 12:22:31 AM »
Vlk, isn't it AlwaysConnectedWaitSeconds value?

No. AFAIK there's no INI setting for this. ;)
If at first you don't succeed, then skydiving's not for you.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67259
Re: "Delay loading of avast services" has stopped being effective
« Reply #5 on: September 10, 2007, 01:03:04 AM »
No. AFAIK there's no INI setting for this. ;)
http://forum.avast.com/index.php?board=2;action=display;threadid=1647 ???
I'm referring to delay the update after logon, not the avast services delay...
The best things in life are free.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3866
  • Just an avast user
Re: "Delay loading of avast services" has stopped being effective
« Reply #6 on: September 10, 2007, 01:03:32 AM »
This is the setting in Troubleshooting in the Program Settings.

It is implemented by the ini entry:

LateServiceStart

in the [Common] section.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67259
Re: "Delay loading of avast services" has stopped being effective
« Reply #7 on: September 10, 2007, 01:21:29 AM »
This is the setting in Troubleshooting in the Program Settings.

It is implemented by the ini entry:

LateServiceStart

in the [Common] section.
Thanks Alan.
Which is the unit and the default values? (minutes, seconds...)
The best things in life are free.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84559
  • No support PMs thanks
Re: "Delay loading of avast services" has stopped being effective
« Reply #8 on: September 10, 2007, 01:35:32 AM »
By default there wouldn't be an ini entry, only if you elect to delay the avast services until other system services have loaded.
So it is an on or off option 0 or 1, LateServiceStart=1 being 'delay loading of avast! services until after other system services.'

There would only be a LateServiceStart=0 in the ini file if you change it back in the program settings, to the default of unchecked.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline MrRAlan

  • Full Member
  • ***
  • Posts: 195
Re: "Delay loading of avast services" has stopped being effective
« Reply #9 on: September 10, 2007, 03:57:04 PM »
Yes.  I was looking at LateServiceStart.  It is set to 1 and when I uncheck the option, it gets a 0.  I will download the newest version first and report back.  Thanks.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: "Delay loading of avast services" has stopped being effective
« Reply #10 on: September 10, 2007, 04:41:08 PM »
The INI option is quite irrelevant - it's probably there only to ease the GUI.
What counts is the changes that this setting makes to the registry.

Let's try this. Manually (e.g. in Notepad) set the INI value to 0, and then use the avast GUI to turn it on. That should redo the required registry changes (in case the INI value somehow got out of sync).

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 84559
  • No support PMs thanks
Re: "Delay loading of avast services" has stopped being effective
« Reply #11 on: September 10, 2007, 04:50:28 PM »
With it set to 1 (e.g. the delay loading of avast! services option 'checked') it is more likely the boot will be slightly quicker as avast isn't loaded sooner so it will not be scanning as quickly.

So if you are concerned about boot time then by unchecking the option you are doing the reverse. Also since you are concerned about the networking icon, you should check the option to delay avast services (LateServiceStart=1), not what you have done uncheck it.

If I have the option checked (LateServiceStart=1) then the number of files scanned is 25-30 less than if the option is unchecked.

As Vlk said you should try manually in the ini and with the GUI to ensure registry changes are made.
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.1.2449 (build 21.1.5968.561) UI-1.0.597/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline MrRAlan

  • Full Member
  • ***
  • Posts: 195
Re: "Delay loading of avast services" has stopped being effective
« Reply #12 on: September 10, 2007, 10:18:27 PM »
I only unchecked it to verify the ini file was properly being set.  I checked it again after I saw that it was.  Vlk, I tried your suggestion, manually changing the ini file to 0 and then using avast to change it back to 1.  I also upgraded to the latest avast but the delay is still present.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: "Delay loading of avast services" has stopped being effective
« Reply #13 on: September 10, 2007, 10:31:31 PM »
To be absolutely sure, please open regedit and go to the "HKLM\System\CurrentControlSet\Services\Avast! Antivirus" key.
Is the a value called "Group"? If so, what does it say?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline MrRAlan

  • Full Member
  • ***
  • Posts: 195
Re: "Delay loading of avast services" has stopped being effective
« Reply #14 on: September 12, 2007, 04:29:07 AM »
I have a DependOnGroup. ... not just Group.  The DependOnGroup does not have a value.  It is a reg_multi_sz.

When I uncheck the "Delay loading of services" the Group value appears.  It is set for ShellSvcGroup.
« Last Edit: September 12, 2007, 04:32:04 AM by MrRAlan »