Author Topic: Avast One preventing login to IMAP server  (Read 1610 times)

0 Members and 1 Guest are viewing this topic.

Offline tsc_chazz

  • Newbie
  • *
  • Posts: 13
Avast One preventing login to IMAP server
« on: September 07, 2022, 10:45:04 PM »
This is only happening for one user, running Windows 7. Environment is: Windows 7, Avast 1 Free, affected mail clients are Outlook 2013 and Thunderbird (most recent as of post date, fresh download for testing). I'm sysop for the mail server as well, which is a Linux system on the local network. The mail clients are using STARTTLS to connect via IMAP at port 143, the server is running Dovecot for IMAP and we're using a LetsEncrypt certificate. This one client, when we try to log in via IMAP, sits at login until it times out. Sending is no problem, we can authenticate to the Sendmail server and send messages with no problem, but I believe that Outlook may never have been told to use STARTTLS for sending - there was a stretch where the certificates weren't set properly to enable TLS from the SMTP server. Disabling the mail shield allows login and access to messages via IMAP. Are there some problems with the transfer between Avast's certificates and the server's certificates, and if so, what do I do about it?

Offline r@vast

  • Avast team
  • Massive Poster
  • *
  • Posts: 2760
Re: Avast One preventing login to IMAP server
« Reply #1 on: September 08, 2022, 12:17:36 PM »

Offline tsc_chazz

  • Newbie
  • *
  • Posts: 13
Re: Avast One preventing login to IMAP server
« Reply #2 on: September 08, 2022, 08:18:20 PM »
I'm not at the site at the moment, so response is a little delayed, but my hands on the site tell me that installing the beta did not resolve the issue.

Offline r@vast

  • Avast team
  • Massive Poster
  • *
  • Posts: 2760
Re: Avast One preventing login to IMAP server
« Reply #3 on: September 09, 2022, 10:50:50 AM »
Hi,

Do they have beta version 22.9.6033 (released yesterday), and did they restart after the installation?
If the issue persists, please provide a support file ID.
1. In Avast One, go to Account> Settings > Troubleshooting >  Debug Logs (at the bottom) > Enable debug logging
2. Reproduce the issue
2. Send Logs
3. Post the file ID here in the thread.
(Support tool guide:https://support.avast.com/en-ww/article/Submit-support-file)
You can disable debug logging after the file has been generated.
Please provide a screenshot of any error messages in Outlook.


Offline tsc_chazz

  • Newbie
  • *
  • Posts: 13
Re: Avast One preventing login to IMAP server
« Reply #4 on: September 09, 2022, 06:52:03 PM »
That's slightly beyond the skill level of my remote hands, so this response will have to wait until Tuesday when I'm next on site. I'll pull a fresh copy of the beta then as well.

Offline tsc_chazz

  • Newbie
  • *
  • Posts: 13
Re: Avast One preventing login to IMAP server
« Reply #5 on: September 13, 2022, 10:36:39 PM »
Okay - looks like we're out of the woods now. Installed the beta, rebooted, confirmed 22.9.6033 (build 22.9.7539.734), tried to reproduce, and there was no reproduction - it simply connected just fine. It did want to check for a program update, but found there wasn't one.