Author Topic: avast blocking embedded webview?  (Read 791 times)

0 Members and 1 Guest are viewing this topic.

Offline dumpsterk

  • Newbie
  • *
  • Posts: 2
avast blocking embedded webview?
« on: February 01, 2024, 07:36:51 AM »
I've been using the web-based IDE Replit for quite some time now, but recently Avast has started blocking parts of the development environment. Basically, I write HTML /CSS/JS code and whatnot and in a window inside that same webpage it shows a view of what that page currently looks like. That webview is now being blocked by Avast for some reason, and I do not know how to unblock it without disabling Avast. I created exceptions for both the url of the larger development webpage and the url that was supposed to be shown in the subwindow, but it still doesn't work. I also disabled Avast's web shield to troubleshoot the problem, but it STILL blocks the webview from opening anyway, even though the message that pops up clearly indicated that the web shield is what detected the problem to begin with. To my knowledge, Replit is perfectly safe and a trusted development environment. I used chrome devtools to try to troubleshoot this issue, and I didn't really manage to discern anything useful, except that the webview was created with an iframe element, and had the correct source link, not any malicious business there. I don't know how to fix this or how to unblock this webview.

I couldn't figure out how to attach the image for the message Avast gives, so here it is in text form:

Threat secured
We've safely aborted connection on local.avast.com because it was infected with HTML:RedirBA-inf [Trj]

Threat name: HTML:RedirBA-inf [Trj]
Threat type: Trojan Horse- (...)
URL: v8/LoadTimes
Process: C:Program Files(x86)\Google\Chrome\Application\chrome.exe
Detected by: Web Shield
Status: Connection aborted

cd59a86166ee/2024-02-01T06:34:34.917Z

The information that this provides didn't really help me at all. The URL given wasn't helpful, the message wasn't helpful, and the Web Shield is described as the part of Avast that detected the problem even when I have it disabled. I'm really confused, how do I stop this?

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37529
  • Not a avast user
Re: avast blocking embedded webview?
« Reply #1 on: February 01, 2024, 05:58:09 PM »
Process: C:Program Files(x86)\Google\Chrome\Application\chrome.exe

URL: v8/LoadTimes = V8 javascript engine

https://en.wikipedia.org/wiki/V8_(JavaScript_engine)


Offline dumpsterk

  • Newbie
  • *
  • Posts: 2
Re: avast blocking embedded webview?
« Reply #2 on: February 02, 2024, 05:58:06 AM »
So, the problem just suddenly disappeared, I was unable to replicate it. I don't know if it will come up again, but that's good!

Offline rohanzx67

  • Newbie
  • *
  • Posts: 1
Re: avast blocking embedded webview?
« Reply #3 on: February 02, 2024, 12:55:01 PM »
even though the message that pops up clearly indicated that the web shield is what detected the problem to begin with. To my knowledge, Replit is perfectly safe and a trusted development environment. I used chrome devtools to try to troubleshoot this issue, and I didn't really manage to discern anything useful, except that the webview was created with an iframe element, and had the correct source link, not any malicious business there. I don't know how to fix this or how to unblock this webview.
9apps apk
« Last Edit: February 07, 2024, 03:51:14 PM by rohanzx67 »