Author Topic: avast! 4.8.1178 self-defense module bug.  (Read 7441 times)

0 Members and 1 Guest are viewing this topic.

Offline Sauron

  • Newbie
  • *
  • Posts: 12
  • Another avast! user.
avast! 4.8.1178 self-defense module bug.
« on: April 12, 2008, 02:42:35 PM »
Found a possible bug with the self-defense module.

I'm running this pre-release (4.8.1178) on Win XP SP2 Pro, and I went into Services and try to stop the avast! service, and do get a warning. With this pre-release I noticed that the "No" buttons has an auto countdown, and decided to leave it and see what happens ... It was not what I expected, it counted down, disappeared and allowed the avast! service to stop.  :-\

I can confirm the service stops since it shows that little red circled-stripe on the avast! logo in the system tray and I'm able to extract the EICAR test virus with no detection what so ever.

Might be something you would want to look into.

-- Sauron
« Last Edit: April 12, 2008, 03:25:40 PM by Sauron »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: avast! 4.8.1178 self-defense module bug.
« Reply #1 on: April 12, 2008, 11:41:53 PM »
On Vista, I can't get this countdown message... Yes or No and the services can't be finished with the self-module on. Shouldn't I see a message from avast alerting that something is trying to kill avast services?
The best things in life are free.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: avast! 4.8.1178 self-defense module bug.
« Reply #2 on: April 12, 2008, 11:53:10 PM »
When I tested this on WinXP SP2 the avast update service just shut down without any complaints from avast at all.  The main service gave the avast pop-up with a countdown.  I too let it count down.  The service took forever to shutdown and timeout alerts were generated in the system event log.

Offline Sauron

  • Newbie
  • *
  • Posts: 12
  • Another avast! user.
Re: avast! 4.8.1178 self-defense module bug.
« Reply #3 on: April 13, 2008, 04:07:35 AM »
On my system when the countdown finishes the warning disappears, avast! and all of the its providers stops, but the windows dialog with the progress bar stays there and after a loooong time it will say that the service did not respond in a timely fashion.

I upgraded from 4.8.1169 using the aswbeta.exe. When I have a few minutes I will remove avast! and use the full install packages to see if it makes a difference.

Offline alanrf

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 3867
  • Just an avast user
Re: avast! 4.8.1178 self-defense module bug.
« Reply #4 on: April 13, 2008, 06:20:24 AM »
The aswbeta induced install proceeds in just the same way as other avast updates (except it allows you to select a beta release rather than looking for a production update). 

I doubt that the step will make any difference but if you wish to make that confirmation please do (don't forget to turn the self-defense on again before you perform the test again).

 

Offline Sauron

  • Newbie
  • *
  • Posts: 12
  • Another avast! user.
Re: avast! 4.8.1178 self-defense module bug.
« Reply #5 on: April 13, 2008, 07:33:58 AM »
No luck :-[

Did an uninstall and used aswClear.exe to make sure everything was gone. Reinstalled with the full package (4.8.1178), but can still stop the avast! Antivirus service by just leaving the 30sec countdown to finish.

I looked through my avast! and windows logs, but can't find any sign of a possible crash. ???

-- Sauron

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: avast! 4.8.1178 self-defense module bug.
« Reply #6 on: April 13, 2008, 05:34:15 PM »
On Vista, I can't get this countdown message...
Does anybody get this message on Vista? ???
The best things in life are free.

Offline Sauron

  • Newbie
  • *
  • Posts: 12
  • Another avast! user.
Re: avast! 4.8.1178 self-defense module bug.
« Reply #7 on: April 14, 2008, 03:19:06 PM »
Tech: I just upgraded avast! on my Vista machine to pre-release 4.8.1178 and also get the 30sec countdown on the "No" button when I try and stop the "avast! Antivirus" service.

I have also discovered that avast! 4.8.1178 suffers the same fate on Vista Home Prem. as it does on XP SP2 Pro, as described in my previous posts. ::)

-- Sauron

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67275
Re: avast! 4.8.1178 self-defense module bug.
« Reply #8 on: April 14, 2008, 04:35:15 PM »
Tech: I just upgraded avast! on my Vista machine to pre-release 4.8.1178 and also get the 30sec countdown on the "No" button when I try and stop the "avast! Antivirus" service.
Now I see it... it was a message from avast self-defense module. I was waiting for a Windows Vista message (and countdown). Thanks for the tip.
The best things in life are free.