Author Topic: Mailmate Antispam  (Read 19212 times)

0 Members and 1 Guest are viewing this topic.

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #30 on: April 29, 2004, 02:22:44 PM »
Yes I am willing to keep going!
I can use original settings and port 8110 in Mailmate & Outlook and Avast scans inbox. Works fine!
Can't get test 2 to work with:
Incoming Mail Port   110
Incoming Pop3 Server   127.0.0.1
Pop username   ****90@dsl.pipex.com#dsl.pipex.com
Still get the same error can't connect to 127.0.0.1 this is using port 110 as you suggest.
Cheers
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #31 on: April 29, 2004, 02:51:40 PM »
Clive, I am very glad that nothing has broken the original setup and that avast is still able to scan the Outlook Inbox <sigh of relief>

From here on please keep a copy of the current avast4.ini as a back up just to be safe.

OK, back to the drawing board:  We need to get avast Internet Mail Provider working iwith Outlook.

Before we assume something else is running on port 110 please check that the Internet Mail Provider status is running in the avast Resdient Shield.  If it is try clicking on the Terminate button, wait for it to stop then try  starting again (Start button) to look for any errors or messages.

Then try the following test:


Outlook using Avast Internet Mail only:
Incoming Mail Port      110
Incoming Pop3 Server  127.0.0.1
Pop username              ****90@dsl.pipex.com#dsl.pipex.com

If we get the same "cannot connect error" then we should try another port.  This requires editing the avast4.ini (make a backup)

To change the port to 29110 use the following:

[MailScanner]
ShowTrayIcon=0
UseDefaultSmtp=1
AutoSetProtection=0
PopListen=127.0.0.1:29110
Trust=127.0.0.1
DefaultPopServer=dsl.pipex.com

*Remember to save the changes, avast monitors for any changes to the ini file, but it probably would not hurt to stop and start the Internet Mail provider again.

Then try a new test with the following settings:

Outlook using Avast Internet Mail only:
Incoming Mail Port      29110
Incoming Pop3 Server  127.0.0.1
Pop username              ****90@dsl.pipex.com#dsl.pipex.com

If we get the same error then we probably have avast setup problems.

If an error does occur, please read the details in  Outlook, it may be a different error which means we are making progress.

After testing change please let me know, then change back to the origial so you dont have to deal with all that spam.

Outlook using Maimate only:
Incoming Mail Port      8110
Incoming Pop3 Server  127.0.0.1
Pop username              csturnbull@dsl.pipex.com


Sean D

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #32 on: April 29, 2004, 03:16:52 PM »
Sean
Followed that to the letter and still the same error. I reckon maybe the setup is incorrect for Avast in some way.  I have even shutdown Mailmate just to be sure so it isn't even in the equation. Can I have done something incorrect when installing? Most of it looked straightforward
Thanks
Clive

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #33 on: April 29, 2004, 03:21:13 PM »
Reverted to Mailmate settings and running ok.
Cheers
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #34 on: April 29, 2004, 03:35:55 PM »
Clive,

Before doing the following back up your ini file.

Would you mind running the Avast Mail Protection Wizard and choose "Setup Protection manually", then select "I dont use Outlook" then select" my Account is not on the list", ignore the Hellp file popup and select "next" where you will be prompted to enter a default smtp and pop server, then on the next screen accept defaults on the resident settings.

After the service starts, verify that your Exchange/Outlook plugin still works with Outlook and Mailmate and then we can try debugging from there.

One question:  Are you running Outlook on the same PC that avast is running?


Sean D

Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #35 on: April 29, 2004, 04:03:50 PM »
Ignore the last message, couldn't find the wizard! Found it and done all that. It said it wasn't running :-[ Although it was checking the inbox.
Where next???
Cheers
Clive

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #36 on: April 29, 2004, 04:41:01 PM »
Clive, what was not running, Exchange or Internet mail Provider.  I am online now ...wanna do this on private message for effecinecy?

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #37 on: April 29, 2004, 08:02:09 PM »
Whew, problem fixed!  Gotta give you a lot of credit for hanging in there Clive!

Was an interesting experience and I will post a summary of what the solution was a little later today (gotta get back to work now)

Sean D
« Last Edit: April 29, 2004, 08:02:41 PM by seand »

Offline seand

  • Jr. Member
  • **
  • Posts: 53
Re:Mailmate Antispam
« Reply #38 on: April 29, 2004, 09:14:01 PM »
Outlook, Mailmate and avast finally working together.

The specific need was to have all mail scanned by avast for viruses.  Using the  avast! Exchange/Outlook provider all mail downloaded by Outlook was being scanned but the spam captured by Mailmate was not.

This appeared to be a simple proxy chaining issue with the need to have the mail first filtered by avast, then Mailmate and finally delivered to Outlook or retained by Mailmate in its spam folder.

After several attempts to "chain" the proxies we learned that actually Mailmate does not  act in the normal fashion of a pass-thru transparent  antispam proxy (like Spampal).  Insead Mailmate acts as a mail client to download mail from all accounts and then acts as a POP server to distribute non spam mail to Outlook and retain all spam mail in a quarantine folder.

Once we realized this, it was relatively simple to put the avast! Internet Mail provider in front of Mailmate so that when it collected email from all accounts (as a standard mail client) the mail was scanned for viri while being downloaded.

The avast [mailscanner] section in avast4.ini was configured to listen to port 29110 since it appeared that another unknown application was already usuing 110.  After that it was simply a matter of modifying the pop user name and pop server and port in the Mailmate account config using the standard instruction in the avast! help file for configuring the Internet mail provider.
Quote
Step one: changing the file AVAST4.INI

Open avast4.ini file in Notepad editor. You will find this file in the folder Data in your avast! installation folder, e.g. C:\Program Files\ALWIL Software\avast4\Data.
Find the section named [MailScanner]. Write these lines into this section (if they already exist, change them):
DefaultSmtpServer=smtp.server.com
DefaultPopServer=pop.server.com
DefaultImapServer=imap.server.com (only if you are using IMAP server for incoming mail).
Replace smtp.server.com by the address of the SMTP server you are using, e.g. smtp.tiscali.com. Do the same for POP (and IMAP) server (e.g. pop3.tiscali.com).
If your e-mail program supports SMTP authentication, and also makes it possible to set a different login name for SMTP than for POP, insert the line: UseDefaultSmtp=0.
If your e-mail program does not support SMTP authentication, insert the line: UseDefaultSmtp=1.
Save the changes and close the Notepad editor.
Step two: modifying the account properties in your mail program

Launch your mail program.
Let the program display the account settings.
If you want to check outgoing messages, change the address of SMTP server to the address of the local computer, i.e. 127.0.0.1.
If you want to check incoming messages, change the address of POP (IMAP) server to the address of the local computer, i.e. 127.0.0.1.
Change user (login) name this way: append the character # (double hash) and the address of your POP (IMAP) server (the same as you specified in the avast4.ini file in Step one). Login name should then look like this:
Ann.Jones#pop3.tiscali.com
If your e-mail program supports SMTP authentication and also makes it possible to set a different login name for SMTP than for POP
If the SMTP authentication is enabled, append the character # and the address of your SMTP server to the login name (e.g. annie2#smtp.tiscali.com).
If the SMTP authentication is disabled, enable it and use the character # together with the address of your SMTP server as the login name (e.g. #smtp.tiscali.com).
Save your changes.
The manual setting of the Mail scanner is now complete.

Now all mail downloaded by Mailmate is scanned by avast! and both spam and non-spam is disinfected if they contain viruses.

I am real glad you hung in there Clive, I think it was well worth while.  Avast! is a superb program and I am delighted we solved this problem together.

Thanks,

Sean D



Offline csturnbull

  • Newbie
  • *
  • Posts: 17
Re:Mailmate Antispam
« Reply #39 on: April 29, 2004, 11:26:26 PM »
Sean
Worth every minute and of great benefit to me!
Thanks once again
Clive