Author Topic: AVast - poor performance - AMS Console.  (Read 5591 times)

0 Members and 1 Guest are viewing this topic.

straightwhiteteeth

  • Guest
AVast - poor performance - AMS Console.
« on: April 22, 2009, 04:33:04 PM »
We are having all sorts of issues with aVast\AMS Server console. Slow, unresponsive and an absolute pain to try and do anything with.

We have had database issues and as a result upgraded to SQLExpress2005. I have a db clean up task running every night in an effort to keep the db manageable and prevent it exceeding its licencing restriction on size.

The console is responsive immediately after login but rapidily grinds to a halt when trying to do simple things like sorting out the computer catalogue and the like. In an effort to keep it working tasks are restricted to the absolute minumum.

I have checked the AMS server log and found the following errors under AntiVirus tab:
Error 1: Source avast! catagory: Client  Event ID 90
AAVM - Scanning error - exception in DriverScanListen Thread! C000005
This error is appearing several times a second.

Error2: Source avast! catagory: Client  Event ID 90
database command failed - [CClient::OnPop, 80004005] Transaction (Process ID 52) was deadlocked on lock resources with another process and has been chosen as the dealock victim. rerun the transaction.

Error 3: Source avast! catagory: Client  Event ID 90
database command failed [CClient::getEnggroup, 80004005]: Timeout expired

The following error appear under the Application tab:
The prelogin packet used to open the connection is structually invalid; the connection has been closed. please contact the vendor of the client library. [CLIENT: Server IPA]

We have a lot of workstations to protect and I must say that I using this product has not been easy up till now.

 ???


Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: AVast - poor performance - AMS Console.
« Reply #1 on: April 22, 2009, 04:43:14 PM »
I guess my question would be is how many computers is
Quote
a lot of workstations
and second, if there are a lot, have you thought about adding an additional mirror server to help the load a little bit?

The error C000005 is access denied.  Sounds like the scanner is trying to scan some protected files, or maybe encrypted files?

The other error 80004005, I've only found this info on so far: http://forum.avast.com/index.php?topic=27756.0

What's your AMS version?

What type of computer is it installed on?
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

straightwhiteteeth

  • Guest
Re: AVast - poor performance - AMS Console.
« Reply #2 on: April 23, 2009, 10:03:03 AM »
Hi Scythe944,

Thanks for taking the time.

We have approx. 8500 devices showing in the console and are running AMS version 4.8.952 (Dec2008).

The AMS server supplied by our local support is a no name brand machine with the following spec:
intel Core 2 Quad CPU Q8200 @ 2.33GHz with 4GB RAM running MS Windows 2K3 SP2 Standard Edition.

I am inclined to agree with your initial diagnosis and install a second mirror. I think the current AMS server is just being overwhelmed.

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: AVast - poor performance - AMS Console.
« Reply #3 on: April 23, 2009, 06:27:39 PM »
Whew!  Yeah, 8500 devices are "attacking" one single server.

I'd definitely start thinking about adding another mirror or two.  While your building your next server, I'd recommend a RAID Mirror or even better a RAID 10 array, to get a little better disk speed out of it.
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum