Author Topic: Please Help! Can't get Avast! Pro to run as an e-mail proxy  (Read 5173 times)

0 Members and 1 Guest are viewing this topic.

Clemens_1

  • Guest
Hello!

I am running Opera 5.1 together with Avast Pro about 20 days ago. Everything worked as it should, but running Avast as a proxy.

I of course want to set up Avast to operate in proxy mode, but I failed with it. Opera does not get a connection via Smtp and IMAP any more.

The description of the settings for my e-mail client are pretty clear in the help file of Avast. But the description for the changes in the avast4.ini are not so clear.

The complete section [MailScanner] was not present originally in the *.ini file. So I tried to insert all the necessary settings there. Now they look like this:

[MailScanner]
DefaultSmtpServer=mail.gmx.net:25
DefaultPopServer=pop.gmx.net
DefaultImapServer=imap.gmx.net:143
UseDefaultSmtp=0
ShowTrayIcon=1
Log=1
SmtpListen=127.0.0.1:25
ImapListen=127.0.0.1:143
PassThrough=0
StartSmtp=1
StartPop=0
StartImap=1
UseSmtp=1
AutoSetProtection=0

BTW:
My mail-provider is GMX. I am sending via SMTP and receiving IMAP. The server needs an identification on both protocols. For both protocols I use the same username and the same password. In order to be able to send mails, also the e-mail-sender-adress has to be identical to the true e-mail adress which here is clemens.huerten@gmx.com.

In case this does matter: I have Internet access via a combined router with dsl-modem. My computer has 192.168.2.1 accessing it via the router.

Til now I am not able to use Avast! in all its features. This is unsufficient for me, because I think, it is a good virus-scanner and I planned to buy full version. But in  my view  "full-version" should mean "full function".

Did I mix up something in the settings? Any help welcome! Urgent!

Clemens

Offline radicalb21

  • Avast Evangelist
  • Poster
  • ***
  • Posts: 438
  • Be Safe. Be Smart. Use Common Sense.
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #1 on: June 10, 2004, 02:59:09 PM »
Hey Clemens_1,
     It's radicalb21. First off let me welcome you to the forum.  I would suggest taking a look a at couple of different threads authored by Technical. Here are a links to those threads:

1. Understanding avast.ini file
http://forum.avast.com/index.php?board=2;action=display;threadid=1647

2. FAQ
http://forum.avast.com/index.php?board=9;action=display;threadid=4818

I hope these links help you out.
iMac 21.5 " Mid 2011 2.7 GHz Intel Core i5
4 GB 1333 MHz DDR3
AMD Radeon HD 6770M 512 MB

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #2 on: June 10, 2004, 03:51:19 PM »
Use the Mail Protection Wizard. It will not find your accounts, but it will start the mail scanner (ashMaiSv.exe) and schedule its autostart.

Clemens_1

  • Guest
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #3 on: June 10, 2004, 11:00:03 PM »
Hello Vojtech!
I have read all the instructions in the forum concering the avast4.ini file and tried my very best but without success.

I have tried to set in the ini-file either:
[MailScanner]
DefaultSmtpServer=mail.gmx.net
while in the e-mail-client Opera M2:
Server: 127.0.0.1
username: aaabbbcc#mail.gmx.net
password:  rrrbbbyyy

or
[MailScanner]
DefaultSmtpServer=aaabbbcc#mail.gmx.net
while in the e-mail-client Opera M2:
Server 127.0.0.1
username: aaabbbcc#mail.gmx.net
password:  rrrbbbyyy

or
[MailScanner]
DefaultSmtpServer=aaabbbcc#mail.gmx.net
while in the e-mail-client Opera M2:
Server 127.0.0.1
username: mail.gmx.net
password:  rrrbbbyyy

None of these combinations did work. The e-mail client does not get access.


Hello radicalb21!
as above, I have tried the different entries in the avast4.ini file but without success.

The second thread, you have shown, I tried the ideas there:
I started the E-Mail Assistant and could set up "Internet Mail". In the Window "On Access Scanner" I can start a new window via the button 2configure"
Now there are all three tasks active: POP3, SMTP and IMAP.

In the avast4.ini file the section Mail is as the following:
[MailScanner]
DefaultSmtpServer=mail.gmx.net
DefaultPopServer=pop.gmx.net
DefaultImapServer=imap.gmx.net
UseDefaultSmtp=0
ShowTrayIcon=1
Log=1
SmtpListen=127.0.0.1:25
ImapListen=127.0.0.1:143
PassThrough=0
StartSmtp=1
StartPop=0
StartImap=1
UseSmtp=1
AutoSetProtection=0

Then I reconfigured the e-mail client with:
Server 127.0.0.1
username: aaabbbcc#mail.gmx.net
password:  rrrbbbyyy

and
Server 127.0.0.1
username: aaabbbcc#imap.gmx.net
password:  rrrbbbyyy

But again the email cleinet could not connect to the mail server.

So my question still remains:

What is wrong here???  Can anybody help me to configure this?

Clemens

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #4 on: June 11, 2004, 02:28:45 PM »
Is the process ashMaiSv.exe running or not ?

Clemens_1

  • Guest
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #5 on: June 11, 2004, 02:58:18 PM »
Thank you Vojtech for your interest and your response!

Yes, the process ashMaiSv.exe is running. If I left-click on the Avast-Icon in the systray, it shows me all the services and the Internet / Mail-Sertvice is shown as active. I can configure it from there.

The main question here is:
Is Avast! able to connect with the mailserver and log in there in order to fetch e-mails?

I think, it cannot, beacause for logging in at gmx you will have to enter a username and a password. In the describtion of Avast! help and the thread about avast4.ini I only could see, that they log in with username#mail.server.com

Or is it the e-mail client Opera M2, which perhaps is not able to correspond properly with avast via the 127.0.0.1.
Or is it Opera M2 which cannot submit password after Avast has begun with login and by this the login procedure will not be completed.

I don't see a feature, to switch on something like a login or a connection protocoll, so that I can see, at which part things get wrong!

In Opera M2 as in other mail clients I can fill in username, password and of course the mailserver (SMTP and POP3 / IMAP). In Avast! I only can fill in username#mailserver...

As I allready have posted, I tried all the possible combinations and none did work! As far as I understand, it should work properly, if I set mail.server.com in avast4.ini and then set the account in the mail client with server = 127.0.0.1 andfill in in Username the username#mail.server.com and password.

Is that right?

Clemens

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9407
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #6 on: June 11, 2004, 03:35:24 PM »
Don't edit avast4.ini since you'll mess everything.

Just edit Opera M2 settings like on this picture (i also use Opera's M2 :) )
Visit my webpage Angry Sheep Blog

Clemens_1

  • Guest
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #7 on: June 11, 2004, 04:06:31 PM »
Hello RejZoR!

Thank you for your screenshot. Looks very much like I have set up here, but instead of localhost I typed 127.0.0.1. I think it is the same, isn't it?

And in Avast I will remove all my settings but those, which came from Avast! by using the Mail Protection Wizzard. That means corresponding to my pervious postings, that I will remove all lines in the section [MailScanner] from Log=1, is that true?

While you can read this, I will go and try this.

Thank you!

Clemens

Clemens_1

  • Guest
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #8 on: June 11, 2004, 04:16:59 PM »
Sorry RejZoR, it did not work!

See attached Screenshot of Opera M2 account. The only difference is, that I am using IMAP instead of POP3. Perhaps is this the reason for my probs?


And here the MailScanner Scection in avast4.ini

[MailScanner]
DefaultSmtpServer=mail.gmx.net
DefaultPopServer=pop.gmx.net
DefaultImapServer=imap.gmx.net
SmtpListen=127.0.0.1
ImapListen=127.0.0.1
PassThrough=0
StartSmtp=1
StartPop=0
StartImap=1
UseSmtp=1
AutoSetProtection=0

Do you have set up something different here?

Clemens

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #9 on: June 11, 2004, 05:20:25 PM »
I see no errors in your account setup. You can look into file Avast4\DATA\log\aswMaiSv.log for problems.

Clemens_1

  • Guest
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #10 on: June 11, 2004, 06:00:58 PM »
Hello Vojtech!

I have checked the aswMaiSv.log
In it there are all my changes logged, which I made in avast4.ini.

At the beginning there were the following lines, which were generated on computer start up this morning:

06/11/04 08:19:25:   Started
06/11/04 08:19:25:   Build 4.1.412
06/11/04 08:19:25:   Using WinSock 2.0
06/11/04 08:19:25:   WSAAccept not loaded

In the last line... is this OK? I don't know what "WSAAccept" really means.

Further:
If now all the settings in my Opera M2 mail client are OK, so only avast4.ini remains as a source for my problems.
Please which lines should be there and which not. Are there some missing?

I quote again, what is in my MailScanner section:
[MailScanner]
DefaultSmtpServer=mail.gmx.net
DefaultPopServer=pop.gmx.net
DefaultImapServer=imap.gmx.net
SmtpListen=127.0.0.1
ImapListen=127.0.0.1
PassThrough=0
StartSmtp=1
StartPop=0
StartImap=1
UseSmtp=1
AutoSetProtection=0

Sorry in case I am making someone crazy with this. But as you see, it is simply NOT trivial!

Clemens

Clemens_1

  • Guest
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #11 on: June 11, 2004, 07:34:16 PM »
Hello Vojtech -- Hello RejZoR!

Now I have focussed completeley on avast4.ini file. I have checked one more time step by step and line by line all in teh section MailScanner. Now my avast4.ini lokks like this:

[MailScanner]
DefaultSmtpServer=mail.gmx.net
DefaultPopServer=pop.gmx.net
DefaultImapServer=imap.gmx.net
SmtpListen=127.0.0.1:25
ImapListen=127.0.0.1:143
PassThrough=0
StartSmtp=1
StartPop=0
StartImap=1
UseDefaultSmtp=0
AutoSetProtection=0
ShowTrayIcon=1
Log=20

By the line Log=20 I get everything in the aswMaiSv.log

Then I started my mail-client to connect, but it failed again.
Then I opened the aswMaiSv.log to find out what is going wrong here and I found the following:

06/11/04 19:20:48:   IMAP accept connection from: 127.0.0.1
06/11/04 19:20:48:   --XXX sleep
06/11/04 19:20:48:   ->IMAP 518 CAPABILITY
06/11/04 19:20:48:   <-IMAP * CAPABILITY IMAP4 IMAP4rev1
518 OK CAPABILITY Completed
06/11/04 19:20:48:   --XXX sleep
06/11/04 19:20:48:   ->IMAP 519 AUTHENTICATE CRAM-MD5
06/11/04 19:20:48:   <-IMAP 519 NO AUTHENTICATE not supported, use LOGIN command
06/11/04 19:20:48:   --XXX sleep
06/11/04 19:20:48:   --XXX sleep
06/11/04 19:20:48:   --XXX sleep
06/11/04 19:20:48:   ->IMAP LOGIN 222333444#imap.gmx.net
06/11/04 19:20:48:   Connected to IMAP server imap.gmx.net 143
06/11/04 19:20:48:   --XXX sleep
06/11/04 19:20:49:   --XXX sleep
06/11/04 19:20:49:   <-IMAP * OK GMX IMAP4 StreamProxy ready.
06/11/04 19:20:49:   --XXX sleep
06/11/04 19:20:49:   --XXX sleep
06/11/04 19:20:49:   --XXX sleep
06/11/04 19:20:49:   --IMAP CATCH 5(0x00000005)
06/11/04 19:20:49:   --IMAP Finishing connection handler

BTW: GMX wants that you close the connection after you have finished all transactions. In Outlook there has been a control box option where I could activate this "closing".

Does anybody know what is going on here? What is going wrong?

Clemens

Clemens_1

  • Guest
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #12 on: June 11, 2004, 07:57:18 PM »
Hello!

I just could achieve one more step:

I wondered about the lines

524 OK CAPABILITY Completed
06/11/04 19:30:48:   --XXX sleep
06/11/04 19:30:48:   ->IMAP 525 AUTHENTICATE CRAM-MD5
06/11/04 19:30:48:   <-IMAP 525 NO AUTHENTICATE not supported, use LOGIN command
06/11/04 19:30:48:   --XXX sleep

in the log-file.

So I changed the mail-client account from Authentication = "Auto" to "Plaintext"

The result in the log-file:
06/11/04 19:43:16:   IMAP accept connection from: 127.0.0.1
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   ->IMAP 530 CAPABILITY
06/11/04 19:43:16:   <-IMAP * CAPABILITY IMAP4 IMAP4rev1
530 OK CAPABILITY Completed
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   ->IMAP LOGIN 222333444#imap.gmx.net
06/11/04 19:43:16:   Connected to IMAP server imap.gmx.net 143
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   <-IMAP * OK GMX IMAP4 StreamProxy ready.
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   --XXX sleep
06/11/04 19:43:16:   --IMAP CATCH 5(0x00000005)
06/11/04 19:43:16:   --IMAP Finishing connection handler

So it seems it logs in directly and not after a first unsuccessfull try.

Next: I only see, that Avast proxy is connecting properly to IMAP mail server  at gmx, upon a reuqest via 127.0.0.1, but I don't see, that the mail client is using / able to use this connection! This is strange!
And because the mail client can't use the connection, it will not go on with the data exchange and try SMTP sending also. It simply tells that it cannot access IMAP.

So we are one big step towards a solution but still not there ;-)

Any help greatly welcome!!!

Clemens

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:Please Help! Can't get Avast! Pro to run as an e-mail proxy
« Reply #13 on: June 16, 2004, 11:19:30 AM »
Please try this version: http://www2.asw.cz/~peterka/4.1.418/ashMaiSv_2.exe
Copy the file to avast4 folder, terminate process ashMaiSv.exe and start this new file.