Author Topic: avast webshield and firefox  (Read 10262 times)

0 Members and 1 Guest are viewing this topic.

TheRebel

  • Guest
avast webshield and firefox
« on: January 22, 2010, 12:55:57 AM »
Just now I downloaded eicar test file to see how avast web shield responds to it, and its behavior was quite strange. :o

On clicking eicar, avast web shiled alert pops up saying "Connection Aborted", but I still get the option to download eicar test file (please see attached image 1)

Is anyone else facing the same problem with firefox?

Because it is working perfectly with Internet Explorer, on clicking eicar, avast web shield alert popped up and did abort the connection as well.

Hermite15

  • Guest
Re: avast webshield and firefox
« Reply #1 on: January 22, 2010, 01:20:39 AM »
that sounds almost impossible...more like you did a first test with web shield on, making the alert sticky while attempting a new download with web shield off...OK I may be wrong and there could be a bug but I seriously doubt it, never seen this happen. Would be good if a dev could come to this thread...

TheRebel

  • Guest
Re: avast webshield and firefox
« Reply #2 on: January 22, 2010, 01:24:01 AM »
that sounds almost impossible...more like you did a first test with web shield on, making the alert sticky while attempting a new download with web shield off
:o why would I do this?
Do u use firefox?
You can try it yourself...

And as I mentioned in my above post, avast web shield worked perfectly with IE, it did abort the connection in IE.


Hermite15

  • Guest
Re: avast webshield and firefox
« Reply #3 on: January 22, 2010, 01:27:06 AM »
Quote
You can try it yourself...
yeah, that's the problem, I got an expected behavior of the webshield in Firefox  ;D connection is aborted, nothing else. May be an interference of another security software that you use...
« Last Edit: January 22, 2010, 01:29:00 AM by Logos »

TheRebel

  • Guest
Re: avast webshield and firefox
« Reply #4 on: January 22, 2010, 01:28:59 AM »
Quote
You can try it yourself...
yeah, that's the problem, I got an expected behavior of the webshield in Firefox  ;D connection is aborted, nothing else.

Good...  ;D
But at my end avast web shield shows a pop up saying connection aborted but still I get the option to download the file  :'(

Hermite15

  • Guest
Re: avast webshield and firefox
« Reply #5 on: January 22, 2010, 01:30:52 AM »
Quote
You can try it yourself...
yeah, that's the problem, I got an expected behavior of the webshield in Firefox  ;D connection is aborted, nothing else.

Good...  ;D
But at my end avast web shield shows a pop up saying connection aborted but still I get the option to download the file  :'(

look, may be there's a bug with V5 in XP that doesn't happen in Win7...let's just wait until a dev comes around here and have a look at the issue, this is really weird...

TheRebel

  • Guest
Re: avast webshield and firefox
« Reply #6 on: January 22, 2010, 01:32:46 AM »
look, may be there's a bug with V5 in XP that doesn't happen in Win7...let's just wait until a dev comes around here and have a look at the issue, this is really weird...

Yes, could be a reason. Coz you're using Windows 7 may be that's why it showed the expected behavior.
And yep you're right, lets wait...

Hermite15

  • Guest
Re: avast webshield and firefox
« Reply #7 on: January 22, 2010, 11:24:01 AM »
bump...
I'd really like to know how this could happen...

disPlay

  • Guest
Re: avast webshield and firefox
« Reply #8 on: January 22, 2010, 11:50:22 AM »
This is really strange.

pete319

  • Guest
Re: avast webshield and firefox
« Reply #9 on: January 22, 2010, 12:30:10 PM »
Hi all

I downloaded eicar test file and when i clicked on it, I was alerted malware blocked and the connection was aborted.

I am using Firefox 3.6 with windows xp Home Sp3

Don't mean to interfere, but thought i would test it on my system. :-[

TheRebel

  • Guest
Re: avast webshield and firefox
« Reply #10 on: January 22, 2010, 07:54:47 PM »
I thought it was a little bug in avast, but it seems only I'm facing this problem  :'( of avast web shield with firefox, though it is working perfectly with Internet explorer...

Offline RZPogi

  • Sr. Member
  • ****
  • Posts: 238
Re: avast webshield and firefox
« Reply #11 on: January 22, 2010, 08:08:11 PM »
Just now I downloaded eicar test file to see how avast web shield responds to it, and its behavior was quite strange. :o

On clicking eicar, avast web shiled alert pops up saying "Connection Aborted", but I still get the option to download eicar test file (please see attached image 1)

Is anyone else facing the same problem with firefox?

Because it is working perfectly with Internet Explorer, on clicking eicar, avast web shield alert popped up and did abort the connection as well.

But did you click the link? Upon clicking the link, the download won't run.
DESKTOP: Win 10, Avast 20 Free, Windows firewall, Malwarebytes free

LAPTOP: Win 10, Windows Defender, Malwarebytes free, Windows Firewall, Mcshield

Hermite15

  • Guest
Re: avast webshield and firefox
« Reply #12 on: January 22, 2010, 08:33:05 PM »
you have stream scanning activated in web shield settings ?... there might be a bug there, especially with Firefox.

TheRebel

  • Guest
Re: avast webshield and firefox
« Reply #13 on: January 22, 2010, 08:48:26 PM »
Just now I downloaded eicar test file to see how avast web shield responds to it, and its behavior was quite strange. :o

On clicking eicar, avast web shiled alert pops up saying "Connection Aborted", but I still get the option to download eicar test file (please see attached image 1)

Is anyone else facing the same problem with firefox?

Because it is working perfectly with Internet Explorer, on clicking eicar, avast web shield alert popped up and did abort the connection as well.


But did you click the link? Upon clicking the link, the download won't run.


yes, this is the problem. I clicked the link. Avast web shield alert popped up saying connection aborted, but still I could download the file... (kindly see attached image in my first post)

TheRebel

  • Guest
Re: avast webshield and firefox
« Reply #14 on: January 22, 2010, 08:51:36 PM »
you have stream scanning activated in web shield settings ?... there might be a bug there, especially with Firefox.

Are you talking about "Use Intelligent Steam Scanning"? Yes it is checked (see attached image)