Author Topic: AVAST free 5.377 memory bug  (Read 7359 times)

0 Members and 1 Guest are viewing this topic.

Offline Cako

  • Full Member
  • ***
  • Posts: 160
AVAST free 5.377 memory bug
« on: January 23, 2010, 01:25:58 AM »
After installing the final version of AVAST 5 free antivírus end I've had memory problems.
after a time avast delay scan of the Internet and the pages and sounds of the pc are stopping and slower.
I need to restart the pc or disable all modules and enable again.
I tried reinstall and the bug continues.
the avast 4.8 dont has this bug
i have 1 GB of memory end pentium 4 processor with 3.2 end windows XP SP2
I think it's something related to the cache memory of AVAST
it consumes a lot of memory after a few hours on the pc using the internet browser
I use firefox 3.6 and internet explorer 8
Excuse my English...
FIX THIS.......
« Last Edit: January 30, 2010, 12:14:13 AM by Cako »

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #1 on: January 27, 2010, 04:11:05 PM »
i find the problem......
happens when I open several tabs in Firefox or IE8.
many people are having the same problem in Brazil.
do this test.
open your browser, then open 8 or more tabs and leave the pages loading So long as you hears music or movie.
you will see how avast slow the computer while he does scan.
ALWIL,Version 5.0.377 is the final or beta ....?????
FIX THIS............
« Last Edit: January 28, 2010, 01:10:23 AM by Cako »

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8786
Re: AVAST free 5.377 memory bug
« Reply #2 on: January 27, 2010, 04:16:06 PM »
I see you are still running Windows Service Pack 2 so you should install Windows Service Pack 3 that has been available for over a year and a half that contains several Critical Security updates plus performance improvements.

Also you should enable Automatic Updates or at least be notified that Updates are available.

Go to Control Panel then Automatic Updates then select Automatic (recommended) or at least Notify me but don't automatically download or install them.

Download and install:
User Profile Hive Cleanup Service:
Brief Description
A service to help with slow log off and unreconciled profile problems.
http://www.microsoft.com/downloads/details.aspx?familyid=1B286E6D-8912-4E18-B570-42470E2F3582&displaylang=en

Go to Secunia Online Software Inspector then run it to see what other applications are vulnerable:
http://secunia.com/vulnerability_scanning/online
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #3 on: January 27, 2010, 04:24:41 PM »
YoKenny Thanks.
my conf. is good
windows xp sp2 ( I dont upgrade because my audio driver is not compatible.)
1Giga memory RAM
Processor pentium 4 (3.2)
this problem does not happen in version 4.8
when avast scans very pages at the same time it leaves the computer very slow after some time.
to return to normal I need to disable then enable the modules again.
then the problem is solved for a few hours.
its not my computer memory its the avast 5.

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8786
Re: AVAST free 5.377 memory bug
« Reply #4 on: January 27, 2010, 07:01:29 PM »
What is the audio driver?
What chipset provides audio?

Use the Belarc Advisor to provide more information
Quote
The Belarc Advisor builds a detailed profile of your installed software and hardware, missing Microsoft hotfixes, anti-virus status, CIS (Center for Internet Security) benchmarks, and displays the results in your Web browser. All of your PC profile information is kept private on your PC and is not sent to any web server.
http://www.belarc.com/free_download.html
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #5 on: January 27, 2010, 11:18:04 PM »
What is the audio driver?
What chipset provides audio?

Use the Belarc Advisor to provide more information
Quote
The Belarc Advisor builds a detailed profile of your installed software and hardware, missing Microsoft hotfixes, anti-virus status, CIS (Center for Internet Security) benchmarks, and displays the results in your Web browser. All of your PC profile information is kept private on your PC and is not sent to any web server.
http://www.belarc.com/free_download.html
I upgrade sp2 to sp3, but the problem continues.
the shield of avast is not well optimized.
it slow the computer when it has to scan many pages.
this is a bug of avast 5.0.377.
thanks.....YoKenny...

Offline Mr.Agent

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2769
  • Proud to be an avast! user.
Re: AVAST free 5.377 memory bug
« Reply #6 on: January 27, 2010, 11:18:33 PM »
Did you try 5.0.394 ?

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #7 on: January 27, 2010, 11:27:35 PM »
Did you try 5.0.394 ?
no.
its not official.
build 394 is indeed unreleased yet
http://forum.avast.com/index.php?topic=54128.0

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83791
  • No support PMs thanks
Re: AVAST free 5.377 memory bug
« Reply #8 on: January 28, 2010, 12:54:01 AM »
Well you can either wait or try the pre-release, you should at least read that topic as many that had an issue have found it resolved it. The more that try it and report their findings, the sooner it will be released.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.598) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #9 on: January 28, 2010, 01:09:29 AM »
Well you can either wait or try the pre-release, you should at least read that topic as many that had an issue have found it resolved it. The more that try it and report their findings, the sooner it will be released.
I found ..
I was wrong, it is not ram memory, avast its consuming a lot processor power .....
perhaps ram memory and processor.
avast antivirus is the best in the world, but they have fix it.
the version 5.0.377 seems a beta.... >:(

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83791
  • No support PMs thanks
Re: AVAST free 5.377 memory bug
« Reply #10 on: January 28, 2010, 01:25:35 AM »
On the contrary, for me both memory and CPU usage is less than 4,8, see image, this taken whilst completing this post. So there is something else going on, whilst browsing downloading, P2P, etc. avast will be scanning so there will be peaks in processor usage, that is normal and it should return quite quickly to normal levels.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.598) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #11 on: January 28, 2010, 02:10:00 PM »
On the contrary, for me both memory and CPU usage is less than 4,8, see image, this taken whilst completing this post. So there is something else going on, whilst browsing downloading, P2P, etc. avast will be scanning so there will be peaks in processor usage, that is normal and it should return quite quickly to normal levels.
I do not make anything on my computer only surf on internet.
the avast makes everything slow surfing.
my avastUI.exe its 6,920k  end avastSvc.exe is 27,400k
its good numbers,and still remains the problem.
these numbers are about RAM and not CPU.
I think it's the processor (CPU),avast can not use less processor when iam using the internet browser with many open tabs.
I hope this guy named VLK bring this problem to engineers of avast for it to be solved,many users are having this problem with this version and are going back to 4.8
version 5.0.377 its unstable....end have many bugs..
Excuse my English..... ::)

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 83791
  • No support PMs thanks
Re: AVAST free 5.377 memory bug
« Reply #12 on: January 28, 2010, 04:15:13 PM »
Have a look at my image again (click to expand) and you will see at the time I was posting there was 00% CPU usage by the avast processes.

So we need to know what your were, but then again you say, "I think it's the processor (CPU),avast can not use less processor when iam using the internet browser with many open tabs." Sorry but 'I think' isn't any help to anyone and certainly won't help us to help you.

Whilst typing this I have 9 tabs open in firefox 3.5.7 and still 00% CPU and not much RAM usage.
WinXP ProSP3/ Core2Duo E8300/ 4GB Ram/ avast! free 18.5.2342/ Firefox ESR, uBlock Origin, uMatrix/ MailWasher Pro7.11.0/ DropMyRights/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security
Windows 10 Home 2004 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 20.7.2425 (build 20.7.5568.598) UI-1.0.558/ WinPatrol+/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #13 on: January 28, 2010, 04:16:20 PM »
I do not make anything on my computer only surf on internet.
the avast makes everything slow surfing.
my avastUI.exe its 6,920k  end avastSvc.exe is 27,400k
its good numbers,and still remains the problem.
these numbers are about RAM and not CPU.
I think it's the processor (CPU),avast can not use less processor when iam using the internet browser with many open tabs.
I hope this guy named VLK bring this problem to engineers of avast for it to be solved,many users are having this problem with this version and are going back to 4.8
version 5.0.377 its unstable....end have many bugs..
Excuse my English..... ::)
« Last Edit: January 28, 2010, 04:17:53 PM by Cako »

Offline Cako

  • Full Member
  • ***
  • Posts: 160
Re: AVAST free 5.377 memory bug
« Reply #14 on: January 28, 2010, 04:18:17 PM »
ho my god.
did you see,after a few hours surfing the internet my AvastSvc.exe now is in 36.700 k in memory usage and CPU using 0.8 to 11
to fix this i need disable the modules.
only by disabling the avast shield it back to normal.
so I active again and runs normal,for a few hours, then I have to disable again.
simply ridiculous.